تسجيل الدخول باستخدام حساب Microsoft
سجل الدخول أو أنشئ حسابا.
مرحباً،
حدد حسابا مختلفا.
لديك حسابات متعددة
اختر الحساب الذي تريد تسجيل الدخول باستخدامه.

ملخص

في Microsoft Excel، يمكنك استخدام ماكرو لسلسلة البيانات الموجودة في عمودين المجاورة وعرض النتيجة في العمود إلى يسار الأعمدة التي تحتوي على البيانات الخاصة بك. تحتوي هذه المقالة على نموذج Microsoft Visual Basic للتطبيقات (VBA) ماكرو (إجراء Sub) للقيام بذلك.

مزيد من المعلومات

تقدم Microsoft أمثلة برمجية للتوضيح فقط، دون أي ضمان صريح أو ضمني. هذا يتضمن، على سبيل المثال لا الحصر، الضمانات الضمنية الخاصة بالتسويق أو الملاءمة لغرض معين. تفترض هذه المقالة أنك معتاد على لغة البرمجة التي يتم شرحها والأدوات المستخدمة لإنشاء الإجراءات وتصحيحها. يساعد مهندسو الدعم لدى Microsoft شرح وظيفة إجراء محدد. ومع ذلك، لن يقوموا بتعديل هذه الأمثلة لتقديم وظيفة إضافية أو إنشاء إجراءات تستوفي متطلبات محددة.

نموذج ماكرو Visual Basic for Applications (VBA)

Sub ConcatColumns()

Do While ActiveCell <> "" 'Loops until the active cell is blank.

'The "&" must have a space on both sides or it will be
'treated as a variable type of long integer.

ActiveCell.Offset(0, 1).FormulaR1C1 = _
ActiveCell.Offset(0, -1) & " " & ActiveCell.Offset(0, 0)

ActiveCell.Offset(1, 0).Select
Loop

End Sub

ملاحظة: كشف ActiveCell.Offset (0، 1). يمكن استبدال FormulaR1C1 البيان الذي ActiveCell.Offset (0، 1). الصيغة. يمكن استخدامها بنفس القدر من النجاح إذا كنت تستخدم النص والأرقام فقط (ليس الصيغ). R1C1 المستخدمة في نهاية العبارة الأولى يشير إلى صف واحد أو عمود واحد وهو النموذج المستخدم في الأمثلة في التعليمات.

كيفية استخدام الماكرو في Microsoft Office Excel 2007

  1. افتح المصنف الذي يحتوي على البيانات.

  2. اضغط ALT + F11 لبدء تشغيل محرر Visual Basic.

  3. في القائمة إدراج ، انقر فوق الوحدة النمطية لإدراج وحدة نمطية. اكتب الماكرو في إطار التعليمات البرمجية للوحدة النمطية.

  4. من القائمة ملف ، انقر فوق إغلاق ورجوع إلى Microsoft Excel.

  5. حدد ورقة العمل التي تحتوي على البيانات التي تريدها لسلسلة.

  6. انقر فوق الخلية العليا في العمود الأيمن من البيانات التي تريد لسلسلة. على سبيل المثال، إذا احتوت الخلايا a1: a100 و b1: b100 على بيانات، انقر فوق الخلية B1.

  7. انقر فوق علامة التبويب المطور . إذا لم يتم عرض علامة التبويب المطور ، اتبع الخطوات التالية:

    1. انقر فوق زر Microsoft Office، ومن ثم انقر فوق خيارات Excel.

    2. انقر فوق شائع.

    3. انقر لتحديد خانة الاختيار إظهار علامة تبويب المطور في الشريط .

    4. انقر فوق موافق لإغلاق مربع الحوار خيارات Excel .

  8. انقر فوق وحدات ماكرو في مجموعة التعليمات البرمجية .

  9. حدد الماكرو كونكاتكولومنس، ومن ثم انقر فوق تشغيل.

كيفية استخدام الماكرو في Microsoft Office Excel 2003 وفي الإصدارات السابقة من Excel

  1. افتح المصنف الذي يحتوي على البيانات.

  2. اضغط ALT + F11 لبدء تشغيل محرر Visual Basic.

  3. في القائمة إدراج ، انقر فوق الوحدة النمطية لإدراج وحدة نمطية. اكتب الماكرو في إطار التعليمات البرمجية للوحدة النمطية.

  4. من القائمة ملف ، انقر فوق إغلاق ورجوع إلى Microsoft Excel.

  5. حدد ورقة العمل التي تحتوي على البيانات التي تريدها لسلسلة.

  6. انقر فوق الخلية العليا في العمود الأيمن من البيانات التي تريد لسلسلة. على سبيل المثال، إذا احتوت الخلايا a1: a100 و b1: b100 على بيانات، انقر فوق الخلية B1.

  7. من القائمة أدوات ، أشر إلى وحدات الماكرو، ومن ثم انقر فوق ماكرو. حدد الماكرو كونكاتكولومنس، ومن ثم انقر فوق تشغيل.

المراجع

لمزيد من المعلومات حول Visual Basic للتطبيقات، انقر فوق رقم المقالة التالي لعرضها في "قاعدة المعارف ل Microsoft":

226118 قائمة بالموارد المتوفرة لمساعدتك في التعرف على Visual Basic for Applications البرمجة

هل تحتاج إلى مزيد من المساعدة؟

توسيع المهارات
استكشاف التدريب
الحصول على الميزات الجديدة أولاً
الانضمام إلى Microsoft Insider

هل كانت المعلومات مفيدة؟

ما مدى رضاك عن جودة اللغة؟
ما الذي أثّر في تجربتك؟

نشكرك على ملاحظاتك!

×