الأعراض
عند معالجة سير عمل اتفاقية مستوى الخدمة (SLA)، يتم تسجيل الخطأ التالي في سجل Operations Manager:
اسم السجل: مصدر إدارة
العمليات: معرف الحدث الخاص بوحدة مصدر
بيانات اشتراك SMCMDB: فئة المهمة 33601
: مستوى بلا
: الكلمات الأساسية للخطأ
: المستخدم الكلاسيكي
: N/A
Computer: وصف ComputerName
:
تكوين اشتراك قاعدة البيانات غير صحيح.
تمت مصادفة الأخطاء التالية:
رسالة الاستثناء: خطأ تكوين الاشتراك. حدث خطأ أثناء قراءة عنصر TargetType. رسالة خطأ: تم تحديد سمة TargetType غير صحيحة. يجب أن يكون معرف نوع الهدف 9bc85fd0-934c-bfdb-9643-63779a0f3742 نوع أساس تجريدي أو أول نوع أساسي غير مجرد.
تأثر اشتراك واحد أو أكثر بذلك.
اسم الاشتراك: اسم مثيل WorkflowSubscription_9d183789_7944_49f2_b5fe_2d8f77ad6ddc
: هدف سير عمل SLA: معرف مثيل DisplayName
: {69CBC824-AA85-B123-58C3-A46F97E54BF7}
مجموعة الإدارة: ManagementGroup
السبب
قد تحدث هذه المشكلة عند تكوين هدف مستوى الخدمة (SLO) لاستخدام فئة مشتقة. على سبيل المثال، افترض أنك تنشئ فئة جديدة تستند إلى فئة طلب الخدمة وتسمى SRNewClass. عند إنشاء هدف مستوى الخدمة، ثم تحديد SRNewClass من قسم "الفئة" على علامة التبويب "عام" في المعالج، يتم إرجاع معرف الحدث 33601 أثناء عملية سير العمل.
الحل
عند إنشاء SLO أو تكوينه، حدد الفئة الأساسية التي يتم اشتقاق الفئة الجديدة منها (على سبيل المثال، طلب الخدمة). في قسم "قوائم الانتظار" في معالج إنشاء هدف مستوى الخدمة، حدد قائمة انتظار معينة حيث تريد توجيه طلبات خدمة الفئة المخصصة هذه.
مزيد من المعلومات
لأغراض الاختبار، قم بإنشاء طلب خدمة جديد باستخدام فئة SRNewClass، ثم قم بتعيينه إلى قائمة الانتظار المحددة في SLO. سيتم تطبيق مستوى الخدمة على هذا الطلب لأنه في أساسه، هو طلب خدمة. باستخدام قائمة الانتظار وفئة قاعدة طلبات الخدمة في هدف مستوى الخدمة، يمكنك السماح بتطبيق مستوى الخدمة على أي طلب خدمة تم تعيينه إلى قائمة الانتظار المحددة.