الأعراض
تمكين اتصال RDP يحاول "ريموتيفكس" فشل "ملقم المحطة الطرفية"، مما يؤدي إلى الخطأ التالي على العميل:
"قطع الكمبيوتر البعيد اتصال جلسة العمل بسبب خطأ في بروتوكول الترخيص. الرجاء محاولة الاتصال بالكمبيوتر البعيد مرة أخرى أو اتصل بمسؤول الملقم. "
ملقم المحطة الطرفية تسجيل الحدث التالي:
معرف الحدث: 1152
المصدر: تيرمينالسيرفيسيس-ريموتيكوننيكتيونماناجير
الرسالة: الملقم "المضيف الوضع الظاهري لسطح المكتب البعيد" لا يمكن إصدار ترخيص لعميل. أنه غير قادر على إصدار الترخيص وجود ترخيص عميل تم تغييرها (غير متطابق)، ذاكرة كافية أو خطأ داخلي.
السبب
تحدث هذه المشكلة عند استخدام أمان RDP القياسية بواسطة العميل للاتصال بخادم "ريموتيفكس".
يمكن أن يحدث هذا الحالات التالية:
-
العميل تطبيق مخصص باستخدام عنصر التحكم النشط "سطح المكتب البعيد". يستخدم عنصر التحكم هذا أمان RDP القياسية بشكل افتراضي.
-
العميل هو الطرف الثالث أو عميل سطح المكتب البعيد في Windows التي تم تكوينها لاستخدام معيار أمان RDP. Windows XP SP3 والعملاء "سطح المكتب البعيد" أحدث استخدام أمان RDP محسنة بشكل افتراضي ولا يحمل هذه المشكلة. أنظمة تشغيل أقدم العميل استخدام أمان RDP القياسية بشكل افتراضي، وسوف يحمل الأعراض المذكورة في هذه المقالة.
الحل
يجب تكوين العميل لاستخدام الأمان المحسن RDP.
إذا كان العميل تطبيق مخصص باستخدام عنصر تحكم ActiveX سطح المكتب البعيد، يجب استخدام الحد الأدنى من التحكم الإصدار IMsRdpClientAdvancedSettings4 واجهة العميل وتعيين الخاصية AuthenticationLevel إلى 1 أو 2 (القيمة الافتراضية هي 0).
أمان محسن MSTSC.exe قيد التشغيل يمكنك حل هذه المشكلة الترخيص باستخدام RDP عملاء Windows XP SP2 (بتحديد القائمة المنسدلة "محاولة المصادقة" في خصائص علامة التبويب الأمان للعميل "الاتصال بسطح المكتب البعيد".