ملاحظة: توثق هذه المقالة حل مشكلة معروفة موثقة على صحة إصدار Windowsومركز إدارة Microsoft.
الأعراض
قد تواجه مجموعة فرعية صغيرة من عملاء Azure Virtual Desktop الذين يستخدمون مضيفين متعددي الجلسات (AVD) وقاموا بتثبيت Windows التحديثات تم إصدارها بين 23 يوليو 2024 (KB5040525) و8 أكتوبر 2024 (KB5044273) المشكلات التالية:
-
تعليق ممتد من 10 إلى 30 دقيقة على شاشة سوداء بعد تسجيل دخول المستخدم.
-
تواجه تطبيقات Office بما في ذلك Outlook وTeams حالات فشل تسجيل الدخول الأحادي (SSO)، مما يمنع المستخدمين من توصيل البيانات أو مزامنتها.
السبب
تحدث هذه المشكلة بسبب توقف تام في التفاعلات بين وسيط Azure Active Directory (AAD) وخدمة توزيع AppX الأساسية (AppxSvc) وخدمة البنية الأساسية لمهام الخلفية. من المرجح أن تواجه هذه المشكلة إذا كنت تستخدم حاويات ملف تعريف مستخدم FSLogix في بيئات متعددة الجلسات. FSLogix هو أداة Microsoft تساعد في إدارة ملفات تعريف المستخدمين وتسريعها على أجهزة الكمبيوتر، خاصة في البيئات الظاهرية مثل أجهزة سطح المكتب البعيدة.
من غير المحتمل أن يواجه مستخدمو الإصدار Windows 10 Education والمستخدمون المنزليون لنظام Windows الذين يستخدمون إصدارات Home أو Pro هذه المشكلة حيث يتم استخدام Azure Virtual Desktop بشكل أكثر شيوعا في بيئات المؤسسة.
الدقة
لحل هذه المشكلة، قم بتطبيق أحد الخيارات التالية إذا لاحظت معرف حدث Microsoft-Windows-AppModel-State 10 في سجل أحداث التطبيق بالتوقيع التالي،
-
الوصف: فشل تحميل إعدادات التطبيق Microsoft.AAD.BrokerPlugin_cw5n1h2txyewy الحزمة
-
رمز الخطأ: -2147024893
الخيار 1: إعادة تصوير الجهاز المتأثر
اتبع هذه الخطوات لإنشاء صورة مخصصة جديدة باستخدام أحدث صورة معرض "Windows 10 Enterprise متعددة الجلسات، الإصدار 22H2" من Azure Marketplace:
-
انتقل إلى microsoft Azure Marketplace. في شريط البحث Search Marketplace، اكتب Microsoft Windows 10.
-
في صفحة Microsoft Windows 10، انقر فوق الحصول عليه الآن.
-
سجل الدخول بمجرد مطالبتك بإدخال عنوان بريدك الإلكتروني.
-
في صفحة إنشاء هذا التطبيق في Azure، حدد Windows 10 Enterprise متعدد الجلسات، الإصدار 22H2 من القائمة المنسدلة خطة البرنامج.
-
بعد تحديد الصورة، انقر فوق إنشاء لإنشاء جهاز ظاهري جديد.
-
اتبع هذه الخطوات في صفحة إنشاء صورة ذهبية في Azure:
-
إنشاء صورة من جهاز Azure الظاهري لإنشاء الصورة المخصصة.
-
قم بتخصيص الجهاز الظاهري ثم قم بتثبيت Windows Update 24 أكتوبر 2024 (KB5045594).
-
-
يمكنك الآن إعادة تصوير جهاز AVD المتأثر باستخدام الصورة المخصصة التي تم إنشاؤها حديثا من الخطوة 6.
ملاحظه إذا كنت تريد صورة تتضمن KB5045594 الإصلاح لهذه المشكلة، يتعين عليك الانتظار حتى 19 نوفمبر 2024 لإعادة تصوير جهازك (لتجنب الخطوة 6).
الخيار 2: تثبيت KB5045594 تحديث Windows وإضافة البرنامج النصي لتسجيل دخول المستخدم
-
قم بإجراء ترقية موضعية للجهاز المتأثر مع تحديث Windows 10، الإصدار 22H2 (KB5045594).
-
بعد تثبيت تحديث Windows (KB5045594)، بالنسبة للمستخدمين الذين ليس لديهم برنامج نصي لتسجيل الدخول موجود، قم بإنشاء ملف برنامج نصي PowerShell جديد (.ps1) ثم أضف أمر PowerShell المذكور أدناه:
Add-AppxPackage -Register -Path "C:\Windows\SystemApps\Microsoft.AAD.BrokerPlugin_cw5n1h2txyewy\AppxManifest.xml" -DisableDevelopmentMode
-
إذا كان لديك بالفعل برنامج نصي لتسجيل الدخول موجود يستخدم برنامج PowerShell النصي في نهج المجموعة، يمكنك إضافة أمر PowerShell المذكور في الخطوة 2 إلى برنامج PowerShell النصي الحالي.
-
لاستخدام هذا البرنامج النصي لتسجيل الدخول الذي تم إنشاؤه حديثا على أجهزة AVD المرتبطة بمعرف Hybrid Entra أو المرتبطة بالمجال، اتبع الخطوة 5 في قسم تعيين البرنامج النصي لتسجيل دخول المستخدم .
-
لاستخدام هذا البرنامج النصي لتسجيل الدخول الذي تم إنشاؤه حديثا على أجهزة AVD المرتبطة بمعرف Entra فقط، اتبع الخطوة 5 في قسم تعيين البرامج النصية لتسجيل دخول المستخدم.
-
-
إذا كان لديك برنامج نصي لتسجيل الدخول موجود بتنسيق آخر غير PowerShell، مثل ملف .bat أو .cmd، يمكنك القيام بما يلي
-
إنشاء ملف برنامج نصيPowerShell.ps1 جديد وإضافة أمر PowerShell المذكور في الخطوة 2.
-
بعد ذلك، أضف أحد الأوامر التالية إلى ملف .bat أو .cmd لتنفيذ البرنامج النصي:
-
مثال باستخدام نموذج مسار SYSVOL: powershell -File "scripts\script.ps1"
-
مثال باستخدام نموذج مسار محلي: powershell -File "D:\scripts\script.ps1"
-
-
الحصول على مساعدة إضافية
للحصول على أي مساعدة إضافية حول هذه المشكلة، نوصي بإرسال طلب دعم إلى دعم Azure.
المراجع
وصف المصطلحات القياسية المستخدمة لوصف تحديثات برامج Microsoft