Съобщение

Преработено на 8.6.2021 г.

На 8 юни 2021 г. тази актуализация е издадена, за да замести предишна актуализация, за да се отговори на грешка "сървърът за отмяна е офлайн", която може да възникне по време на инсталирането. Ако вече сте инсталирали предишно издание на тази актуализация, не се изисква действие. За да получите най-новата версия на тези актуализации, вижте раздела "Как да получите и инсталирате актуализацията" на отделната статия за актуализация.  Връзки към всяка статия се намират в раздела "Допълнителна информация за тази актуализация" на тази статия.

На 13 април 2021 г. тази актуализация е издадена, за да замести предишното издание на тази актуализация.

На 23 юли 2020 г. актуализирайте KB4552952 v2 и KB4552951 v2, за да заместите v1 от тези актуализации за .NET Framework (платформа) 4.5.2 и 4.6 за Windows Server 2008 SP2. Актуализациите на v1 не се инсталират за клиенти, които са имали определени конфигурации на ESU.  Актуализациите на v2 коригират проблема за клиенти, които не могат да инсталират актуализациите на v1.  

Отнася се за:

Microsoft .NET Framework (платформа) 2.0 Microsoft .NET Framework (платформа) 3.0 Microsoft .NET Framework (платформа) 4.5.2 Microsoft .NET Framework (платформа) 4.6

ВАЖНО Уверете се, че сте инсталирали задължителните актуализации, изброени в раздела Как да получите тази актуализация,преди да инсталирате тази актуализация.

ВАЖНО Файловете на кабината за сканиране на WSUS ще продължат да са налични за Windows Server 2008 SP2. Ако имате подмножество от устройства, на които се изпълнява тази операционна система без ESU, те може да се показват като несъответстващи на вашите набори инструменти за управление на корекции и съответствие.

ВАЖНО Клиентите, които са закупили разширена актуализация на защитата (ESU) за локални версии на тази операционна система, трябва да следват процедурите в KB4522133, за да продължат да получават актуализации на защитата, след като разширената поддръжка приключи на 14 януари 2020 г. За повече информация относно ESU и кои издания се поддържат, вижте KB4497181.

ВАЖНО От август 2019 г. актуализациите на .NET Framework (платформа) 4.6 и по-нови, за Windows Server 2008 SP2 се изисква поддръжка за подписване на SHA-2 код. Уверете се, че имате всички най-нови актуализации Windows, преди да приложите тази актуализация, за да избегнете проблеми с инсталирането. За по-подробна информация относно актуализациите на поддръжката за подписване на код SHA-2 вж. KB 4474419.

ВАЖНО Всички актуализации за .NET Framework (платформа) 4.7.2, 4.7.1, 4.7, 4.6.2, 4.6.1 и 4.6 изискват инсталирането на актуализацията на d3dcompiler_47.dll. Препоръчваме ви да инсталирате включената актуализация d3dcompiler_47.dll, преди да приложите тази актуализация. За повече информация относно d3dcompiler_47.dll вижте KB 4019990.

ВАЖНО Ако инсталирате езиков пакет, след като инсталирате тази актуализация, трябва да преинсталирате тази актуализация. Затова ви препоръчваме да инсталирате всички езикови пакети, които ви трябват, преди да инсталирате тази актуализация. За повече информация вижте Добавяне на езикови пакети към Windows.

Обобщена информация

В момента съществува уязвимост с увеличаване на правата.NET Framework (платформа) което може да позволи на атакуващият да издига нивото на привилегиите си. За да използва уязвимостта, първо ще трябва да получи достъп до локалния компютър и след това да изпълни злонамерена програма. Актуализацията адресира уязвимостта, като коригира как .NET Framework (платформа) активира COM обекти.  

За да научите повече за уязвимостите, отидете на следните често срещани уязвимости и експозиции (CVE).

В софтуера за отдалечено изпълнение на код .NET Framework (платформа), когато софтуерът не успее да провери изходната коректовка на файл. Хакер, който успешно е използвал уязвимостта, може да изпълни произволен код в контекста на текущия потребител. Ако текущият потребител е влязъл с администраторски права, хакер може да поеме управлението на засегнатата система. След това хакерът може да инсталира програми; преглеждате, променяте или изтривате данни; или създайте нови акаунти с пълни потребителски права. Потребителите, чиито акаунти са конфигурирани да имат по-малко потребителски права в системата, може да бъдат по-малко засегнати от потребителите, които работят с администраторски права. Използването на уязвимостта изисква потребителят да отвори специално създаден файл със засегната версия на .NET Framework (платформа). В сценарий на атака по имейл хакерът може да използва уязвимостта, като изпрати специално изработения файл на потребителя и убеди потребителя да отвори файла. Актуализацията на защитата адресира уязвимостта, като коригира как .NET Framework (платформа) проверява коректурунето на източника на файл.

За да научите повече за уязвимостите, отидете на следните често срещани уязвимости и експозиции (CVE).

Отказът на уязвимост на услугата съществува, .NET Framework (платформа) неправилно обработва уеб заявки. Хакер, който успешно е използвал тази уязвимост, може да доведе до отказ на услуга срещу .NET Framework (платформа) уеб приложение. Уязвимостта може да се използва отдалечено, без удостоверяване. Отдалечен неупълномен хакер може да използва тази уязвимост, като издаде специално изработени заявки към .NET Framework (платформа) приложение. Актуализацията адресира уязвимостта, като коригира как уеб приложението .NET Framework (платформа) обработва уеб заявки.

За да научите повече за уязвимостите, отидете на следните често срещани уязвимости и експозиции (CVE).

Известни проблеми в някои части на тази актуализация

Симптом

Тази актуализация не се инсталира и връща едното или и двете от следните съобщения за грешка:

  • -2146762495

  • Задължителният сертификат не е в рамките на срока му на валидност, когато се проверява спрямо текущия системен часовник или времевото отменено време в подписания файл.

  • Функцията за отмяна не можа да провери отмяната, защото сървърът за анулиране е офлайн.

Заобиколно решение

Този проблем е коригиран от най-новото издание на засегнатите части в тази актуализация.

Ако вече сте инсталирали предишно издание на засегнатите части, не се изисква действие.

Допълнителна информация за тази актуализация

Следващите статии съдържат допълнителна информация за тази актуализация, тъй като тя се отнася за отделни версии на продукта.

  • 4552964 Описание на актуализацията само на защитата за .NET Framework (платформа) 2.0, 3.0 за Windows Server 2008 SP2 (KB4552964)

  • 4552952 Описание на актуализацията само на защитата за .NET Framework (платформа) 4.5.2 за Windows 7 SP1 и Windows Server 2008 R2 SP1 и Windows Server 2008 SP2 (KB4552952)

  • 4552951 Описание на актуализацията само на защитата за .NET Framework (платформа) 4.6 за Windows 7 SP1 и Windows Server 2008 R2 SP1 и Windows Server 2008 SP2 (KB4552951)

Информация за защитата и защитата

Нуждаете се от още помощ?

Разширете уменията си
Преглед на обучението
Получавайте първи новите функции
Присъединете се към Microsoft приобщени

Беше ли полезна тази информация?

Доколко сте доволни от качеството на езика?
Какво е повлияло на вашия потребителски опит?

Благодарим ви за обратната връзка!

×