Преминаване към основното съдържание
Поддръжка
Влизане с Microsoft
Влезте или създайте акаунт.
Здравейте,
Изберете друг акаунт.
Имате няколко акаунта
Изберете акаунта, с който искате да влезете.

Симптоми

Да разгледаме следния сценарий:

  • Използвате Временната папка в FTP порт за изпращане на Microsoft BizTalk Server 2010.

  • Изберете подредени доставка и разрешите маршрут за неуспешни съобщения опции в страницата на Транспортния разширени опции за FTP изпращане порт.

  • Задавате стойността на представяне като двоични в диалоговия прозорец свойства на FTP транспортиране за този FTP порт за изпращане.

В този случай някои съобщения не се прехвърлят на FTP сървъра периодично. Освен това получавате следното съобщение за грешка:

Адаптерът не успя да предаде съобщението ще изпрати порт "< SendPortName >" URL адрес "< FTPAddress >". Той ще бъде препредават след повторно опитване за този порт за изпращане. Данни: "отдалечен сървърът отказва връзка към данни. Проверете разрешенията на отдалечената система. "

След като получите предишното съобщение за грешка, съобщения се направи повторен опит за изпращане на FTP сървъра според настройките на порта за изпращане. По време на опит получавате следното съобщение за грешка:

Адаптерът не успя да предаде съобщението ще изпрати порт "< SendPortName >" URL адрес "< FTPAddress >". Той ще бъде препредават след повторно опитване за този порт за изпращане. Данни: "неочаквана грешка възникна при обработка на съобщение. Текстът, свързани с изключение е "коренен елемент липсва.". "

След това съобщенията се насочват към мястото за доставка на отказ.

Забележка Този проблем е решен вече в Microsoft BizTalk Server 2013 и BizTalk Server 2013 R2.

Причина

Проблемът възниква, защото опитай в двоичен режим обърква Дизасемблер. Затова "коренен елемент липсва" грешка.

Решение

Информация за сборна актуализация

Първо този проблем е решен в следната сборна актуализация на BizTalk сървъра:

Статус

Microsoft потвърждава, че това е проблем в продуктите на Microsoft, изброени в раздела "Отнася се за".

Нуждаете ли се от още помощ?

Искате ли още опции?

Разгледайте ползите от абонамента, прегледайте курсовете за обучение, научете как да защитите устройството си и още.

Общностите ви помагат да задавате и отговаряте на въпроси, да давате обратна връзка и да получавате информация от експерти с богати знания.

Беше ли полезна тази информация?

Доколко сте доволни от качеството на езика?
Какво е повлияло на вашия потребителски опит?
Като натиснете „Подаване“, вашата обратна връзка ще се използва за подобряване на продуктите и услугите на Microsoft. Вашият ИТ администратор ще може да събира тези данни. Декларация за поверителност.

Благодарим ви за обратната връзка!

×