Преминаване към основното съдържание
Поддръжка
Влизане с Microsoft
Влезте или създайте акаунт.
Здравейте,
Изберете друг акаунт.
Имате няколко акаунта
Изберете акаунта, с който искате да влезете.

Симптоми

Да разгледаме следния сценарий:

  • Сборен пакет за актуализация 6 за Microsoft Exchange Server 2010 Service Pack 2 (SP2) или по-късно Сборен пакет за актуализация е инсталиран в среда, която съдържа множество обекти на Active Directory.

  • Сайтовете са сървърите за клиентски достъп на интернет.

  • Вътрешни и външни URL адреси са конфигурирани на сървърите за клиентски достъп на интернет.

  • Опитвате се да синхронизирате устройството на пощенска кутия с помощта на Microsoft Exchange ActiveSync (EAS).

  • Устройството изпраща EAS заявки към сървър за клиентски достъп, който не е в сайта на Active Directory, на който се намира сървъра на пощенската кутия.

В този случай устройството извлича пренасочване отговор HTTP 403 вместо очакваното HTTP 451 пренасочване отговор. След това процесът на синхронизация е неуспешно.

Освен това в регистрационния файл се записва следното събитие:

Log Name: Application Source: MSExchange ActiveSync Date: Date and Time Event ID: 1044 Task Category: Requests Level: Warning Keywords: Classic User: N/A Computer: COMPUTER Description: The Client Access server doesn't have the InternalURL value set for the Microsoft-Server-ActiveSync virtual directory. This prevents Exchange ServiceDiscovery from finding the MobileSyncService information for user MBX server . At least one Client Access server in the user's mailbox Active Directory site must have the InternalURL value set. The format for the InternalURL value is https://hostname/Microsoft-Server-ActiveSync

Бележки

  • Ако този проблем възниква в помещения само инсталация на Exchange Server 2010, запис е влязъл в регистрационните файлове на Internet Information Services (IIS). По-долу е даден пример за този запис:

    Date Time 214.21.84.142 POST /Microsoft-Server-ActiveSync/default.eas Cmd=Provision&DeviceType=DeviceType&User=user1 &DeviceId=DeviceId&Log=RdirTo:https%3a%2f%2fmail-eu.contoso.coml%2fMicrosoft-Server-ActiveSync_V25_LdapC1_Cpo19984_Fet20015_S130_Error:DiscoveryInfoMissing_Mbx:mbx1.contoso.com_Budget:(D)Conn%3a1%2cHangingConn%3a0%2cAD%3a%24null%2f%24null%2f0%25%2cCAS%3a%24null%2f%24null%2f0%25%2cAB%3a%24null%2f%24null%2f0%25%2cRPC%3a%24null%2f%24null%2f0%25%2cFC%3a%24null%2f0%2cPolicy%3aDefaultThrottlingPolicy%2cNorm_ 443 contoso\user1 192.168.0.20 UserAgent - 403 0 0 1477 523 20046

  • Можете да използвате следните регистрационни анализатор Studio заявката за идентифициране на потребителите, които са засегнати при възникването на този проблем:

    SELECT COUNT(*) AS Hits, cs-username AS UserFROM '[LOGFILEPATH]' WHERE cs-uri-query LIKE '%DiscoveryInfoMissing%'
    GROUP BY User
    ORDER BY Hits DESC



Причина

Този проблем възниква на Android и Windows Phone 8 устройства, защото устройството типове и модели, който е потвърден от структурата на DeviceCapability.RedirectDeviceTypes не съдържа типа и модела на устройството.

Този проблем възниква на Apple iOS устройства, защото заявки от iOS устройства не съдържат информация за версията на EAS или устройството низ. Следователно функцията DeviceCapability не пренасочва заявката.

Решение

За да разрешите този проблем, инсталирайте следния Сборен пакет за актуализация:

2866475 описание на сборния пакет за актуализация 2 за Exchange Server 2010 SP3

Статус

Microsoft потвърждава, че това е проблем в продуктите на Microsoft, изброени в раздела "Отнася се за".

Допълнителна информация

За повече информация относно този проблем щракнете върху следните номера на статии в базата знания на Microsoft:

2746164 описание на сборния пакет за актуализация 6 за Exchange Server 2010 Service Pack 2

2751417 синхронизирането е неуспешно, ако синхронизирате външно устройство с пощенска кутия чрез EAS в среда на Exchange Server 2010За повече информация относно регистрационния анализатор Studio посетете следния уеб сайт на Microsoft:

Обща информация за регистъра анализатор Studio 2.0
Продуктите на други разработчици, които се обсъждат в тази статия, са произведени от фирми, независими от Microsoft. Microsoft не дава никакви гаранции, подразбиращи се или от друго естество, за производителността или надеждността на тези продукти.

Нуждаете ли се от още помощ?

Искате ли още опции?

Разгледайте ползите от абонамента, прегледайте курсовете за обучение, научете как да защитите устройството си и още.

Общностите ви помагат да задавате и отговаряте на въпроси, да давате обратна връзка и да получавате информация от експерти с богати знания.

Беше ли полезна тази информация?

Доколко сте доволни от качеството на езика?
Какво е повлияло на вашия потребителски опит?
Като натиснете „Подаване“, вашата обратна връзка ще се използва за подобряване на продуктите и услугите на Microsoft. Вашият ИТ администратор ще може да събира тези данни. Декларация за поверителност.

Благодарим ви за обратната връзка!

×