Applies ToMicrosoft Dynamics CRM 2011

Симптоми

Когато имате дълъг работен поток, който съдържа изчакващи условия в Microsoft Dynamics CRM 2011, работният поток може да премине в състояние на изчакване и може да се наложи да се възобнови.

Причина

Този проблем възниква, ако условията в условието за изчакване не могат да бъдат оценени правилно, когато обектите в условието за очакване бъдат променени извън изпълнението на работния поток преди или едновременно с това е оценено условието за изчакване.

Решение

За да отстраните проблема, приложете кумулативен сбор 13 за Microsoft Dynamics CRM 2011 или по-нова версия. За повече информация щракнете върху номерата по-долу, за да видите статиите в базата знания на Microsoft:

2791312 Пакетът за актуализиране 13 за Microsoft Dynamics CRM 2011 е достъпен

2849744 Има налична актуализация на сбор 14 за Microsoft Dynamics CRM 2011

2843571 Пакетът за актуализиране 15 за Microsoft Dynamics CRM 2011 е достъпен След като приложите сборната актуализация, трябва да използвате инструмента OrgDBOrgSettings за Microsoft Dynamics CRM 2011. За повече информация относно този инструмент щракнете върху следния номер на статия, за да видите статията в базата знания на Microsoft:

2691237 OrgDBOrgSettings инструмент за Microsoft Dynamics CRM 2011 Трябва да промените настройката ActivateAdditionalRefreshOfWorkflowConditions в OrgDBOrgSettings на TRUE. Забележка Стойността по подразбиране на тази настройка е FALSE.

Състоянието

Microsoft потвърди, че това е проблем в продуктите на Microsoft, които са посочени в секцията "важи за".

Нуждаете ли се от още помощ?

Искате ли още опции?

Разгледайте ползите от абонамента, прегледайте курсовете за обучение, научете как да защитите устройството си и още.

Общностите ви помагат да задавате и отговаряте на въпроси, да давате обратна връзка и да получавате информация от експерти с богати знания.