Преминаване към основното съдържание
Поддръжка
Влизане с Microsoft
Влезте или създайте акаунт.
Здравейте,
Изберете друг акаунт.
Имате няколко акаунта
Изберете акаунта, с който искате да влезете.

Симптоми

Да разгледаме следния сценарий:

  • Използвате приложението, за да отворите изпълними файлове по мрежата от клиентски компютър, работещ под Windows 7 или Windows Server 2008 R2.

  • Това приложение се отваря повече файлове, които позволяват на опортюнистичната блокировка (oplock) по мрежата.

  • Друг процес се опитва да влезе в споделен файл, който приложението вече отворен през мрежата.

  • Сървърът изисква клиентския компютър да прекъсне опортюнистичната блокировка.

В този случай клиентския компютър не прекъсване на опортюнистичната блокировка. Затова споделен файл остава отворена на сървъра и други клиентски програми може да използва този файл.

Причина

Този проблем възниква, защото Диспечерът на паметта на клиентския компютър съдържа изпълними обекти и да ги затвори. Обаче сървърът счита изпълними обекти да бъдат затворени и използва ИД на файла за друг файл. Това води до файл ID противоречие. Затова при издаването на искането за oplock прекъсване на клиентския компютър обработва предишния обекта вместо новия файл.

Решение

Информация за актуалната корекция

Корекция на този проблем е включена в актуализация на 2732673. За да решите проблема, инсталирайте актуализация 2732673 от следната статия в базата знания на Microsoft:

2732673 "Delayed write failed" съобщение за грешка, когато .pst файловете се съхраняват на мрежов файлов сървър, работещ под Windows Server 2008 R2

Необходими условия:

За да приложите тази актуална корекция, трябва да използвате Windows 7 Service Pack 1 (SP1) или Windows Server 2008 R2 SP1.

За повече информация за придобиването на сервизен пакет за Windows 7 или Windows Server 2008 R2 щракнете върху следния номер на статия в базата знания на Microsoft:

976932 информация за Service Pack 1 за Windows 7 и Windows Server 2008 R2

Информация за системния регистър

За да приложите тази актуална корекция, не трябва да променяте нищо в системния регистър.

Изискване за рестартиране

Трябва да рестартирате компютъра, след като приложите тази актуална корекция.

Информация за заместване на актуалната корекция

Тази актуална корекция не замества издадените актуални корекции.

Статус

Microsoft потвърждава, че това е проблем в продуктите на Microsoft, изброени в раздела "Отнася се за".

Допълнителна информация

За повече информация относно терминологията за актуализация на софтуера щракнете върху следния номер на статия, за да я видите в базата данни на Microsoft:

824684 описание на стандартната терминология, използвана за описание на софтуерните актуализации на Microsoft

Нуждаете ли се от още помощ?

Искате ли още опции?

Разгледайте ползите от абонамента, прегледайте курсовете за обучение, научете как да защитите устройството си и още.

Общностите ви помагат да задавате и отговаряте на въпроси, да давате обратна връзка и да получавате информация от експерти с богати знания.

Беше ли полезна тази информация?

Доколко сте доволни от качеството на езика?
Какво е повлияло на вашия потребителски опит?
Като натиснете „Подаване“, вашата обратна връзка ще се използва за подобряване на продуктите и услугите на Microsoft. Вашият ИТ администратор ще може да събира тези данни. Декларация за поверителност.

Благодарим ви за обратната връзка!

×