Odeslání dat formuláře do databáze serveru Microsoft SQL Server

Platí pro
InfoPath 2010 InfoPath 2013

Důležité

Podpora pro Microsoft InfoPath 2013 skončila 14. července 2026. Doporučujeme, abyste stávající formuláře a pracovní postupy InfoPathu migrovali do podporovaných řešení Microsoft 365. Další informace o vyřazení InfoPathu z provozu

V tomto článku

Přehled

Při návrhu šablony formuláře, která je založená na databázi Microsoft SQL Server, povolí Průvodce datovým připojením datové připojení pro odesílání datové připojení k databázi, pokud jsou splněny následující podmínky:

  • Formuláře založené na této šabloně formuláře je nutné vyplňovat pomocí aplikace systém Microsoft Office InfoPath. Pokud bude formulář vyplňovaný ve webovém prohlížeči, nemůže formulář odesílat data přímo do databáze. Pokud chcete nakonfigurovat šablonu formuláře kompatibilní s prohlížečem tak, aby odesílala data do databáze, použijte datové připojení, které data odesílá do webové služby, která s databází spolupracuje.
  • Primární tabulka databáze použitá v hlavním datovém připojení obsahuje primární klíč, jedinečné omezení nebo jedinečný index.
  • Jakékoli další databázové tabulky, které se používají s tímto hlavním datovým připojením, mají jednoduchou relaci k primární tabulce databáze.

Pokud databáze splňuje tyto požadavky, aplikace InfoPath povolí datové připojení pro odesílání a přidá do formuláře tlačítko Odeslat na panel nástrojů Standardní a příkaz Odeslat do nabídky Soubor .

Při návrhu šablony formuláře založené na databázi můžete v průvodci zakázat datové připojení pro odesílání. Pokud datové připojení pro odesílání zakážete v průvodci a později se rozhodnete, že chcete toto datové připojení pro odesílání použít, můžete datové připojení pro odesílání povolit úpravou hlavního datového připojení. Tento článek popisuje, jak povolit toto datové připojení pro odesílání.

Poznámka

Datové připojení pro odesílání můžete mít jenom v hlavním datovém připojení k databázi. Datové připojení pro odesílání nelze přidat do šablony formuláře, která je sekundárním datovým připojením k databázi. Pokud chcete datové připojení pro odesílání použít jako sekundární datové připojení, použijte webovou službu, která spolupracuje s databází, a pak přidejte datové připojené pro odesílání k této datové službě.

Po povolení datového připojení pro odesílání můžete následujícími způsoby upravit možnosti odesílání pro šablonu formuláře:

  • Změna textu, který se zobrazuje na tlačítku Odeslat na panelu nástrojů Standardní a v příkazu Odeslat v nabídce Soubor .
  • Můžete změnit klávesovou zkratku pro tlačítko Odeslat na panelu nástrojů Standardní a příkaz Odeslat v nabídce Soubor .
  • Vytvořte vlastní zprávy, které se uživatelům zobrazí při odeslání formulářů.
  • určit, jestli má formulář po odeslání zůstat otevřený, zavřít nebo otevřít jiný prázdný formulář.

Začátek stránky

Krok 1: Povolení datového připojení pro odesílání

  1. V nabídce Nástroje klepněte na příkaz Datová připojení.
  2. V dialogovém okně Datová připojení klikněte na hlavní datové připojení a potom klikněte na Změnit.
  3. V Průvodci datovým připojením klikněte na tlačítko Další.
  4. Na další stránce průvodce zaškrtněte políčko Povolit odesílání pro toto připojení a klikněte na tlačítko Dokončit.

Začátek stránky

Krok 2: Nastavení možností odesílání

Jakmile povolíte datové připojení pro odesílání, aplikace InfoPath přidá tlačítko Odeslat na panel nástrojů Standardní a příkaz Odeslat do nabídky Soubor . Aplikace InfoPath taky nakonfiguruje formuláře založené na této šabloně formuláře tak, aby se uživatelům po odeslání vyplněných formulářů zobrazila zpráva. Ve zprávě je uvedeno, jestli byl formulář úspěšně odeslán. Ve výchozím nastavení ponechá InfoPath formuláře otevřené i poté, co je uživatelé odešlou. Chcete-li změnit text, který se zobrazí na tlačítku Odeslat , a chování formuláře po jeho odeslání uživatelem, postupujte takto:

  1. V nabídce Nástroje klepněte na příkaz Možnosti odeslání.

    1. Chcete-li změnit název tlačítka Odeslat , které se zobrazuje na panelu nástrojů Standardní , a příkazu Odeslat , který se zobrazuje v nabídce Soubor , když uživatelé vyplní formulář, zadejte nový název do pole Titulek v dialogovém okně Možnosti odeslání .

      Tip:

      Pokud chcete k tomuto tlačítku a příkazu přiřadit klávesovou zkratku, zadejte znak ampersandu (&) před znak, který chcete použít jako klávesovou zkratku. Chcete-li například přiřadit klávesovou zkratku ALT+B pro tlačítko a příkaz Odeslat , zadejte Su&bmit.

  2. Pokud uživatelům při vyplňování formuláře nechcete povolit použití příkazu Odeslat ani tlačítka Odeslat na panelu nástrojů Standardní , zrušte zaškrtnutí políček Zobrazit položku nabídky Odeslat a tlačítko Odeslat na panelu nástrojů .

    1. Ve výchozím nastavení zůstane formulář po odeslání otevřený a aplikace InfoPath zobrazí zprávu s informacemi o tom, zda byl formulář úspěšně odeslán. Chcete-li toto výchozí chování změnit, klikněte na tlačítko Upřesnit a proveďte jednu z následujících akcí:

      • Chcete-li po odeslání vyplněného formuláře uživatelem formulář zavřít nebo vytvořit nový prázdný formulář, klikněte na požadovanou možnost v rozevíracím seznamu Po odeslání .

      • Chcete-li vytvořit vlastní zprávu s informacemi o tom, zda byl formulář úspěšně odeslán, zaškrtněte políčko Použít vlastní zprávy a potom zadejte požadované zprávy do polí Při úspěchu a Při neúspěchu .

        Tip:

        Pomocí zprávy v poli Při neúspěchu uživatelům sdělte, co je třeba provést, pokud nelze formulář odeslat. Můžete uživatelům například navrhnout, aby uložili formulář a požádali o další pokyny jinou osobu.

      • Pokud nechcete, aby se po odeslání formuláře uživateli zobrazila zpráva, zrušte zaškrtnutí políčka Zobrazit zprávy o úspěšném nebo neúspěšném odeslání .

Začátek stránky