Pomocí funkce A (jedné z logických funkcí) můžete určit, jestli mají všechny testované podmínky hodnotu PRAVDA.

Příklad

Příklady funkce A

Funkce A vrátí hodnotu PRAVDA, pokud jsou všechny argumenty vyhodnoceny jako PRAVDA. Vrátí hodnotu NEPRAVDA, pokud je alespoň jeden z argumentů vyhodnocen jako NEPRAVDA.

Jedním z obvyklých způsobů použití funkce A je rozšíření užitečnosti jiných funkcí provádějících logické testy. Funkce KDYŽ například provede logický test a vrátí jednu hodnotu, pokud je test vyhodnocen jako PRAVDA, a jinou hodnotu, pokud je test vyhodnocen jako NEPRAVDA. Použijete-li funkci A jako argument podmínka funkce KDYŽ, můžete namísto jedné podmínky testovat několik různých podmínek.

Syntaxe

A(logická1;[logická2];...)

Syntaxe funkce A má následující argumenty:

Argument

Popis

Logická1

Povinný argument. První podmínka, kterou chcete testovat a která může být vyhodnocena jako PRAVDA nebo NEPRAVDA.

Logická2; ...

Nepovinný argument. Další podmínky, které chcete testovat a které mohou být vyhodnoceny jako PRAVDA nebo NEPRAVDA. Je možné použít maximálně 255 podmínek.

Poznámky

  • Argumenty musí být vyhodnotitelné jako logické hodnoty PRAVDA nebo NEPRAVDA nebo se musí jednat o matici nebo odkazy na buňky, které obsahují logické hodnoty.

  • Jestliže je argumentem matice nebo odkaz a příslušná oblast obsahuje text nebo prázdné buňky, jsou tyto hodnoty ignorovány.

  • Pokud zadaná oblast neobsahuje žádné logické hodnoty, vrátí funkce A chybu #HODNOTA!. chybu #HODNOTA!.

Příklady

Tady je několik obecných příkladů použití funkce A jako samostatné funkce a ve spojení s funkcí KDYŽ.

Příklady použití funkce KDYŽ s funkcí A

Vzorec

Popis

=A(A2>1;A2<100)

Zobrazí hodnotu PRAVDA, když je hodnota v buňce A2 větší než 1 A menší než 100, jinak zobrazí hodnotu NEPRAVDA.

=KDYŽ(A(A2<A3;A2<100);A2;”Hodnota je mimo rozsah”)

Když je hodnota menší než hodnota v buňce A3 A menší než 100, zobrazí hodnotu v buňce A2, jinak zobrazí zprávu, že je hodnota mimo rozsah.

=KDYŽ(A(A3>1;A3<100);A3;"Hodnota je mimo rozsah.")

Když je hodnota v buňce A3 větší než 1 A menší než 100, zobrazí hodnotu z buňky A3, jinak zobrazí zprávu. Text zprávy můžete nahradit zprávou podle vlastního výběru.

Výpočet bonusu

Představujeme vcelku běžný scénář, kdy je potřeba vypočítat, jestli má pracovník prodeje nárok na odměnu, pomocí funkce KDYŽ a A.

Příklad výpočtu odměny za prodej pomocí funkcí KDYŽ a A.  Vzorec v buňce E14 je =KDYŽ(A(B14>=$B$7;C14>=$B$5);B14*$B$8;0)
  • =KDYŽ(A(B14>=$B$7;C14>=$B$5);B14*$B$8;0)KDYŽ je celkový objem prodeje větší nebo roven (>=) cílovému objemu prodeje A počet zákazníků je větší nebo roven (>=) cílovému počtu zákazníků, potom se má celkový objem prodeje vynásobit % bonusu, jinak se má vrátit hodnota 0.

Potřebujete další pomoc?

Kdykoliv se můžete zeptat některého odborníka v technické komunitě Excelu nebo získat podporu v komunitě pro odpovědi.

Příbuzná témata

Video: Rozšířené funkce KDYŽ
Naučte se používat vnořené funkce ve vzorci
Funkce KDYŽ
FUNKCE NEBO
NOT (funkce)
Přehled vzorců v Excel
Jak se vyhnout nefunkční vzorce
Zjišťování chyb ve vzorcích
Klávesové zkratky v Excel
Logické funkce (odkaz)
Excel (abecední)
Excel (podle kategorie)

Potřebujete další pomoc?

Rozšiřte své znalosti a dovednosti
Projít školení
Získejte nové funkce jako první
Připojit se k programu Microsoft Insider

Byly tyto informace užitečné?

Jak jste spokojeni s kvalitou překladu?
Co ovlivnilo váš názor?

Děkujeme za váš názor!

×