Excel pro Mac zahrnuje technologii Power Query (označovanou také jako Get & Transform), která poskytuje větší možnosti při importu, aktualizaci a ověřování zdrojů dat, správě Power Query zdrojů dat, vymazání přihlašovacích údajů, změně umístění souborových zdrojů dat a tvarování dat do tabulky, která vyhovuje vašim požadavkům.  Dotaz Power Query můžete vytvořit také pomocí jazyka VBA. 

Další informace o importu dat pomocí starších konektorů najdete v tématu Import dat v Excelu pro Mac (starší verze).

Důležité informace: Tato funkce je dostupná jenom pro předplatitele Microsoft 365, kteří se zapojili do programu Office Insider. Musíte používat verzi 16.61 (build 22041701) nebo novější Excel pro Mac. Pokud máte předplatné Microsoft 365, ujistěte se, že máte nejnovější verzi Office

 V Excel pro Mac můžete data tvarovat a transformovat pomocí Editor Power Query.

Postup

  1. Vyberte Data > Načíst data (Power Query).

  2. Pokud chcete otevřít Editor Power Query, vyberte Spustit Editor Power Query.

    Nabídka příkazů Načíst data (Power Query)

    Tip: K Editor Power Query se dostanete také tak, že vyberete Získat data (Power Query), zvolíte zdroj dat a pak kliknete na Další.

  3. Data můžete tvarovat a transformovat pomocí Editor Power Query stejně jako v Excelu pro Windows.



    Editor Power Query Další informace najdete v Power Query nápovědy k Excelu.

  4. Až budete hotovi, vyberte Domů > Zavřít & Načíst.

Výsledek

Nově importovaná data se zobrazí na novém listu.

Typické výsledky dotazu

Podporované zdroje dat

Mezi podporované zdroje dat patří:

  • Textové soubory, soubory CSV, XLSX, XML a JSON

  • SharePoint, SharePoint Lists, SharePoint Folders a OData.

  • Místní tabulky a oblasti

  • Microsoft SQL Server.

  1. Vyberte Data > Načíst data.

    Hlavní tlačítko a nabídka pro získání dat

  2. V dialogovém okně Zvolit zdroj dat – Načíst data (Power Query) vyberte excelový sešit nebo text/CSV.

    Příklad zdrojů dat, které se mají vybrat v dialogovém okně

  3. Vyberte Procházet a vyhledejte soubor, který chcete připojit jako zdroj dat.

  4. V dialogovém okně Výběr souboru vyberte soubor, zkontrolujte podrobnosti o souboru a potom klikněte na tlačítko Další

  5. Pokud existuje více než jedna sada dat, na levé straně vyberte data, která chcete importovat, a pak vpravo potvrďte výběr v náhledu dat.

  6. V pravém dolním rohu vyberte Načíst.

Výsledek

Importovaná data se zobrazí na novém listu.

Typické výsledky dotazu

Můžete aktualizovat následující zdroje dat: sharepointové soubory, sharepointové seznamy, sharepointové složky, OData, textové soubory / soubory CSV, excelové sešity (.xlsx), soubory XML a JSON, místní tabulky a oblasti a databázi Microsoft SQL Server.

První aktualizace

Při prvním pokusu o aktualizaci souborových zdrojů dat v dotazech sešitu bude pravděpodobně nutné aktualizovat cestu k souboru.

  1. Vyberte Data,  šipku vedle možnosti Získat data a potom nastavení zdroje dat. Zobrazí se dialogové okno Nastavení zdroje dat .

  2. Vyberte připojení a pak vyberte Změnit cestu k souboru.

  3. V dialogovém okně Cesta k souboru vyberte nové umístění a pak vyberte Načíst data.

  4. Vyberte Zavřít.

Aktualizace následných časů

Aktualizace:

  • Všechny zdroje dat v sešitu vyberte Data > Aktualizovat vše.

  • Konkrétní zdroj dat, klikněte pravým tlačítkem myši na tabulku dotazu na listu a pak vyberte Aktualizovat.

  • Kontingenční tabulka, vyberte buňku v kontingenční tabulka a pak vyberte kontingenční tabulka Analyzovat > Aktualizovat data.

Při prvním přístupu k SharePointu, SQL Server, OData nebo jiným zdrojům dat, které vyžadují oprávnění, musíte zadat příslušné přihlašovací údaje. Můžete také vymazat přihlašovací údaje pro zadání nových přihlašovacích údajů.

Zadání přihlašovacích údajů

Při první aktualizaci dotazu se může zobrazit výzva k přihlášení. Vyberte metodu ověřování a zadejte přihlašovací údaje pro připojení ke zdroji dat a pokračujte v aktualizaci.

Pokud se vyžaduje přihlášení, zobrazí se dialogové okno Zadat přihlašovací údaje .

Příklad:

  • Přihlašovací údaje SharePointu:

    Výzva k zadání přihlašovacích údajů SharePointu na Macu

  • SQL Server přihlašovacích údajů:

    Dialogové okno SQL Server pro zadání serveru, databáze a přihlašovacích údajů

Vymazání přihlašovacích údajů

  1. Vyberte data > Získat data > nastavení zdroje dat.

  2. V dialogovém okně Nastavení zdroje datvyberte požadované připojení.

  3. V dolní části vyberte Vymazat oprávnění.

  4. Potvrďte, že to chcete udělat, a pak vyberte Odstranit.

I když vytváření obsahu v Editor Power Query není v Excel pro Mac dostupné, jazyk VBA podporuje vytváření Power Query. Přenos modulu kódu VBA v souboru z Excelu pro Windows do Excel pro Mac je dvoustupňový proces. Na konci této části je k dispozici ukázkový program.

Krok 1: Excel pro Windows

  1. V Excelu Windows vyvíjejte dotazy pomocí jazyka VBA. Kód jazyka VBA, který používá následující entity v objektového modelu aplikace Excel, funguje také v Excel pro Mac: Objekt Queries, objekt WorkbookQuery, vlastnost Workbook.Queries.Další informace najdete v referenčních informacích k jazyku VBA v Excelu.

  2. V Excelu stiskněte kombinaci kláves ALT+F11 a ujistěte se, že je editor jazyka Visual Basic otevřený.

  3. Klikněte pravým tlačítkem na modul a pak vyberte Exportovat soubor. Zobrazí se dialogové okno Exportovat .

  4. Zadejte název souboru, ujistěte se, že přípona souboru je .bas, a pak vyberte Uložit.

  5. Nahrajte soubor VBA do online služby, aby byl soubor přístupný z Macu.

    Můžete použít Microsoft OneDrive. Další informace najdete v tématu Synchronizace souborů s OneDrivem v systému Mac OS X.

Krok 2: Excel pro Mac

  1. Stáhněte si soubor VBA do místního souboru, do souboru VBA, který jste si uložili v kroku 1: Excel pro Windows, a nahrajte ho do online služby.

  2. V Excel pro Mac vyberte Nástroje > Makro > Editor jazyka Visual Basic. Zobrazí se okno Editor jazyka Visual Basic .

  3. Klikněte pravým tlačítkem na objekt v okně Projektu a pak vyberte Importovat soubor. Zobrazí se dialogové okno Importovat soubor .

  4. Vyhledejte soubor VBA a pak vyberte Otevřít.

Ukázkový kód

Tady je základní kód, který můžete přizpůsobit a použít. Toto je ukázkový dotaz, který vytvoří seznam s hodnotami od 1 do 100.

Sub CreateSampleList()
    ActiveWorkbook.Queries.Add Name:="SampleList", Formula:= _
        "let" & vbCr & vbLf & _
            "Source = {1..100}," & vbCr & vbLf & _
            "ConvertedToTable = Table.FromList(Source, Splitter.SplitByNothing(), null, null, ExtraValues.Error)," & vbCr & vbLf & _
            "RenamedColumns = Table.RenameColumns(ConvertedToTable,{{""Column1"", ""ListValues""}})" & vbCr & vbLf & _
        "in" & vbCr & vbLf & _
            "RenamedColumns"
    ActiveWorkbook.Worksheets.Add
    With ActiveSheet.ListObjects.Add(SourceType:=0, Source:= _
        "OLEDB;Provider=Microsoft.Mashup.OleDb.1;Data Source=$Workbook$;Location=SampleList;Extended Properties=""""" _
        , Destination:=Range("$A$1")).QueryTable
        .CommandType = xlCmdSql
        .CommandText = Array("SELECT * FROM [SampleList]")
        .RowNumbers = False
        .FillAdjacentFormulas = False
        .PreserveFormatting = True
        .RefreshOnFileOpen = False
        .BackgroundQuery = True
        .RefreshStyle = xlInsertDeleteCells
        .SavePassword = False
        .SaveData = True
        .AdjustColumnWidth = True
        .RefreshPeriod = 0
        .PreserveColumnInfo = True
        .ListObject.DisplayName = "SampleList"
        .Refresh BackgroundQuery:=False
    End With
End Sub

Viz také

Nápověda pro doplněk Power Query pro Excel

Potřebujete další pomoc?

Rozšiřte své znalosti a dovednosti
Projít školení
Získejte nové funkce jako první
Připojit se systém Microsoft Office insiderům

Byly tyto informace užitečné?

Jak jste spokojeni s kvalitou jazyka?
Co ovlivnilo váš názor?

Děkujeme vám za zpětnou vazbu.

×