Odesílání dat formuláře v e-mailové zprávě

Platí pro
InfoPath 2010 InfoPath 2013

Důležité

Podpora pro Microsoft InfoPath 2013 skončila 14. července 2026. Doporučujeme, abyste stávající formuláře a pracovní postupy InfoPathu migrovali do podporovaných řešení Microsoft 365. Další informace o vyřazení InfoPathu z provozu

Do šablony formuláře můžete přidat sekundární datové připojení pro odesílání, které uživatelům umožní odesílat data formuláře v e-mailové zprávě. Pomocí statických hodnot, hodnot založených na datech ve formuláři nebo vzorců můžete zadat e-mailové adresy, na které bude formulář odeslán, řádek předmětu e-mailové zprávy a název formuláře. Můžete taky určit, jestli se má formulář zobrazit v textu e-mailové zprávy nebo jako příloha zprávy.

Pokud šablonu formuláře nakonfigurujete tak, aby zahrnovala formulář jako přílohu e-mailové zprávy, můžete ji také připojit k e-mailové zprávě. Tím, že formulář a šablonu formuláře přidáte jako přílohy e-mailové zprávy, můžete zajistit, aby příjemci e-mailu mohli otevřít formulář v aplikaci systém Microsoft Office InfoPath i v případě, že nemají šablonu formuláře uloženou v mezipaměti počítače. Aby mohli příjemci přílohy otevřít, musí mít na počítači nainstalovaný InfoPath.

Když uživatelé odešlou data formuláře v e-mailové zprávě, InfoPath vytvoří e-mailovou zprávu s daty formuláře a odešle ji příjemcům e-mailů, které jste určili při vytváření datového připojení. Pokud příjemci vyplněných formulářů používají aplikaci systém Microsoft Office Outlook 2007, mohou si do složky Doručená pošta přidat složku, která bude obsahovat všechny formuláře InfoPathu, jež obdrží, a nakonfigurovat ji tak, aby zobrazovala data ve formulářích ve sloupcích v aplikaci Outlook.

Po přidání datového připojení pro odesílání nakonfigurujete šablonu formuláře tak, aby uživatelé mohli odesílat data formuláře. Když tedy uživatelé otevřou formulář, InfoPath automaticky přidá tlačítko Odeslat na panel nástrojů Standardní a příkaz Odeslat do nabídky Soubor . Možnosti odesílání je možné u šablony formuláře také následujícími způsoby upravit:

  • Změna textu, který se zobrazuje na tlačítku Odeslat na panelu nástrojů Standardní a v příkazu Odeslat v nabídce Soubor .
  • Můžete změnit klávesovou zkratku pro tlačítko Odeslat na panelu nástrojů Standardní a příkaz Odeslat v nabídce Soubor .
  • Vytvořte vlastní zprávy, které se uživatelům zobrazí při odeslání formulářů.
  • Určit, jestli má formulář po odeslání formuláře zůstat otevřený, nebo se má zavřít, nebo se má otevřít nový prázdný formulář.

Začátek stránky

Přidání datového připojení pro odesílání

  1. V nabídce Nástroje klepněte na příkaz Možnosti odeslání.

  2. V dialogovém okně Možnosti odeslání zaškrtněte políčko Povolit uživatelům odeslat tento formulář .

  3. Klikněte na možnost Odeslat data formuláře do jednoho umístění a poté v seznamu klikněte na položku E-mail.

  4. Klikněte na Přidat.

  5. V Průvodci datovým připojením zadejte do příslušných polí e-mailové adresy příjemců, předmět, který se má zobrazit v e-mailové zprávě, libovolný úvodní text a klikněte na tlačítko Další.

    Tip:

    Můžete také zadat pole nebo pomocí vzorce vytvořit hodnotu pro každé pole kromě úvodního pole.

    Jak na to?

    1. Klikněte na Vložit vzorec .

    2. V dialogovém okně Vložit vzorec proveďte jednu z následujících akcí:

      • Chcete-li ve vzorci použít pole, klepněte na tlačítko Vložit pole nebo skupina, klepněte na pole, které chcete použít, v dialogovém okně Vybrat pole nebo skupinu a potom klepněte na tlačítko OK.

      • Chcete-li ve vzorci použít funkci, klepněte na tlačítko Vložit funkci, vyberte funkci, kterou chcete použít v dialogovém okně Vložit funkci , a klepněte na tlačítko OK.

        Tip:

        Pokud funkce vyžaduje zadání parametrů, vyberte funkci v dialogovém okně Vložit funkci , klepněte na tlačítko OK a poté v poli Vzorec v dialogovém okně Vložit vzorec poklikejte na funkci, kterou jste přidali, a klepněte na pole nebo skupinu. Odkazy na další informace o funkcích naleznete v části Viz také .

      • Chcete-li do vzorce vložit hodnotu nebo matematický operátor, zadejte hodnotu nebo symbol matematické operace do pole Vzorec .

    Operace Symbol
    Přidat +
    Odečíst -
    Násobení *
    Dělení /
    • Poznámka

      Pokud vzorec používá operátor dělení (/), ujistěte se, že před i za operátorem je mezera. Pokud nebude operátor dělení z obou stran oddělen mezerou, bude ho aplikace InfoPath považovat za oddělovač v umístění cesty XPath, ne za operátor dělení.

    • Chcete-li zkontrolovat syntaxi vzorce, klepněte v dialogovém okně Vložit vzorec na tlačítko Ověřit vzorec.
      Odkazy na další informace o vzorcích naleznete v části Viz také .

  6. Na další stránce průvodce proveďte jednu z následujících akcí:

    1. Chcete-li zobrazit formulář v textu e-mailové zprávy, klepněte na možnost Odeslat pouze aktivní zobrazení formuláře bez přílohy.

    2. Chcete-li data formuláře odeslat jako přílohu e-mailové zprávy, klepněte na možnost Odeslat data formuláře jako přílohu, zaškrtněte políčko Připojit šablonu formuláře, aby uživatelé mohli otevřít formulář a do pole Název přílohy zadejte název formuláře. Můžete taky zadat pole nebo použít vzorec a zajistit tak jedinečnost názvu každého formuláře.
      Jak na to?

      1. Klikněte na Vložit vzorec .

      2. V dialogovém okně Vložit vzorec proveďte jednu z následujících akcí:

        • Chcete-li ve vzorci použít pole, klepněte na tlačítko Vložit pole nebo skupina, klepněte na pole, které chcete použít, v dialogovém okně Vybrat pole nebo skupinu a potom klepněte na tlačítko OK.

        • Chcete-li ve vzorci použít funkci, klepněte na tlačítko Vložit funkci, vyberte funkci, kterou chcete použít v dialogovém okně Vložit funkci , a klepněte na tlačítko OK.

          Tip:

          Pokud funkce vyžaduje zadání parametrů, vyberte funkci v dialogovém okně Vložit funkci , klepněte na tlačítko OK a poté v poli Vzorec v dialogovém okně Vložit vzorec poklikejte na funkci, kterou jste přidali, a klepněte na pole nebo skupinu. Odkazy na další informace o funkcích naleznete v části Viz také .

        • Chcete-li do vzorce vložit hodnotu nebo matematický operátor, zadejte hodnotu nebo symbol matematické operace do pole Vzorec .

      Operace Symbol
      Přidat +
      Odečíst -
      Násobení *
      Dělení /
      • Poznámka

        Pokud vzorec používá operátor dělení (/), ujistěte se, že před i za operátorem je mezera. Pokud nebude operátor dělení z obou stran oddělen mezerou, bude ho aplikace InfoPath považovat za oddělovač v umístění cesty XPath, ne za operátor dělení.

      • Chcete-li zkontrolovat syntaxi vzorce, klepněte v dialogovém okně Vložit vzorec na tlačítko Ověřit vzorec.
        Odkazy na další informace o vzorcích naleznete v části Viz také .

      Poznámka

      Lidé, kteří dostanou data formuláře jako přílohu v e-mailové zprávě, potřebují mít na počítači nainstalovaný InfoPath, aby mohli přílohu otevřít.

  7. Klikněte na tlačítko Další.

  8. Do pole Zadejte název tohoto datového připojení na další stránce průvodce zadejte popisný název tohoto datového připojení pro odesílání.

  9. Ověřte správnost informací v části Souhrn a klikněte na tlačítko Dokončit.

    1. Chcete-li změnit název tlačítka Odeslat , které se zobrazuje na panelu nástrojů Standardní , a příkazu Odeslat , který se zobrazuje v nabídce Soubor , když uživatelé vyplní formulář, zadejte nový název do pole Titulek v dialogovém okně Možnosti odeslání .

      Tip:

      Pokud chcete k tomuto tlačítku a příkazu přiřadit klávesovou zkratku, zadejte znak ampersandu (&) před znak, který chcete použít jako klávesovou zkratku. Chcete-li například přiřadit klávesovou zkratku ALT+B pro tlačítko a příkaz Odeslat , zadejte Su&bmit.

  10. Pokud uživatelům při vyplňování formuláře nechcete povolit použití příkazu Odeslat ani tlačítka Odeslat na panelu nástrojů Standardní , zrušte zaškrtnutí políček Zobrazit položku nabídky Odeslat a tlačítko Odeslat na panelu nástrojů .

    1. Ve výchozím nastavení zůstane formulář po odeslání otevřený a aplikace InfoPath zobrazí zprávu s informacemi o tom, zda byl formulář úspěšně odeslán. Chcete-li toto výchozí chování změnit, klikněte na tlačítko Upřesnit a proveďte jednu z následujících akcí:

      • Chcete-li po odeslání vyplněného formuláře uživatelem formulář zavřít nebo vytvořit nový prázdný formulář, klikněte na požadovanou možnost v rozevíracím seznamu Po odeslání .

      • Chcete-li vytvořit vlastní zprávu s informacemi o tom, zda byl formulář úspěšně odeslán, zaškrtněte políčko Použít vlastní zprávy a potom zadejte požadované zprávy do polí Při úspěchu a Při neúspěchu .

        Tip:

        Pomocí zprávy v poli Při neúspěchu uživatelům sdělte, co je třeba provést, pokud nelze formulář odeslat. Můžete uživatelům například navrhnout, aby uložili formulář a požádali o další pokyny jinou osobu.

      • Pokud nechcete, aby se po odeslání formuláře uživateli zobrazila zpráva, zrušte zaškrtnutí políčka Zobrazit zprávy o úspěšném nebo neúspěšném odeslání .

Začátek stránky