Někdy je potřeba zkontrolovat, jestli je buňka prázdná, obvykle proto, že nechcete, aby vzorec zobrazoval výsledek bez vstupních hodnot.

Vzorec v buňce E2 je =KDYŽ(D2=1;"Ano";KDYŽ(D2=2;"Ne";"Možná"))

V tomto případě používáme funkci KDYŽ v kombinaci s funkcí JE.PRÁZDNÉ:

  • =KDYŽ(JE.PRÁZDNÉ(D2);"Prázdné";"Není prázdné")

Tento vzorec říká KDYŽ(buňka D2 je prázdná; vrať hodnotu "Prázdné"; jinak vrať hodnotu "Není prázdné"). Stejně snadno můžete pro podmínku "Není prázdné" použít i vlastní vzorec. V dalším příkladu používáme místo funkce JE.PRÁZDNÉ výraz prázdného řetězce: "". Výraz "" v zásadě znamená „nic“.

Kontrola, jestli není buňka prázdná: Vzorec v buňce E2 je =KDYŽ(JE.PRÁZDNÉ(D2);"Prázdné";"Není prázdné")

=KDYŽ(D3="";"Prázdné";"Není prázdné")

Tento vzorec říká KDYŽ(buňka D3 nemá žádný obsah; vrať hodnotu "Prázdné"; jinak vrať hodnotu "Není prázdné"). Tady je příklad velmi běžného způsobu použití výrazu "" k tomu, aby se zabránilo výpočtu vzorce v případě, že je závislá buňka prázdná:

  • =KDYŽ(D3="";"";VášVzorec())

    KDYŽ(buňka D3 nemá žádný obsah; nevracej nic; jinak vypočti zadaný vzorec).

Potřebujete další pomoc?

Rozšiřte své znalosti a dovednosti
Projít školení
Získejte nové funkce jako první
Připojit se k programu Microsoft Insider

Byly tyto informace užitečné?

Jak jste spokojeni s kvalitou překladu?
Co ovlivnilo váš názor?

Děkujeme za váš názor!

×