Když zadáte maticový vzorec, nejčastěji používáte oblast buněk v listu, ale nemusíte. Můžete taky použít maticové konstanty, hodnoty, které zadáte do řádku vzorců uvnitř složených závorek: {}. Pak můžete konstantu pojmnovat, aby se snadněji znovu znova používá.

Konstanty můžete použít v maticových vzorcích nebo sami.

  1. Do maticového vzorce zadejte počáteční složenou závorku, hodnoty, které chcete, a závěrečnou složenou závorku. Tady je příklad: =SUMA(A1:E1*{1;2;3;4;5})

    Konstanta je uvnitř složených závorek ({)} a ano, tyto složené závorky opravdu zadáte ručně.

  2. Zadejte zbytek vzorce a stiskněte Ctrl+Shift+Enter.

    Vzorec bude vypadat nějak jako {=SUMA(A1:E1*{1;2;3;4;5})}a výsledky budou vypadat takhle:


    Maticová konstanta vnořená do vzorce SUMA

    Vzorec vynásobil A1 1 a B1 2 atd., takže jste museli do buněk na listu umístit 1,2;3;4;5.

Zadání hodnot do sloupce pomocí konstanty

Pokud chcete zadat hodnoty do jednoho sloupce, například do 3 buněk ve sloupci C, můžete:

  1. Vyberte buňky, které chcete použít.

  2. Zadejte znaménko rovná se a konstantu. Hodnoty v konstantě oddělte středníky, ne středníky, a pokud zadáváte text, obklopte je dvojitými uvozovkami. Příklad: ={"Čtvrtletí 1";" Čtvrtletí2";" Čtvrtletí 3"}

  3. Stiskněte Ctrl+Shift+Enter. Konstanta vypadá takhle:

    Svislá maticová konstanta využívající text

    Z hlediska šprtů jde o jednorozměrnou svislou konstantu.

Zadání hodnot do řádku pomocí konstanty

Pokud chcete rychle zadat hodnoty do jednoho řádku, jako jsou buňky F1, G1 a H1, můžete:

  1. Vyberte buňky, které chcete použít.

  2. Zadejte znaménko rovná se a konstantu, ale tentokrát hodnoty oddělíte středníky, ne středníky. Příklad: ={1;2;3;4;5}

  3. Stiskněte Ctrl+Shift+Enter a konstanta vypadá takhle:

    Jednorozměrná vodorovná maticová konstanta

    Z hlediska šprtů jde o jednorozměrnou vodorovnou konstantu.

Zadání hodnot do více sloupců a řádků pomocí konstanty

  1. Vyberte buňky, které chcete použít.

    Ujistěte se, že počet řádků a sloupců, které vyberete, odpovídá počtu hodnot ve vaší konstantě. Pokud třeba vaše konstanta zapisuje data do čtyř sloupců a tří řádků, vyberte tolik sloupců a řádků.

  2. Zadejte znaménko rovná se a konstantu. V tomto případě oddělte hodnoty v každém řádku čárkami a na konci každého řádku použijte středník. Příklady:

    ={1\2\3\4;5\6\7\8;9\10\11\12}

  3. Stiskněte Ctrl+Shift+Enter a:

    Dvourozměrná maticová konstanta

    Z hlediska šprtů jde o dvojrozměrnou konstantu, protože vyplňuje sloupce a řádky. Pokud vás to zajímá, nemůžete vytvořit trojrozměrnou konstantu, což znamená, že nemůžete vnořit konstantu do jiné konstanty.

Použití konstanty ve vzorci

Teď, když znáte maticové konstanty, tady je pracovní příklad.

  • Do libovolné prázdné buňky zadejte (nebo zkopírujte a vložte) tento vzorec a stiskněte kombinaci kláves Ctrl+Shift+Enter:

    =SUMA(A1:E1*{1\2\3\4\5})

    V buňce A3 se zobrazí hodnota 85.

    Co se stalo? Vynásobil(a) jste hodnotu v buňce A1 hodnotou 1, hodnotou v buňce B2 hodnotou 2 atd., pak funkce SUMA tyto výsledky přidala. Můžete také zadat vzorec jako =SUMA(A1*1;B1*2;C1*3;D1*4;E1*5)

Pokud chcete, můžete zadat obě sady hodnot jako maticové konstanty:

=SUMA({3\4\5\6\7}*{1\2\3\4\5})

Zkuste to tak, že vzorec zkopírujete, vyberete prázdnou buňku a vzorec vložíte do řádku vzorců a stisknete kombinaci kláves Ctrl+Shift+Enter. Zobrazí se stejný výsledek.

Poznámky: Pokud vaše konstanty nefungují, hledejte tyto problémy:

  • Ujistěte se, že hodnoty oddělíte správným znakem. Pokud nezadáte čárku nebo středník nebo pokud ji dáte na nesprávné místo, nemusí maticová konstanta vypadat správně nebo se může zobrazit zpráva s upozorněním.

  • Vybraná oblast buněk možná neodpovídá počtu prvků v konstantě. Pokud například vyberete sloupec šesti buněk pro použití s pětibuněčkovou konstantou, zobrazí se v prázdné buňce #N/A. Pokud nevyberte dostatek buněk, Excel hodnoty, které nemají odpovídající buňku.

  • Další informace o maticových vzorcích:

Začátek stránky

Potřebujete další pomoc?

Rozšiřte své znalosti a dovednosti
Projít školení
Získejte nové funkce jako první
Připojit se systém Microsoft Office insiderům

Byly tyto informace užitečné?

Jak jste spokojeni s kvalitou jazyka?
Co ovlivnilo váš názor?

Děkujeme vám za zpětnou vazbu.

×