Vlastnosti oblasti externích dat můžete změnit tak, aby bylo možné řídit data importovaná do listu prostřednictvím připojení k externímu zdroji dat, jako je databáze, webový dotaz nebo textový soubor.

Oblast externích dat je definovaný název nebo název tabulky, který definuje umístění dat, která se převedou do listu. Když se připojíte k externím datům, Excel automaticky vytvoří oblast externích dat. Jedinou výjimkou je sestava kontingenční tabulky, která je připojená ke zdroji dat – sestava kontingenční tabulky neobsahuje oblast externích dat. V Excel můžete formátovat a rozložit oblast externích dat nebo ji použít ve výpočtech, stejně jako u jiných dat.

Vlastnosti oblasti externích dat

Oblast externích dat má další vlastnosti (nezaměňovat s dotazem nebo vlastnostmi připojení), které můžete použít k řízení dat, například zachování formátování buněk a šířky sloupce. Tyto vlastnosti oblasti externích dat můžete změnit kliknutím na Vlastnosti ve skupině Připojení na kartě Data. Pak proveďte změny následujícím způsobem:

  • Pro oblasti externích dat vytvořené z Microsoft Query a Průvodce datovým připojením použijte dialogové okno Vlastnosti externích dat.

  • Pro oblasti externích dat vytvořené z importovaného textového souboru nebo webového dotazu, které načítá data HTML, použijte dialogové okno Vlastnosti oblasti externích dat.

  • U externích rozsahů dat vytvořených z webového dotazu, který načítá data XML, použijte dialogové okno Vlastnosti mapování XML.

  1. Vyberte list, ve kterém chcete vyhledat Oblast externích dat.

  2. Na Řádek vzorců klikněte na šipku vedle pole Název a potom klikněte na název oblasti externích dat, kterou chcete použít.

  1. Vyberte Vzorce > Správce názvů.

  2. V dialogovém okně Správce názvů klikněte na název oblasti externích dat a potom klikněte na Upravit. Můžete také poklikat na název.

  3. V dialogovém okně Upravit název zadejte nový název odkazu do pole Název.

Poznámka: Tlačítko Zavřít zavře jenom dialogové okno Správce názvů. Abyste mohli potvrdit změny, které jste už udělali, nemusíte klikat na Zavřít.

Podkladový dotaz pro oblast externích dat, která byla vytvořena z Microsoft Query, importovaného textového souboru, webového dotazu nebo Průvodce datovým připojením, můžete změnit.

  1. Klikněte na buňku v oblasti externích dat, u které chcete změnit podkladový dotaz.

  2. Vyberte Data > Vlastnosti.

  3. V dialogovém okně Vlastnosti externích dat klikněte na Vlastnosti připojení Obrázek tlačítka .

  4. V dialogovém okně Vlastnosti připojení klikněte na kartu Definice a potom klikněte na Upravit dotaz.

Další informace o vytváření a úpravách dotazů v Microsoft Query najdete v nápovědě k Microsoft Query.

  1. Klikněte na buňku v oblasti externích dat, u které chcete změnit podkladový dotaz.

  2. Vyberte Data > Connections & Queries > Connections (Připojení), klikněte pravým tlačítkem myši na připojení, které chcete použít, a pak vyberte Vlastnosti.

  3. V dialogovém okně Vlastnosti připojení klikněte na kartu Definice a potom klikněte na Upravit dotaz.

  4. V dialogovém okně Importovat textový soubor klikněte na Importovat.

  5. Proveďte změny importovaného textového souboru v Průvodci importem textu a potom klikněte na Dokončit.

    Další informace o importu textových souborů najdete v tématu Import nebo export textových souborů.

  1. Klikněte na buňku v oblasti externích dat, u které chcete změnit podkladový dotaz.

  2. Vyberte Data > Vlastnosti.

  3. Vyberte Data > Connections & Queries > Connections (Připojení), klikněte pravým tlačítkem myši na připojení, které chcete použít, a pak vyberte Vlastnosti.

  4. V dialogovém okně Vlastnosti připojení klikněte na kartu Definice a potom klikněte na Upravit dotaz.

  5. V dialogovém okně Upravit webový dotaz proveďte změny webového dotazu a klikněte na Dokončit.

Další informace o vytváření a úpravách webových dotazů najdete v Připojení na webovou stránku.

  1. Klikněte na buňku v oblasti externích dat, u které chcete změnit podkladový dotaz.   

  2. Vyberte Data > Vlastnosti.

  3. V dialogovém okně Vlastnosti externích dat klikněte na Vlastnosti připojení Obrázek tlačítka .

  4. V dialogovém okně Vlastnosti připojení klikněte na kartu Definice.

  5. Udělejte jednu z těchto věcí:

    • V poli Typ příkazu klikněte na Tabulka a potom v textovém poli Příkaz změňte hodnotu na název příslušné tabulky, zobrazení nebo dotazu.

    • V poli Typ příkazu klikněte na SQLnebo Výchozí a potom v textovém poli Příkaz upravte příkaz SQL příkazu.

      Poznámka: V závislosti na tom, jak bylo připojení definováno, nemusí být pole Typ příkazu dostupné (zobrazí se šedě).

  1. Na řádku vzorců klikněte na šipku vedle pole Název a vyberte název oblasti externích dat, kterou chcete zkopírovat.

    U Excel vyberte název oblasti a stisknutím kombinace kláves CTRL+A vyberte záhlaví tabulky.

    Pokud chcete zahrnout popisky sloupců nebo vzorce, které nejsou součástí oblasti externích dat, vyberte buňky obsahující popisky sloupců nebo vzorce, které chcete zkopírovat. Klikněte na šipku vedle pole Název na řádku vzorců a klikněte na název oblasti externích dat, kterou chcete zkopírovat.

  2. Vyberte Domů > Kopírovat.

  3. Přepněte do sešitu, do kterého chcete vložit oblast externích dat.

  4. Klikněte na levou horní buňku Oblast pro vložení.

    Pokud chcete zajistit, Externí data existující data nenahradí, zkontrolujte, jestli list neobsahuje žádná data v buňce nebo napravo od buňky, na kterou kliknete.

  5. Na kartě Domů klikněte ve skupině Schránka na Vložit.

Poznámka: Pokud zkopírujete jenom část oblasti externích dat, podkladová Dotaz se nekopíruje a zkopírovaná data se ne aktualizují.

Můžete řídit, jak zpracovat menší nebo větší sadu dat, která se vrátí do Excel při aktualizaci dat.

  1. Vyberte Data > Vlastnosti.

  2. V dialogovém okně Vlastnosti oblasti externích dat v části Pokud se počet řádků v oblasti dat změní při aktualizaci, klikněte na jednu z těchto možností:

    • Vložení buněk pro nová data, odstranění nepoužívaných buněk

      Poznámky: 

      • Když se do zdroje dat přidá jeden nebo více řádků, buňky přímo pod oblastmi externích dat se přesunou dolů, ale buňky napravo od oblasti externích dat se přesunou.

      • Když jeden nebo více řádků odstraníte ve zdroji dat, buňky přímo pod oblastmi externích dat se přesunou nahoru, ale buňky napravo od oblasti externích dat se nesouou.

    • Vložení celých řádků pro nová data, vymazání nepoužívaných buněk

      Poznámky: 

      • Když se do zdroje dat přidá jeden nebo více řádků, přesunou se buňky přímo pod oblast externích dat a napravo od oblasti externích dat dolů.

      • Když se odstraní jeden nebo více řádků ve zdroji dat, buňky přímo pod a vpravo od oblasti externích dat se nebudou přesouvat.

    • Přepsat existující buňky novými daty, vymazat nepoužívané buňky

      Poznámky: 

      • Při přidání jednoho nebo více řádků do zdroje dat se buňky přímo pod oblastmi externích dat přepíšou, ale buňky napravo od oblasti externích dat se přesunou.

      • Když se odstraní jeden nebo více řádků ve zdroji dat, buňky přímo pod a vpravo od oblasti externích dat se nebudou přesouvat.

  1. Vyberte Data > Vlastnosti.

  2. V části Formátování a rozložení datproveďte jednu nebo více z těchto akcí:

    • Pokud chcete jako první řádek zahrnout názvy polí, zaškrtněte políčko Zahrnout názvy polí.

      Poznámka: Toto políčko je dostupné jenom pro oblast externích dat, která se převádí z aplikace Microsoft Office 2003, nebo pro oblast externích dat, která je vytvořena programově.

    • Pokud chcete přidat sloupec čísel řádků, zaškrtněte políčko Zahrnout čísla řádků.

      Poznámka: Toto políčko není dostupné pro importovaný textový soubor, soubor XML nebo webový dotaz.

    • Pokud chcete zachovat použité formátování buněk, zaškrtněte políčko Zachovat formátování buněk.

      Poznámka: U webového dotazu se tato možnost automaticky vyškrtne, když v dialogovém okně Možnosti vyberete Úplné formátování HTML. Dialogové okno Možnosti se zobrazí v dialogovém okně Upravit dotaz.

    • Pokud chcete zachovat nastavené šířky sloupců, zaškrtněte políčko Upravit šířku sloupce.

    • Pokud chcete zachovat řazení, filtrování a rozložení sloupců, které použijete, zaškrtněte políčko Zachovat řazení, filtrování nebo rozložení sloupců.

      Poznámka: Toto zaškrtávací políčko není pro webový dotaz dostupné.

    • Pokud chcete zachovat filtrování sloupců, které použijete, zaškrtněte políčko Zachovat filtr sloupců.

      Poznámka: Toto zaškrtávací políčko je dostupné jenom pro webový dotaz založený na datech XML.

Poznámka: Následující postup platí jenom pro oblast externích dat, která se převádí z aplikace Microsoft Office 2003, nebo pro oblast externích dat, která je vytvořena programově. Všechny oblasti externích dat vytvořené pomocí uživatelského rozhraní se vytvoří jako Excel tabulek. Tyto tabulky se při přidání nových řádků automaticky rozbalí a vyplní počítané sloupce.

  1. Do buňky, která sousedí s prvním řádkem dat v oblasti externích dat, zadejte vzorec.

    Poznámka: První řádek dat může být první nebo druhý řádek v oblasti externích dat v závislosti na tom, jestli první řádek obsahuje záhlaví.

  2. Vyberte buňku a poklikejte na Úchyt a zkopírujte vzorec do všech řádků v oblasti externích dat.

  3. Klikněte na buňku v oblasti externích dat.

  4. Vyberte Data > Vlastnosti.

  5. V dialogovém okně Vlastnosti oblasti externích dat zaškrtněte políčko Vyplnit vzorce ve sloupcích sousedících s daty.

    Poznámka: Pokud se oblast externích dat při Aktualizovat zvětší, Excel zkopíruje jenom ty vzorce, které jsou hned vedle oblasti externích dat nebo v oblasti externích dat.

Ukotvení oblasti externích dat zachová data, ale ne její podkladový dotaz, takže ukotvenou oblast externích dat nelze aktualizovat.

  1. Klikněte na list obsahující tabulku Excel, ze které chcete datové připojení odebrat.

  2. Na řádku vzorců klikněte na šipku vedle pole Název a potom klikněte na název oblasti externích dat, ze které chcete datové připojení odebrat. Potom je vybraná oblast dat.

  3. Na kartě Nástroje klikněte ve skupině Externí data tabulky na Zrušit propojení. Oblast dat zůstane a bude mít stejný název, ale připojení se odstraní.

Poznámka: Následující postup platí jenom pro oblast externích dat, která se převádí z aplikace Microsoft Office 2003, nebo pro oblast externích dat, která je vytvořena programově. Všechny oblasti externích dat vytvořené pomocí uživatelského rozhraní se vytvoří jako Excel tabulek. Tyto tabulky se při přidání nových řádků automaticky rozbalí a vyplní počítané sloupce.

  1. Vyberte Data > Vlastnosti.

  2. V části Definice dotazuzrušte zaškrtnutí políčka Uložit definici dotazu.

Poznámka: Při uložení sešitu se ze sešitu odstraní podkladový dotaz. Soubory uloženého databázového dotazu (soubory .dqy nebo .odc) se ale ne odstraní. Pokud jste dotaz uložili, když jste ho vytvořili v Průvodci dotazem nebo v Microsoft Query, uloží se soubor dotazu do počítače a můžete ho znovu použít k načtení externích dat. Další informace najdete v nápovědě k Microsoft Query.

Poznámka: Následující postup platí jenom pro oblast externích dat vytvořenou pomocí Průvodce datovým připojením nebo Microsoft Query (a ne pro importovaný textový soubor nebo webový dotaz), oblast externích dat převedenou z aplikace Microsoft Office 2003 nebo programově vytvořenou oblast externích dat. Všechny oblasti externích dat vytvořené pomocí uživatelského rozhraní se vytvoří jako Excel tabulek.

  1. Vložte prázdný řádek nad oblast externích dat jedním z těchto způsobů:

    • Vyberte buňku, nad kterou chcete vložit nový řádek. Potom na kartě Domů klikněte ve skupině Buňky na šipku vedle vložit a potom klikněte na Vložit řádky listu. Protože jste vybrali jednu buňku, vloží se nad aktuální řádek jeden nový řádek.

    • Klikněte na volič řádku, nad který chcete vložit nový řádek. Potom na kartě Domů klikněte ve skupině Buňky na Vložit. Vzhledem k tomu, že jste vybrali jeden celý řádek, vloží se nad vybraný řádek jeden nový řádek.

  2. Do buněk v prázdném řádku zadejte popisky, které chcete použít.

  3. Klikněte na buňku v oblasti externích dat.

  4. Vyberte Data > Vlastnosti.

  5. V dialogovém okně Vlastnosti oblasti externích dat zrušte v části Formátovánía rozložení dat zaškrtnutí políčka Zahrnout názvy polí a potom klikněte na OK.

  6. Pokud chcete odebrat existující názvy polí a aktualizovat oblast externích dat, klikněte na buňku v oblasti externích dat a potom klikněte na Aktualizovat data Obrázek tlačítka.

Poznámka: Když načítáte data z databáze, všechny změny názvů sloupců v Microsoft Query se zachovají v oblasti externích dat. Informace o změně názvů sloupců v dotazu najdete v nápovědě k Microsoft Query.

  1. Klikněte na list obsahující oblast externích dat, kterou chcete odstranit.

  2. Na řádku vzorců klikněte na šipku vedle pole Název a potom klikněte na název oblasti externích dat, kterou chcete odstranit.

    Pokud je oblast externích dat Excel, vyberte celou tabulku stisknutím kombinace kláves CTRL+A.

  3. Oblast externích dat odstraníte stisknutím klávesy DELETE.

  4. Pokud chcete odstranit podkladový dotaz, klikněte na Ano, Excel vás vyzve.

Viz také

Nápověda pro doplněk Power Query pro Excel

Potřebujete další pomoc?

Rozšiřte své znalosti a dovednosti
Projít školení
Získejte nové funkce jako první
Připojit se systém Microsoft Office insiderům

Byly tyto informace užitečné?

Jak jste spokojeni s kvalitou jazyka?
Co ovlivnilo váš názor?

Děkujeme vám za zpětnou vazbu.

×