Když budete moct analyzovat všechna data, můžete se lépe rozhodovat o obchodních záležitostech. Někdy je ale těžké vědět, kde začít, hlavně když máte hodně dat uložených mimo Excel, třeba v databázi Microsoft Accessu nebo Microsoft SQL Server nebo v souboru datové krychle OLAP (Online Analytical Processing). V takovém případě se připojíte k externímu zdroji dat a potom vytvoříte kontingenční tabulku, která bude shrnout, analyzovat, prozkoumat a prezentovat tato data.

Tady je postup, jak vytvořit kontingenční tabulku pomocí existujícího externího datového připojení:

  1. Klikněte na jakoukoliv buňku v listu.

  2. Klikněte na Vložení > Kontingenční tabulka.

    Tlačítko Kontingenční tabulka na kartě Vložení

  3. V dialogovém okně Vytvořit kontingenční tabulku klikněte v části Zvolte data, která chcete analyzovat na Použít externí zdroj dat.

    Dialogové okno Vytvořit kontingenční tabulku s vybranou možností Použít externí zdroj dat

  4. Klikněte na možnost Zvolit připojení.

  5. Na kartě Připojení nechte v poli Zobrazit vybraná možnost Všechna připojení nebo vyberte kategorii připojení se zdrojem dat, ke které se chcete připojit.

Pokud chcete znovu použít nebo sdílet existující připojení, použijte připojení z aplikace Connections v tomto sešitu.

  1. V seznamu připojení vyberte připojení, které chcete, a potom klikněte na Otevřít.

  2. V části Zvolte umístění sestavykontingenční tabulky vyberte umístění.

    • Pokud chcete kontingenční tabulku umístit do nového listu od buňky A1, zvolte Nový list.

    • Pokud chcete kontingenční tabulku umístit do aktivního listu, zvolteExistující list a do pole Umístění zadejte buňku, do které chcete kontingenční tabulku spustit.

  3. Klikněte na OK.

    Excel přidá prázdnou kontingenční tabulku a zobrazí seznam polí, abyste mohli zobrazit pole, která chcete, a změnit jejich uspořádání tak, aby se vytvořilo vlastní rozložení.

    Seznam polí zobrazující pole externích dat

  4. V části Seznam polí zaškrtněte políčko vedle názvu pole a umístěte pole do výchozí oblasti oddílu oblasti seznamu polí.

    Obvykle se do oblasti Řádky přidávají nečíselné pole, číselná pole se přidávají do oblasti Hodnoty a pole data a času se přidávají do oblasti Sloupce. Podle potřeby můžete pole přesunout do jiné oblasti.

    Tip: Můžete také kliknout pravým tlačítkem myši na název pole a pak vybrat Přidat do filtru sestavy ,Přidat do popisků sloupců ,Přidat do popisků řádků nebo Přidat k hodnotám, aby se pole v této oblasti oddílu oblasti nasoudí, nebo přetáhnout pole z oddílu pole do oblasti v oddílu oblasti.

    Pomocí seznamu polí můžete dále navrhnout rozložení a formát kontingenční tabulky tak, že kliknete pravým tlačítkem myši na pole v oddílu oblasti a vyberete oblast, kterou chcete, nebo přetažením polí mezi oblastmi v oddílu oblasti.

Připojení k novému externímu zdroji dat

Pokud chcete vytvořit nové externí datové připojení pro SQL Server a importovat data do Excel jako tabulku nebo kontingenční tabulku, proveďte toto:

  1. Klikněte na >z jiných zdrojů.

Tlačítko Z jiných zdrojů na kartě Data

  1. Klikněte na připojení, které chcete použít.

    • Kliknutím na SQL Server vytvořit připojení k SQL Server tabulky.

    • Pokud chcete vytvořit připojení k datové krychli SQL Server Analysis Services, klikněte na Z analysis Services.

  2. V Průvodci datovýmpřipojením proveďte postup vytvoření připojení.

    • Na stránce 1 zadejte databázový server a určete, jak se chcete k serveru přihlásit.

    • Na stránce 2 zadejte databázi, tabulku nebo dotaz obsahující data, která chcete použít.

    • Na stránce 3 zadejte soubor připojení, který chcete vytvořit.

Pokud chcete vytvořit nové připojení k accessové databázi a importovat data do Excel jako tabulku nebo kontingenční tabulku, proveďte toto:

  1. Klikněte na >z Accessu.

Tlačítko Z aplikace Access na kartě Data

  1. V dialogovém okně Vybrat zdroj dat vyhledejte databázi, ke které se chcete připojit, a klikněte na Otevřít.

  2. V dialogovém okně Vybrat tabulku vyberte požadovanou tabulku a klikněte na OK.

Pokud existuje více tabulek, zaškrtněte políčko Povolit výběr více tabulek, abyste mohli zaškrtovat políčka u tabulek, které chcete, a potom klikněte na OK.

  1. V dialogovém okně Importovat data vyberte, jak chcete data v sešitu zobrazit a kam je chcete vložit, a potom klikněte na OK.

Tabulky se automaticky přidávají do datového modelua databáze Accessu se přidá do připojení sešitu.

Další informace o kontingenčních tabulkách

Potřebujete další pomoc?

Rozšiřte své znalosti a dovednosti
Projít školení
Získejte nové funkce jako první
Připojit se k programu Microsoft Insider

Byly tyto informace užitečné?

Jak jste spokojeni s kvalitou překladu?

Co ovlivnilo váš názor?

Máte další zpětnou vazbu? (Nepovinné)

Děkujeme za váš názor!

×