Zjištění počtu znaků v buňkách

Pokud potřebujete spočítat znaky v buňkách, použijte funkci DÉLKA, která počítá písmena, čísla, znaky a všechny mezery. Například délka "Je to dnes 98 stupňů, takže půjdu zaplavat" (s výjimkou uvozovek) je 42 znaků – 31 písmen, 2 čísla, 8 mezer, čárka a 2 apostrofy.

Funkci použijete tak, že do řádku vzorcůzadáte=DÉLKA(buňka ) a na klávesnici stisknete Enter.

Více buněk: Pokud chcete použít stejný vzorec pro více buněk, zadejte vzorec do první buňky a přetáhněte úchyt dolů (nebo přes) oblast buněk.

Zadání více funkcí DÉLKA v listu

Celkový počet všech znaků v několika buňkách získáte tak, že použijete funkce SUMA společně s funkcí DÉLKA. V tomto příkladu funkce DÉLKA počítá znaky v jednotlivých buňkách a funkce SUMA sčítá počty:

=SUMA((DÉLKA( buňka1 ),DÉLKA( buňka2 ),(DÉLKA( buňka3 )) )).

Vyzkoušejte si to

Tady je několik příkladů, které ukazují, jak používat funkci DÉLKA.

Zkopírujte tabulku níže a vložte ji do buňky A1 v Excel listu. Přetažením vzorce z B2 na B4 zobrazíte délku textu ve všech buňkách ve sloupci A.

Textové řetězce

Vzorce

Rychlá hnědá liška.

=DÉLKA(A2)

Rychle hnědá liška skočila.

Příliš žluťoučký kůň úpěl ďábelské ódy.

Zjištění počtu znaků v jedné buňce

  1. Klikněte na buňku B2.

  2. Enter =DÉLKA(A2).

Vzorec spočítá znaky v buňce A2, která sečte na 27 , což zahrnuje všechny mezery a tečku na konci věty.

POZNÁMKA: Délka spočítá všechny mezery za posledním znakem.
 

Zjištění počtu znaků ve víc buňkách

  1. Klikněte na buňku B2.

  2. Stisknutím kombinace kláves Ctrl+C zkopírujte buňku B2, pak vyberte buňky B3 a B4 a stisknutím kombinace kláves Ctrl+V vložte vzorec do buněk B3:B4.

Vzorec se zkopíruje do buněk B3 a B4 a funkce spočítá znaky v každé buňce (20, 27 a 45).

Zjištění celkového počtu znaků

  1. V ukázkovém sešitu klikněte na buňku B6.

  2. Zadejte do buňky vzorec =SUMA(DÉLKA(A2);DÉLKA(A3);DÉLKA(A4)) a stiskněte Enter.

Spočítá znaky v každé ze tří buněk a sečte je (92).

Potřebujete další pomoc?

Rozšiřte své znalosti a dovednosti

Projít školení >

Získejte nové funkce jako první

Připojit se k programu Microsoft Insider >

Byly tyto informace užitečné?

Jak jste spokojeni s kvalitou jazyka?
Co ovlivnilo váš názor?

Děkujeme vám za zpětnou vazbu.

×