ZVOLIT (funkce)

Tento článek popisuje syntaxi vzorce a použití funkce ZVOLIT v Microsoft Excelu.

Popis

Na základě argumentu index určuje pořadí prvku seznamu, jehož hodnotu funkce vrátí. Použitím funkce ZVOLIT můžete vybrat 1 až 254 hodnot seznamu. Jestli jsou hodnota 1 až hodnota 7 třeba dny v týdnu, vrátí funkce ZVOLIT jeden den v týdnu určený argumentem index.

Syntaxe

ZVOLIT(index, hodnota1; [hodnota2];...)

Syntaxe funkce ZVOLIT obsahuje následující argumenty:

  • Index    Povinný argument. Určuje, který argument hodnoty je vybraný. Argument index musí být číslo v rozmezí 1 až 254 nebo vzorec nebo odkaz na buňku obsahující čísla 1 až 254.

    • Pokud index = 1, vrátí funkce ZVOLIT hodnotu argumentu hodnota1. Pokud index = 2, vrátí funkce ZVOLIT hodnotu argumentu hodnota2 a tak dále.

    • Pokud je hodnota index_num menší než 1 nebo větší než počet hodnot v seznamu, vyberte možnost vrátí #VALUE. .

    • Pokud argument index představuje zlomek, je před použitím zkrácený na nejbližší nižší celé číslo.

  • Hodnota1; hodnota2; ...     Hodnota1 je povinný argument, další hodnoty jsou nepovinné. Jedná se o 1 až 254 hodnot argumentů, ze kterých na základě zadaného argumentu index vybere funkce ZVOLIT hodnotu. Argumenty můžou být čísla, odkazy na buňky, definované názvy, vzorce, funkce a textové řetězce.

Poznámky

  • Pokud je argument index Matice, jsou při výpočtu funkce ZVOLIT přepočítané všechny hodnoty obsažené v matici.

  • Argumenty funkce ZVOLIT mohou být celé oblasti nebo samostatné hodnoty.

    Následující vzorec:

=SUMA(ZVOLIT(2,A1:A10,B1:B10,C1:C10))

se vyhodnotí jako:

=SUMA(B1:B10)

a vrátí hodnotu na základě obsahu buněk v oblasti B1:B10.

Funkce ZVOLIT je vyčíslená první a vrátí hodnotu B1:B10. Funkce SUMA potom použije výsledek funkce ZVOLIT jako svůj argument.

Příklady

Zkopírujte vzorová data v následující tabulce a vložte je do buňky A1 nového excelového sešitu. Aby vzorce zobrazily výsledky, vyberte je, stiskněte F2 a potom stiskněte Enter. Pokud potřebujete, můžete přizpůsobit šířky sloupců a zobrazit si všechna data.

Data

 

První

Hřebíky

Druhý

Šrouby

Třetí

Matice

Dokončeno

Nýty

Vzorec

Popis

Výsledek

=ZVOLIT(2;A2;A3;A4;A5)

Hodnota argumentu druhého seznamu (hodnota buňky A3)

Druhý

=ZVOLIT(4;B2;B3;B4;B5)

Hodnota argumentu čtvrtého seznamu (hodnota buňky B5)

Nýty

=ZVOLIT(3;"Širý";115;"svět";8)

Hodnota argumentu třetího seznamu

svět

Příklad 2

Data

23

45

12

10

Vzorec

Popis (výsledek)

Výsledek

=SUMA(A2:ZVOLIT(2;A3;A4;A5))

Sečte rozsah A2:A4. Funkce ZVOLIT vrátí A4 jako druhou část rozsahu u funkce SUMA.

80

Poznámka:  Tato stránka byla přeložena automaticky a může obsahovat gramatické chyby nebo nepřesnosti. Naším cílem je to, aby pro vás byl její obsah užitečný. Mohli byste nám prosím dát vědět, jestli vám informace pomohly? Pokud chcete, můžete se podívat na anglickou verzi článku.

Rozšiřte své dovednosti s Office
Projít školení
Získejte nové funkce jako první
Připojte se k účastníkům programu Office Insiders

Byly tyto informace užitečné?

Děkujeme vám za zpětnou vazbu.

Děkujeme vám za váš názor! Pravděpodobně bude užitečné, když vás spojíme s některým z našich agentů podpory Office.

×