V Projectu si můžete zobrazení filtrovat, abyste viděli jenom kritické úkoly, milníky a další informace, které jsou pro vás nejdůležitější. Existují tři způsoby filtrování úkolů nebo zdrojů v projektu: poskytuje předdefinované filtry pro zobrazení specifických aspektů úkolů a zdrojů. Pokud žádný z těchto filtrů nevyhovuje vašim potřebám, můžete vytvořit nový filtr nebo upravit existující filtr.
- Předdefinované filtry Tyto filtry se dodávají s Projectem. Slouží k rychlému vyfiltrování úkolů nebo zdrojů, například neúplných úkolů nebo přetížených zdrojů.
- Vlastní filtry Jedná se o filtry, které navrhujete pro vlastní potřeby projektu.
- Automatické filtry Když jsou zapnuté, zobrazují se v zobrazení listů v horní části každého sloupce jako šipky. Slouží k rychlému filtrování položek ve sloupci.
V tomto článku
Filtrování úkolů nebo zdrojů
Někdy potřebujete v projektu zobrazit jenom určitý typ informací. Můžete chtít například zobrazit jenom milníky projektu nebo úkoly, které ještě nezačaly. Pokud má váš projekt hodně úkolů a zahrnuje hodně zdrojů, můžou být filtry velmi užitečné pro zobrazení určitého rozsahu informací. Filtry umožňují zobrazit pouze informace, které vás zajímají, a zbytek skrýt.
Data úkolů nebo zdrojů můžete filtrovat pomocí předdefinovaných filtrů Projectu. Pokud žádný z filtrů nevyhovuje vašim potřebám, můžete vytvořit nový filtr nebo upravit existující filtr.
Použití nebo odebrání filtru
Na kartě Zobrazení ve skupině Data vyberte filtr v seznamu filtrů.
Pokud chcete použít filtr, který není v seznamu, vyberte Další filtry a udělejte jednu z těchto věcí:Pokud chcete vybrat filtr úkolu, zvolte Úkol, vyberte název filtru v seznamu Filtry a pak zvolte Použít.
Pokud chcete vybrat filtr zdrojů, zvolte Zdroj, vyberte název filtru v seznamu Filtry a pak zvolte Použít.
Poznámka
Filtry úkolů nelze použít u zobrazení zdrojů a filtry zdrojů u zobrazení úkolů.
Pokud používáte interaktivní filtr, zadejte požadované hodnoty a pak zvolte OK.
Pokud chcete filtr vypnout, zvolte v seznamu filtrů možnost Bez filtru .
Použití barvy na filtrované úkoly pomocí zvýraznění
Při filtrování úkolů nebo zdrojů můžete použít zvýraznění. Zvýrazněné úkoly nebo zdroje se zobrazí s nefiltrovanými úkoly, ale s jinou barvou.
- Na kartě Zobrazení ve skupině Data vyberte filtr v seznamu filtrů a pak zvolte Další filtry.
- V seznamu filtrů vyberte filtr a pak zvolte Zvýraznit.
Tip:
Pokud chcete zvýrazněným úkolům přiřadit jinou barvu, použijte jiný styl textu. Zvolte kartu Formát a pak vyberte Styly textu. V seznamu Změnit položku vyberte Zvýrazněné úkoly a pak vyberte možnosti formátování.
Vytvoření vlastního filtru
- Na kartě Zobrazení klikněte ve skupině Data na šipku u tlačítka Filtr a potom zvolte Další filtry.
- Vyberte Úkol nebo Zdroj (podle toho, jaký typ filtru chcete vytvořit) a pak zvolte Nový.
- Zadejte název nového filtru. Pokud chcete tento filtr zahrnout do seznamu Skupina dat, vyberte Zobrazit v nabídce.
- Ve sloupci A/Nebo zvolte A , pokud chcete zobrazit výsledky, které splňují více než jedno kritérium filtru. Pokud chcete zobrazit řádky, které se shodují s jedním nebo druhým, zvolte Or .
- Ve sloupci Název pole vyberte pole, které chcete filtrovat.
- Ve sloupci Test se rozhodněte, jak chcete sladit to, co jste zvolili pro sloupec Název pole , se sloupcem Hodnoty v dalším kroku.
- Ve sloupci Hodnoty zvolte požadovanou hodnotu nebo zadejte novou.
Pokud jste ve sloupci Test vybrali možnost Rovná se nebo Nerovná se, můžete do sloupce Hodnoty zadat zástupný znak (místo výběru možnosti ze seznamu). Například zadáním otazníku (?) by se vyhledaly jednotlivé znaky. Když napíšete hvězdičku (*), vyhledá se libovolný počet znaků. Pokud používáte zástupné znaky, dbejte na to, aby ve sloupci Název pole nebyl vybrán text, ale text (například Název), nikoli čísla (například Doba trvání). - Pokud chcete do filtru přidat další řádek (a zvolit jiný název pole pro filtrování), zvolte Vložit řádek. Řádky můžete seskupit přidáním prázdného řádku. Přidáním operátoru A nebo Nebo do prázdného řádku můžete filtrovat skupinu proti druhé.
- Až to budete mít, zvolte Uložit.
Tip:
Pokud chcete rychle odebrat všechny filtry, použijte klávesu F3. Mějte na paměti, že filtry úkolů fungují jenom se zobrazeními úkolů a filtry zdrojů fungují jenom se zobrazeními zdrojů.
Úprava existujícího filtru
Na kartě Zobrazení ve skupině Data vyberte seznam filtrů a potom zvolte Další filtry.
Udělejte jednu z těchto věcí:
- Pokud chcete upravit filtr úkolu, zvolte Úkol, vyberte filtr, který chcete upravit, a pak zvolte Upravit.
- Pokud chcete upravit filtr zdrojů, zvolte Zdroj, zvolte filtr, který chcete upravit, a pak zvolte Upravit.
Nastavení filtru můžete upravit pomocí ovládacích prvků v dialogovém okně Definice filtru .
Použití automatických filtrů
Automatický filtr můžete použít u polí v libovolném zobrazení listu. Kromě standardních filtrů obsahuje Project také automatické filtry, které jsou v zobrazení listů viditelné v horní části každého sloupce.
Použití a odebrání automatických filtrů
Na kartě Zobrazení klikněte ve skupině Data na šipku seznamu filtrů a pak zvolte Zobrazit automatický filtr.
Zvolte šipku automatického filtru vedle záhlaví sloupce s informacemi, které chcete zobrazit, a pak vyberte hodnotu pro filtrování tabulky.
Šipka automatického filtru a záhlaví pole se změní na modrou.Pokud chcete použít další podmínku založenou na hodnotě v jiném sloupci, opakujte krok 2 pro druhý sloupec.
Pokud chcete odebrat filtrování na konkrétním řádku, zvolte pro dané pole v seznamu automatického filtru možnost Vymazat všechny filtry .
Pokud chcete automatické filtry vypnout, zvolte znovu Zobrazit automatický filtr .
Poznámka
Pokud se změní informace v některém z řádků v zobrazení, můžete aktualizovat nastavení automatického filtru výběrem šipky a opětovným výběrem hodnot filtru.
Vytvoření vlastního automatického filtru
Zobrazit automatické filtry.
Klikněte na šipku automatického filtru, přejděte na příkaz Filtr a pak zvolte příkaz Vlastní.
V prvním poli zvolte operátor, který chcete použít, a v druhém poli zadejte nebo vyberte hodnotu, kterou chcete použít.
Pokud třeba chcete najít shodné datum v poli data, zvolte v prvním poli operátor rovná se a pak vyberte požadované datum v druhém poli.Chcete-li u automatického filtru použít dvě podmínky, proveďte jednu z následujících akcí:
- Pokud chcete v zobrazení zobrazit řádky, které splňují obě podmínky, zvolte v druhém řádku polí požadovaný operátor a hodnotu a pak zvolte A.
- Pokud chcete v zobrazení zobrazit řádky, které splňují jednu nebo druhou podmínku, zvolte v druhém řádku polí požadovaný operátor a hodnotu a pak zvolte Or.
Chcete-li nastavení automatického filtru uložit, zvolte Uložit.
Pokud je v zobrazení již použit předdefinovaný filtr, budou podmínky nastavené pro automatický filtr zahrnuty jako dodatečné podmínky aktuálního filtru. Když uložíte nastavení automatického filtru, uloží se filtr s ostatními filtry v souboru a je k dispozici jenom v dialogovém okně Další filtry .
Automatické zapnutí automatických filtrů pro nové projekty
- Na kartě Soubor zvolte Možnosti.
- Zvolte Upřesnit a potom v části Obecné zaškrtněte políčko Nastavit automatický filtr pro nové projekty .