Příznaky
Předpokládejme, že používáte dynamický port SFTP. Pokud při upgradu Microsoft BizTalk Server z verze 2013 nebo 2013 R2 na verzi 2016 adresa SFTP používaná za běhu neurčuje číslo portu, přestane dynamický port SFTP fungovat s následující chybou:
System.ArgumentException: Číslo portu nemůže být záporné
Stav
Společnost Microsoft potvrdila, že se jedná o problém produktů Microsoft, které jsou uvedeny v sekci Platí pro.
Řešení
Tento problém je opravený v následující kumulativní aktualizaci pro BizTalk Server:
- Kumulativní aktualizace 6 pro BizTalk Server 2016
Poznámka Číslo portu 22 se automaticky použije, pokud v adrese serveru SFTP, která se používá za běhu, není zadané žádné číslo portu.
Alternativní řešení
Když v BizTalk Server 2013 nebo 2013 R2 není zadané číslo portu, použije se ve výchozím nastavení výchozí číslo portu SFTP 22. V BizTalk Server 2016 se ve výchozím nastavení používá hodnota -1. To je příčinou chyby a vyžaduje, aby adresy dynamických portů pro odesílání výslovně obsahovaly výchozí číslo portu. Příklady:
SFTPDynSendMsg(Microsoft.XLANGs.BaseTypes.Address)= "sftp://127.0.0.1:22test//" + "%MessageID%.xml";
Místo bez čísla portu:
SFTPDynSendMsg(Microsoft.XLANGs.BaseTypes.Address)= "sftp://127.0.0.1//test//" + "%MessageID%.xml";
Reference
Informace o aktualizacích Service Pack a seznamu kumulativních aktualizací pro BizTalk Server najdete v následujícím článku znalostní báze znalostní báze Microsoft Knowledge Base:
2555976 Aktualizace Service Pack a seznam kumulativních aktualizací pro BizTalk Server
Další informace o opravách hotfix pro BizTalk Server najdete v následujícím článku znalostní báze znalostní báze Microsoft Knowledge Base:
2003907 Informace o opravách hotfix BizTalk a podpoře kumulativních aktualizací