Příznaky
Předpokládejme, že klient používá prázdný kontext k vyvolání služby Microsoft Distributed Connectivity Services (DCS) v Microsoft Customer Care Framework (CCF) 2009. V tomto scénáři vlákno služby používá předchozí kontext, který inicializoval jiný klient.
Příčina
K tomuto problému dochází, protože statická proměnná vlákna je nastavena na hodnotu kontextu předchozího volání klienta, když aktuální volání klienta neprojde žádným kontextem.
Řešení
Informace o opravě hotfix
Od Microsoftu je teď k dispozici podporovaná oprava hotfix. Jeho cílem je však opravit pouze problém popsaný v tomto článku. Aplikujte ho jenom na systémy, ve kterých dochází k tomuto konkrétnímu problému. Tato oprava hotfix může projít dalším testováním. Pokud se vás tedy tento problém vážně netýká, doporučujeme, abyste počkali na další opravu hotfix.
Chcete-li tyto potíže vyřešit okamžitě, obraťte se na služby podpory zákazníků společnosti Microsoft a získejte opravu hotfix. Úplný seznam telefonních čísel služeb podpory zákazníků společnosti Microsoft a informace o cenách podpory naleznete na následujícím webu společnosti Microsoft:
http://support.microsoft.com/contactus/?ws=supportPoznámka: Ve zvláštních případech mohou být poplatky, které jsou obvykle účtovány za volání podpory, zrušeny, pokud odborník na podporu Microsoftu určí, že konkrétní aktualizace vyřeší váš problém. Další dotazy a problémy týkající se podpory, které se netýkají této konkrétní opravy, podléhají běžným sazbám za podporu.
Poznámky
- Očekává se, že tato oprava hotfix bude použita na počítačích, které hostují základní službu DCS a které hostují aplikace cílové služby. Pokud tuto opravu hotfix použijete na klientovi, zůstane klient touto opravou hotfix nedotčen.
- Další informace o instalaci tohoto balíčku opravy hotfix naleznete v dokumentu README_HOTFIX, který je součástí balíčku opravy hotfix.
Požadavky
Tuto opravu hotfix musíte nainstalovat do počítače s následujícím softwarem:
Služba DCS (Distributed Connectivity Services) Service Pack 1 (SP1)
DCS Service Pack 1 (SP1) Obchodní logika Rozšíření sady Visual Studio
Všechny předchozí opravy hotfix Microsoft Customer Care Framework (CCF) 2009. Zvláště následující:
Poznámky
Další informace o provedení čisté instalace aktualizace DCS SP1 naleznete na následujícím webu Microsoft TechNet:
Tuto opravu hotfix je možné použít jen ve verzi Microsoft.ConnectedIndustry.ServiceModel.dll 1.5.0.93 nebo novější.
Informace o souborech
Anglická verze této opravy hotfix má následující (nebo pozdější) atributy souborů. Data a časy pro tyto soubory jsou uvedeny v čase UTC (Coordinated Universal Time). Při zobrazení informací o souboru jsou převedeny na místní čas. Rozdíl mezi místním časem a časem UTC naleznete na kartě Časové pásmo na panelu Datum a čas v okně Ovládací panely.
| Název souboru | Verze souboru | Velikost souboru | Datum | Čas | Platforma |
|---|---|---|---|---|---|
| Context_threading_issue_fixdll.bat | Nejde použít | 5,210 | 24. října 2010 | 14:39 | Nejde použít |
| Microsoft.connectedindustry.servicemodel.application.dll | 1.5.0.130 | 223,040 | 24. října 2010 | 14:39 | x86 |
Stav
Společnost Microsoft potvrdila, že se jedná o problém produktů Microsoft, které jsou uvedeny v sekci Platí pro.