OPRAVA: Microsoft ADO.NET provider for DB2 fails to read data stored in DB2 for z/OS V11 BLOB and CLOB columns, které jsou větší než 1 048 576 bajtů

Platí pro
Host Integration Server 2016

Příznaky

Zprostředkovatel Microsoft ADO.NET pro DB2 nedokáže přečíst data uložená v databázi DB2 pro z/OS V11, sloupce BLOB a CLOB, které jsou větší než 1 048 576 bajtů.
V takovém případě se může zobrazit následující chybová zpráva:

Není podporovaný formát obchodních dat. SQLSTATE HY000 s kódem SQLCODE -343

Příčina

Microsoft ADO.NET Provider for DB2 a podkladový klient Microsoft DRDA Application Requester Client for DB2 nezpracovávají datové hodnoty DB2 for z/OS V11 BLOB a CLOB, které jsou delší než 1 048 576 bajtů.

Stav

Společnost Microsoft potvrdila, že se jedná o problém produktů Microsoft, které jsou uvedeny v sekci Platí pro.

Řešení

Tento problém je opravený v následující kumulativní aktualizaci pro Host Integration Server:

Poznámka Zprostředkovatel Microsoft ADO.NET Provider pro DB2 a podkladový klient Microsoft DRDA Application Requester Client pro DB2 byly opraveny tak, aby podporovaly převod dat pro DB2 pro z/OS V11 BLOB a CLOB, které jsou delší než 1 048 576 bajtů.

Reference

Podívejte se na informace o terminologii, kterou společnost Microsoft používá k popisování aktualizací softwaru.