OPRAVA: Zprostředkovatel ADO.NET pro DB2 nezpracovává statický příkaz SQL INSERT s hodnotami parametrů NULL vůči DB2 pro LUW

Platí pro
Host Integration Server 2016

Příznaky

Zprostředkovatel ADO.NET pro DB2 nezpracovává statický příkaz SQL INSERT s hodnotami parametrů NULL proti DB2 pro LUW (Linux, UNIX, Windows). Navíc vrátí následující chybu:

SQLSTATE 07002, SQLCODE -309

Hodnota proměnné hostitele v příkazu OPEN je NULL, ale její odpovídající použití nemůže být NULL.

Příčina

Zprostředkovatel ADO.NET pro DB2 nekóduje správně hodnoty NULL při zpracování statických příkazů SQL INSERT proti DB2 pro LUW.

Stav

Společnost Microsoft potvrdila, že se jedná o problém produktů Microsoft, které jsou uvedeny v sekci Platí pro.

Řešení

Tento problém je opravený v následující kumulativní aktualizaci pro Host Integration Server:

Reference

Podívejte se na informace o terminologii, kterou společnost Microsoft používá k popisování aktualizací softwaru.