Chyba "Neplatná adresa URL EWS: URL>" <v nastavení overlay v CalendarService.ashx (KB5064829)

Platí pro
SharePoint Server Subscription Edition SharePoint Server 2019 SharePoint Server 2016

Příznaky

Po konfiguraci parametru adresy URL webové služby Exchange v nastavení překrytí Calendar zobrazí soubor CalendarService.ashx chybovou položku Neplatná adresa URL EWS. <> Když dojde k tomuto problému, zaznamenají se do protokolů služby SharePoint ULS (Unified Logging System) následující položka chyby a značky události "583ga" nebo "apmev":

Poznámka

ExchangeAccess: Zabránění neplatnému volání. ServiceURL='{0}'.",

Příčina

Kvůli zachování bezpečnosti nejsou ve výchozím nastavení na SharePoint Serveru povolené žádné adresy URL webových služeb Exchange.

Řešení

Poznámka

Ujistěte se, že je blokovaná adresa URL bezpečná, než budete postupovat podle těchto pokynů k jejímu odblokování.

Pokud chcete tento problém vyřešit, můžou správci farmy spustit následující příkazy PowerShellu a přidat blokovanou adresu URL do AllowedSafeDomain:

add-pssnapin * 
$f=get-spfarm 
$f.AllowedSafeDomain.Add("<host>") 
$f.update() 

Například:

$f.AllowedSafeDomain.Add("smtp.office365.com")