Verzi této aplikace pro Microsoft Publisher 98 najdete v článku 191131.

Shrnutí

Pokud při používání publikace v aplikaci Microsoft Publisher dochází k neočekávanému chování, může být publikace poškozená. Mezi příznaky poškozené publikace patří:

  • Obdržíte chybovou zprávu o neplatnosti, obecnou chybu ochrany nebo neplatnou instrukci.

  • Při pokusu o otevření publikace se zobrazí jedna z následujících chybových zpráv:

    – Toto není publikace Publisheru.

    -Publisher nemůže otevřít typ souboru reprezentovaného <název_souboru>.

    – Chybí část souboru.

  • Zobrazí se chybová zpráva o nedostatku paměti nebo chybová zpráva o nízkém systémových prostředcích.

Poznámka Některé z těchto chybových zpráv se mohou zobrazit pro jiné než poškozené publikace. Pokud k tomuto chování dochází jenom v případě, že používáte určitou publikaci, je tato publikace pravděpodobně poškozená.

Další informace

Tento problém vyřešíte restartováním počítače v nouzovém režimu. Potom použijte pro váš problém příslušné metody řešení potíží.Poznámka: Vzhledem k různým verzím Microsoft Windows se následující postup může v počítači lišit. Pokud jsou uvedené, Projděte si dokumentaci k produktu.

Restartování počítače v nouzovém režimu

Pokud chcete restartovat počítač v nouzovém režimu, použijte příslušnou metodu pro vaši verzi Microsoft Windows.

  1. Vypněte a restartujte počítač.

  2. Po zobrazení zprávy "vyberte operační systém, který chcete spustit" stiskněte klávesu F8.

  3. V nabídce Upřesnit možnosti systému Windows vyberte pomocí kláves se šipkami Nouzový režima pak stiskněte ENTER.

  4. Pokud máte počítač se dvěma operačními systémy nebo počítač s možností spouštění více konfigurací, vyberte v seznamu příslušný operační systém a stiskněte ENTER.

Další informace o nouzovém režimu najdete v následujících článcích znalostní báze Microsoft Knowledge Base:

315222 Popis možností spuštění nouzového režimu v systému Windows XP

202485 Popis režimu bezpečného spuštění ve Windows 2000

180902 Jak spustit počítač se systémem Windows 98 v nouzovém režimu

Pokusu o otevření publikace

Po spuštění počítače v nouzovém režimu Zkuste publikaci otevřít. Pokud se chybová zpráva nezobrazuje, program nebo zařízení, které je načteno, když je počítač v normálním režimu, může narušit publikaci.

Pokud publikaci nemůžete otevřít

Pokud nemůžete publikaci po spuštění počítače v nouzovém režimu otevřít, použijte následující metody v uvedeném pořadí.

Vložení publikace do souboru aplikace Publisher

Publikaci můžete otevřít tak, že ji vložíte do souboru aplikace Publisher. Postupujte takto:

  1. Spusťte Průzkumníka Windows.

  2. Vyhledejte soubor publikace.

  3. Klikněte pravým tlačítkem na soubor publikace a potom klikněte na Kopírovat.

  4. Ukončete Průzkumníka Windows.

  5. Klikněte na tlačítko Start, na příkaz Spustit, do pole otevřít zadejte jeden z následujících řádků a klikněte na tlačítko OK:

    Publisher 2003c:\Program Files\Microsoft Office\Office11for Publisher 2002c:\Program Files\Microsoft Office\Office10for Publisher 2000c:\Program Files\Microsoft Office\Office

  6. Klikněte pravým tlačítkem na soubor programu MSPUB. exe a pak klikněte na Vložit.

Pokud publikaci nemůžete otevřít, přejděte na další metodu.

Poklikejte na soubor publikace v Průzkumníkovi Windows

Pokud chcete v Průzkumníkovi Windows poklikejte na soubor publikace, postupujte takto:

  1. Klikněte na tlačítko Start, přejděte na příkaz programya klikněte na položku Průzkumník Windows.

  2. Vyhledejte soubor publikace.

  3. Poklikejte na soubor publikace.

Pokud publikaci nemůžete otevřít, přejděte na další metodu.

Správa obrázků v aplikaci Publisher

Pokud chcete, aby Publisher skryl obrázky, postupujte takto:

  1. Spusťte Publisher a otevřete novou, prázdnou publikaci.

  2. V nabídce zobrazení klikněte na zobrazení obrázku v Publisheru 2000 nebo klikněte na obrázky v Publisheru 2003 nebo Publisher 2002.

  3. Klikněte na Skrýt obrázkya potom na OK.

  4. V nabídce soubor klikněte na otevřít.

  5. Vyhledejte soubor publikace.

  6. Kliknutím vyberte publikaci a klikněte na otevřít.

Pokud můžete publikaci otevřít, publikace může obsahovat poškozený objekt nebo objekt. Pokud chcete odebrat nebo nahradit poškozený zástupný objekt nebo objekt, přejděte na další metodu. Pokud publikaci nemůžete otevřít, přejděte na metodu "zkopírování publikace do druhého počítače".

Vyhledání a odebrání poškozeného objektu nebo objektu

Pokud chcete vyhledat a odebrat poškozený zástupný objekt nebo objekt, postupujte takto:

  1. V publikaci klikněte pravým tlačítkem myši na zástupný symbol objektu a potom klikněte na Odstranit objekt.

  2. V nabídce soubor klikněte na Uložit jako.

  3. Do pole název zadejte nový název publikace a klikněte na Uložit.

  4. V nabídce zobrazení klikněte na zobrazení obrázku v Publisheru 2000 nebo klikněte na obrázky v Publisheru 2003 nebo Publisher 2002.

  5. Klikněte na podrobný displeja potom klikněte na OK.Poznámka Pokud se zobrazí chybová zpráva, přejděte na krok 8.

  6. V nabídce soubor klikněte na Zavřít.

  7. V nabídce soubor klikněte na otevříta potom klikněte na publikaci, kterou jste uložili v kroku 3. Pokud můžete publikaci otevřít, objekt nebo zástupný symbol objektu, který jste odstranili v kroku 1, je poškozený. Upravte rozložení na zástupný symbol objektu nebo objektu. Můžete taky vytvořit nový zástupný symbol objektu a nahradit odstraněný objekt nepoškozeným. K tomu použijte metodu, která je vhodná pro váš zdroj objektu.Z Galerie klipartů

    1. V nabídce Vložit přejděte na Obrázeka klikněte na Klipart.

    2. V jedné z kategorií, které jsou k dispozici, kliknutím vložte obrázek, zvuk nebo požadovaný klip.

    3. Uložte a zavřete publikaci. Potom zkuste publikaci znovu otevřít.

    Z jiného místa než Galerie klipartů

    1. Pomocí nástroje rámeček obrázku nakreslete zástupný symbol pro nový objekt.

    2. Kliknutím vyberte zástupný symbol, v nabídce Vložit přejděte na Obrázek a potom klikněte na ze souboru.

    3. Vyhledejte obrázek, který chcete vložit, a kliknutím ho vyberte.

    4. Klikněte na Vložit.

    5. Uložte a zavřete publikaci. Potom zkuste publikaci znovu otevřít.

    Pokud publikaci nemůžete otevřít, opakujte metodu "Configure Publisher to Hide obrázků". Přejděte na krok 8.

  8. Opakujte kroky 1 až 7, dokud nebudete moct otevřít publikaci s povolenou možností podrobné zobrazení .

  9. Když můžete otevřít publikaci, použijte jednu z těchto metod:

    • Nahradí odstraněný zástupný objekt nebo objekt jiným, který není poškozený.

    • Upravte rozložení na zástupný symbol objektu nebo objektu.

  10. V nabídce soubor klikněte na Uložit.

Pokud se vám pořád nedaří publikaci otevřít, přejděte na další metodu.

Přesunutí souboru publikace na jiný disk

Pokud je soubor publikace uložený na výměnném disku, jako je třeba disketa nebo disk zip, může se stát, že systém Windows nemůže soubor přečíst. V tomto scénáři zkopírujte soubor na pevný disk. Pokud nemůžete zkopírovat soubor z vyměnitelného disku, může se stát, že soubor bude přecházet z propojení s jinými soubory nebo složkami. Případně může být soubor umístěn v poškozeném sektoru disku. V obou případech přejděte na metodu spuštění kontroly chyb na disku.

Zkopírování publikace do druhého počítače

V některých scénářích můžete po zkopírování publikace do druhého počítače s nainstalovanou aplikací Publisher otevřít poškozenou publikaci. Postupujte takto:

  1. Spusťte Průzkumníka Windows.

  2. Vyhledejte soubor publikace.

  3. Klikněte pravým tlačítkem na soubor publikace a potom klikněte na Kopírovat.

  4. Pomocí jedné z následujících metod zkopírujte publikaci do druhého počítače:

    • Zkopírujte soubor publikace na vyměnitelný disk, třeba na disketu nebo na disk zip. Potom zkopírujte publikaci z vyměnitelného disku do druhého počítače.

    • Zkopírujte soubor publikace do druhého počítače v síti.

  5. Na druhém počítači spusťte Průzkumníka Windows.

  6. Najděte soubor publikace a poklikejte na něj.

Pokud můžete otevřít publikaci, prozkoumejte jednotlivé stránky, abyste zjistili, jestli jsou nějaké zástupné symboly prázdného objektu. V každém nalezeném zástupném symbolu pro prázdný objekt klikněte pravým tlačítkem myši na soubor a potom klikněte na příkaz Odstranit. Uložte publikaci a pak ji zkopírujte zpátky do prvního počítače. Pokud publikaci nemůžete otevřít, přejděte na další metodu.

Spuštění kontroly chyb na disku

Spuštěním kontroly chyb opravíte všechny chyby na disku. Dejte pokyn kontrole chyb, abyste opravili všechny soubory křížových propojení a převedli ztracené fragmenty na soubory.Poznámka Přestože kontrola chyb může zjistit, že je křížový odkaz na soubor publikace, a potom soubor opravit, tento způsob nezaručuje, že se může Publisher přečíst po kontrole a opravě chyb. Pokud chcete spustit kontrolu chyb, postupujte takto:

  1. Ukončete všechny spuštěné aplikace.

  2. Poklikejte na ikonu Tento počítač na ploše.

  3. Klikněte pravým tlačítkem na místní disk, který chcete zkontrolovat, a potom klikněte na vlastnosti.

  4. Na kartě nástroje klikněte na zkontrolovat v části Kontrola chyb.

  5. V části Možnosti kontroly diskuzaškrtněte políčko Vyhledat a pokusit se obnovit chybné sektory . Potom klikněte na Start.

  6. Když Kontrola chyb dokončuje a opravuje chyby, klikněte na Zavřít.

  7. Spusťte Publisher a zkuste publikaci otevřít.

Pokud publikaci nemůžete otevřít, přejděte na další metodu.

Pokusit se obnovit text v publikaci

Tento způsob popisuje, jak obnovit text z poškozené publikace a jak vložit obnovený text do nové prázdné publikace. Musíte pak znovu vytvořit rozložení a znovu vložit všechny objekty z poškozené publikace do nové publikace. Pokud chcete obnovit text z poškozené publikace a pak vložit text do nové publikace, postupujte takto:

  1. Spusťte Publisher a vytvořte novou, prázdnou a celou stránku.

  2. Pomocí nástroje textový rámeček v Publisheru 2000 nebo v nástroji textový rámeček v Publisheru 2003 nebo Publisher 2002 nakreslete textový rámeček na prázdné stránce.

  3. V nabídce Vložit klikněte na textový soubor.

  4. V poli typ souborů klikněte nasoubory aplikace Publisher (*. pub).

  5. Klikněte na publikaci a potom klikněte na OK. Pokud se zobrazí zpráva, že se text, který chcete vložit, vejde na stránku, klikněte na Ano.

Pokud můžete otevřít poškozenou publikaci

Pokud můžete otevřít publikaci v nouzovém režimu, použijte k opětovnému vytvoření publikace jednu z následujících metod.

Kopírování stránek z poškozené publikace do nové publikace

Pokud chcete zkopírovat stránky z poškozené publikace do nové, postupujte takto:

  1. Spusťte Publisher a otevřete poškozenou publikaci.

  2. Spuštění další instance aplikace Publisher

  3. Vytvořte novou prázdnou publikaci, která je nakonfigurovaná stejně jako u poškozené publikace.

  4. V poškozené publikaci vyberte všechny objekty na určité stránce.

  5. V nabídce Úpravy klikněte na Kopírovat.

  6. Stisknutím kombinace kláves ALT + TAB přepněte do nové publikace.

  7. V nabídce Úpravy klikněte na Vložit.

  8. Opakujte kroky 4 až 7, dokud všechny stránky nevložíte do nové publikace.

Poznámka Pokud zaznamenáte odlišné chování nové publikace po zkopírování stránky do nové publikace, tato zkopírovaná stránka pravděpodobně obsahuje poškozený objekt. Tento problém můžete vyřešit jedním z následujících způsobů:

  • Zkopírujte na novou publikaci jeden objekt ze stránky problému a zjistěte, který objekt je poškozený. Potom se ujistěte, že jste do nové publikace nezahrnuli poškozený objekt.

  • Znovu vytvořte stránku s problémy v nové publikaci.

Pokud jsou všechny stránky v publikaci poškozené, přejděte na další metodu.

Uložení publikace ve formátu RTF (Rich Text Format)

Pokud je poškození vaší publikace široké, uložte text publikace uložením ve formátu RTF. Postupujte takto:

  1. Otevřete publikaci.

  2. Klikněte na textový rámeček.

  3. V poli Uložit jako typ klikněte naFormát RTF (*. RTF).

  4. Do pole název souboru zadejte požadovaný název souboru.

  5. V poli Uložit do klikněte na složku, do které chcete uložit text publikace.

  6. Klikněte na Uložita potom na OK.

  7. Zavřete publikaci.

  8. V nabídce soubor klikněte na otevřít.

  9. V poli typ souborů klikněte naFormát RTF (*. RTF).

  10. V seznamu souborů klikněte na textový soubor, který jste uložili v kroku 6.

  11. Klikněte na možnost Otevřít.

  12. Rozvrhnout a formátujte text způsobem, který duplikuje způsob rozložení a formátování textu v poškozené publikaci.

Odkazy

Další informace o řešení potíží s poškozenými publikacemi aplikace Publisher najdete v následujících článcích znalostní báze Microsoft Knowledge Base:

315222 Popis možností spuštění nouzového režimu v systému Windows XP

164519 Řešení chyb Office Kernel32. dll v systému Windows 95

179095 Chyba odkazu na soubor při otevírání Publisheru

Potřebujete další pomoc?

Rozšiřte své znalosti a dovednosti
Projít školení
Získejte nové funkce jako první
Připojit se k programu Microsoft Insider

Byly tyto informace užitečné?

Jak jste spokojeni s kvalitou překladu?
Co ovlivnilo váš názor?

Děkujeme za váš názor!

×