Příznaky
Zvažte následující scénář.
-
Otevřete formulář aplikace Microsoft InfoPath kliknutím na název formuláře v knihovně formulářů služby SharePoint.
-
Než formulář otevřete, nerezervujte dokument formuláře.
-
Knihovna, ve které je formulář umístěný, je nakonfigurovaná tak, aby vyžadovala rezervaci dokumentů. Neobdrží se ale zpráva, že je nutné formulář rezervovat.
-
Změníte formulář a pak se pokusíte přepsat původní formulář jedním z následujících způsobů:
-
Kliknete na ikonu Uložit.
-
Klikněte na ikonu Uložit jako, ale zkuste soubor přepsat tím, že poskytnete stejnou cílovou složku a název souboru.
-
V tomto scénáři se zobrazí následující chybová zpráva:
Aplikace InfoPath nemůže formulář uložit. Zadané umístění není platné nebo není k dispozici. Zkontrolujte pravopis názvu souboru a ověřte, jestli je správné.
PoznámkaPokud otevřete formulář kliknutím na Upravit v prohlížeči v rozevírací nabídce formuláře, zobrazí se výzva k rezervaci formuláře.
Příčina
K tomuto chování dochází, protože aplikace InfoPath z SharePointu obdrží chybu "přístup odepřen". Aplikace InfoPath obdrží tento výsledek chyby v případě, že se v aplikaci InfoPath pokusí získat zámek pro cílový soubor k přepsání cílového souboru. K tomuto výsledku chyby dochází, protože dokument není rezervovaný.
Řešení
Tento problém vyřešíte tak, že před změnou formuláře rezervujte dokument formuláře. To provedete tak, že v knihovně formulářů vyhledáte dokument formuláře a v seznamu vedle něj kliknete na Rezervovat . Pokud si nejste jistí, jestli je potřeba dokument rezervovat, otevřete rozevírací nabídku pro formulář a kliknutím na Upravit v Microsoft InfoPathu otevřete formulář. Pokud je to potřeba, vrátí aplikace InfoPath následující zprávu:
Tuto položku musíte před provedením změn rezervovat. Chcete tuto položku Rezervovat hned?
Další informace
Pokud jste už v dokumentu neprovedli změny, které jste si nerezervovali, můžete je uložit pomocí ikony Uložit jako a zadat nový název souboru nebo umístění pro formulář. Pokud spravujete SharePointový web a zjistíte, že k tomuto problému dochází často, můžete zvážit provedení jedné z následujících změn:
-
Přidejte do šablony formuláře aplikace InfoPath textovou zprávu, která uživatelům připomene, že si ji před úpravami vyjímá.
-
V nastavení správy verzí knihovny nastavte možnost vyžadovat rezervaci na ne.
-
Změňte typ formuláře šablona formuláře z formuláře webového prohlížeče na formulář pro vyplnění formuláře a pak šablonu znovu publikujte.