Příznaky

Když se pokusíte změnit výchozí společnost pro uživatele, zobrazí se následující chybová zpráva:

Chyba skriptu v Internet Exploreru Ve skriptu na této stránce došlo k chybě. Řádek: 127 znaků: 3 Chyba: Access je odepřen Kód: 0 ADRESAURL:http:// XXX /businessportal/portal/administration/AC_DefaultCompany.aspx? ID_uživatele=IDENTIFIKÁTOR GUID

V této chybové zprávě představuje identifikátor GUID identifikátor GUID uživatele, u kterého jste se pokusili změnit výchozí společnost.K tomuto problému dochází v aplikaci Business Portal 3.0 v aplikaci Microsoft Dynamics GP, v portálu Business Portal 3.0 v produktu Microsoft Dynamics SL a na portálu Microsoft Business Solutions Business Portal 2.5.Poznámka: Tato chybová zpráva se zobrazí, jenom když se pokusíte změnit výchozí společnost uživatele, který nemá přiřazenou roli správce.

Příčina

K tomuto problému dochází, protože pole Výchozí společnost je uživatelem definované pole, nikoli pole definované správcem. Protože tedy uživatel nemá přiřazenou roli Správce, nemůžete změnit výchozí společnost tohoto uživatele na kartě Web Nastavení na portálu Business Portal 3.0 nebo na portálu Microsoft Business Portal 2.5.

Řešení

Pokud chcete tento problém vyřešit, použijte jednu z následujících metod.

Metoda 1: Nechte uživatele změnit výchozí společnost

Jednotlivý uživatel může změnit svoji výchozí společnost pomocí možnosti Můj Nastavení v portálu Business Portal 3.0, na portálu Microsoft Business Portal 2.5 nebo v 2.5 Feature Pack pro Microsoft Business Portal.

Metoda 2: Dočasné přiřazení role správce uživateli

Důležité: Tento postup může zvýšit vaše bezpečnostní riziko. Tento postup může také způsobit, že váš počítač nebo síť budou zranitelnější vůči útokům uživatelů se zlými úmysly nebo škodlivým softwarem, jako jsou viry. Doporučujeme použít postup uvedený v tomto článku, který umožňuje, aby programy pracovaly zamýšleným způsobem, nebo použít specifické možnosti programů. Před provedením změn však doporučujeme vyhodnotit nebezpečí spojená s nasazením daného postupu v konkrétním prostředí. Pokud se rozhodnete tento proces implementovat, udělejte další vhodné kroky k ochraně systému. Doporučujeme tento postup použít pouze tehdy, pokud je to opravdu nutné.Pokud chcete změnit výchozí společnost pro uživatele, který není správcem, postupujte takto:

  1. Přiřaďte roli Správce uživateli, u kterého chcete změnit výchozí společnost:

    1. Přihlaste se k portálu Business Portal 3.0 nebo k portálu Microsoft Business Portal 2.5.

    2. Klikněte na Nastavenía potom na Spravovat uživatele portálu Business Portal v části Uživatelé a oprávnění.

    3. V seznamu uživatelů kliknětena uživatele, který není správcem, u kterého chcete změnit výchozí společnost.

    4. V podokně Vlastnosti uživatele klikněte na Změnit vedle seznamu Role portálu.

    5. V dialogovém okně Upravit role – webová stránka, které se zobrazí, zaškrtněte políčko Správce a potom klikněte na OK.

  2. Změňte výchozí společnost pro tohoto uživatele na portálu Business Portal 3.0 nebo Na portálu Microsoft Business Portal 2.5.

  3. Odeberte roli Správce od tohoto uživatele.

Další informace

Postup pro reprodukci chování

  1. Přihlaste se k portálu Business Portal 3.0 nebo k portálu Microsoft Business Portal 2.5.

  2. Klikněte na kartu Web Nastavení a potom klikněte na Spravovat uživatele portálu Business Portal.

  3. Klikněte na uživatele, který není správcem, a zkuste změnit výchozí společnost pro tohoto uživatele.

Zobrazí se chybová zpráva uvedená v části Příznaky.

Potřebujete další pomoc?

Chcete další možnosti?

Prozkoumejte výhody předplatného, projděte si školicí kurzy, zjistěte, jak zabezpečit své zařízení a mnohem více.