Důležité
Tento článek popisuje známý problém s kompatibilitou mezi aplikací Adobe Acrobat 7.0 a staršími verzemi systému systém Microsoft Office. Pokud používáte aktuální verzi Microsoft 365 nebo novější verzi Adobe Acrobatu, tento článek se nemusí vztahovat na vaše prostředí.
Příznaky
Při používání aplikace systému systém Microsoft Office uvedené v části Informace v tomto článku jsou určeny pro produkt v tomto článku se mohou vyskytnout některé z následujících příznaků:
Pokud změníte pracovní prostor v aplikaci Microsoft Word, nebudou změny při ukončení aplikace Word uloženy. Tyto změny pracovního prostoru zahrnují následující příklady:
- Vytvoříte makro.
- Změníte výchozí písmo.
- Přidáte položku automatického textu.
- Přidáte panel nástrojů.
Po restartování aplikace Word nebudou položky, které jste změnili nebo přidali, k dispozici.
Poznámka: K tomuto chování dochází i v případě, že je zaškrtnuto políčko Výzva k uložení šablony Normal .
Při pokusu o spuštění aplikace systému Office se zobrazí chybová zpráva podobná jedné z následujících zpráv:
Poznámka
Chyba modulu runtime Visual C++
Poznámka
Běhová knihovna Microsoft Visual C++
Program files\Microsoft office\office10\product name.exe
Tato aplikace požádala modul runtime o její ukončení neobvyklým způsobem.
Při otevření dokumentu aplikace Word se zobrazí následující chybová zpráva:
Poznámka
Není k dispozici dostatek paměti nebo místa na disku. Word nemůže zobrazit požadované písmo.
Po zavření Word otevřete soubor v Word poklikáním. V tomto scénáři Word přestane reagovat (přestane reagovat).
Příčina
K těmto problémům může dojít po instalaci elementů pro Adobe Acrobat 7.0 Professional, Adobe Acrobat 7.0 Standard nebo Adobe Acrobat 7.0.
Aplikace Acrobat 7.0 nainstaluje doplněk modelu COM do následující složky:
\Acrobat 7.0\PDFMaker\OfficeTento doplněk modelu COM poskytuje aplikacím Office ikony a příkazy nabídek aplikace PDFMaker.
Alternativní řešení
Pokud chcete tento problém vyřešit, použijte jednu z následujících metod v závislosti na vaší situaci. Pokud se změny při ukončení aplikace Word neuloží, použijte metodu 1 nebo 2. Pokud se při pokusu o spuštění aplikace Office nebo otevření dokumentu aplikace Word zobrazí chybová zpráva, použijte metodu 3 nebo metodu 4.
Metoda 1: Uložení maker, předvoleb a vlastních nastavení v aplikaci Word pomocí příkazu Uložit vše v nabídce Soubor
Poznámka: Tuto metodu nejde použít u aplikace systém Microsoft Office Word 2007.
Chcete-li makra, předvolby a vlastní nastavení v aplikaci Word 2003 a v dřívějších verzích aplikace Word uložit ručně, postupujte takto:
- Stiskněte a podržte klávesu SHIFT.
- V nabídce Soubor klikněte na Uložit vše.
Změny se uloží. Změny jsou navíc dostupné i v jiných dokumentech aplikace Word.
Metoda 2: Přidání příkazu Uložit vše
V Word klikněte na příkaz Uložit vše pokaždé, když vytvoříte makro, předvolbu nebo vlastní nastavení.
Pokud chcete do aplikace Word přidat příkaz Uložit vše, proveďte jednu z následujících akcí:
V aplikaci Word 2007 přidáte příkaz Uložit vše na panel nástrojů Rychlý přístup takto:
- Klikněte na tlačítko Microsoft Office a potom klikněte na Možnosti aplikace Word.
- Klikněte na Přizpůsobit.
- V rozevíracím seznamu Zvolit příkazy z klikněte na Všechny příkazy.
- V seznamu pod rozevíracím seznamem Zvolit příkazy z klikněte na Uložit vše a potom klikněte na Přidat.
- Kliknutím na tlačítko OK zavřete dialogové okno Možnosti aplikace Word.
V aplikaci Word 2003 a dřívějších verzích aplikace Word přidejte příkaz Uložit vše do nabídky Soubor následujícím postupem:
- V nabídce Tools (Nástroje ) klikněte na Customize (Přizpůsobit).
- Na kartě Příkazy klikněte v části Kategorie na Soubor.
- V části Příkazy přetáhněte Uložit vše do nabídky Soubor . Když se otevře nabídka Soubor , umístěte příkaz Uložit vše tam, kde ho chcete mít.
- Zavřete dialogové okno Přizpůsobit .
Metoda 3: Kontaktujte společnost Adobe
Chcete-li zjistit, zda je k dispozici aktualizace pro aplikaci Acrobat 7.0, obraťte se na společnost Adobe Systems Incorporated.
Společnost Microsoft poskytuje kontaktní informace třetích stran, aby vám pomohla získat technickou podporu. Tyto kontaktní informace se můžou bez upozornění změnit. Společnost Microsoft nezaručuje správnost kontaktních informací třetích stran.
Metoda 4: Odebrání doplňku Adobe z Office
Pokud odeberete doplněk Adobe, nebude možné v aplikaci Office uložit soubor jako soubor PDF (Portable Document File).
Chcete-li doplněk Adobe odebrat, postupujte takto.
Poznámka: Vzhledem k různým verzím systému Microsoft Windows se následující postup může lišit od postupu ve vašem počítači. V takovém případě vyhledejte návod k provedení těchto kroků v dokumentaci k danému produktu.
- Ukončete všechny programy.
- Klikněte na tlačítko Start, přejděte na příkaz Nastavení a klikněte na položku Ovládací panely.
- Dvakrát klikněte na Přidat nebo odebrat programy.
- V části Aktuálně nainstalované programy klikněte na Adobe Acrobat Professional 7.0 a poté klikněte na Změnit.
- Klikněte na Změnit a potom na Další.
- Rozbalte Vytvořit Adobe PDF.
- Rozbalte Acrobat PDFMaker.
- Klikněte na šipku vedle systém Microsoft Office a potom klikněte na Nenainstalováno.
- V průvodci nastavením aplikace Adobe Acrobat Professional 7.0 klikněte na tlačítko OK.
- Zavřete okno Přidat nebo odebrat programy.
Pokud po dokončení těchto kroků stále pociťujete dříve zmíněné příznaky, můžete doplněk Adobe ručně odebrat z registru.
Důležité: Před ručním odebráním doplňku Adobe požádejte společnost Adobe o další informace.
Důležité: Tato část, metoda nebo úkol obsahuje kroky, které popisují úpravu registru. Pokud byste ale registr upravili nesprávně, mohlo by dojít k vážným problémům. Provádějte proto tento postup pečlivě. Před úpravami registru vytvořte pro zvýšení ochrany zálohu registru. V případě problému pak můžete registr obnovit. Další informace o zálohování a obnovení registru naleznete v následujícím článku znalostní báze znalostní báze Microsoft Knowledge Base:
322756 Postup zálohování a obnovení registru v systému Windows
Chcete-li ručně odebrat doplněk Adobe, postupujte takto:
Klikněte na tlačítko Start, klikněte na příkaz Spustit, zadejte příkaz regedit a klikněte na tlačítko OK.
Vyhledejte následující podklíč registru a klikněte na něj:
HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Office\Word\Addins\PDFMaker.OfficeAddinV nabídce Soubor klikněte na Exportovat, zadejte název souboru a klikněte na Uložit.
Klikněte pravým tlačítkem myši na položku registru PDFMaker.OfficeAddin a potom klikněte na příkaz Odstranit.
Proveďte kroky 3 a 4 a odstraňte položky registru doplňků v následujících podklíčích registru:
HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Office\Excel\Addins\PDFMaker.OfficeAddin
HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Office\Outlook\Addins\PDFMOutlook.PDFMOutlook
Ukončete Editor registru.
Další informace
Globální šablona (soubor Normal.dotm v aplikaci Word 2007 a soubor Normal.dot v aplikaci Word 2003 a starších verzích aplikace Word) je výchozí šablona, kterou aplikace Word používá. Ve výchozím nastavení se změny, které ovlivní všechny nové dokumenty, ukládají do globální šablony. Toto chování nastane, pokud při uložení změn nezadáte jinou šablonu. Acrobat 7.0 může aplikaci Word zabránit v automatickém ukládání změn do globální šablony.
Další informace o tomto problému naleznete na následujícím webu společnosti Adobe: