Log på med Microsoft
Log på, eller opret en konto.
Hej
Markér en anden konto.
Du har flere konti
Vælg den konto, du vil logge på med.

Symptom

Når du forsøger at få adgang til Project Center-siden i Virksomhedsportal i Microsoft Dynamics GP, modtager du følgende fejlmeddelelse:

Du har ikke en brugerpost i Personal Data Keeper. Kontakt din Microsoft Dynamics GP-administrator for at få hjælp

Årsag

Dette problem kan have forskellige årsager:

  • En forkert medarbejder er sammenkædet med PDK-brugeren (Personal Data Keeper).

  • En forkert medarbejder er sammenkædet med business portal-brugeren.

  • Firma-id'et er blevet ændret i PDK40001 efter en nylig opgradering, servicepakke eller oprettelse af en testdatabase.

Løsning

1. For at bekræfte, at det korrekte medarbejder-id er knyttet til PDK-brugeren, skal du logge på Personal Data Keeper som "sa". Klik på System under fanen Konfiguration, og klik derefter på Bruger. I vinduet Opsætning af PDK-bruger skal du angive bruger-id og firma for brugeren, der modtager fejlen. Bekræft, at værdien i feltet Medarbejder-id er korrekt. Hvis det er forkert, skal du slette PDK-brugeren og oprette den igen ved hjælp af det korrekte medarbejder-id.

2. For at bekræfte, at det korrekte medarbejder-id er knyttet til business portal-brugeren, skal du notere dig medarbejder-id'et, der findes i løsning 1. Følg derefter disse trin:

a. Log på Business Portal (BP) med en bruger, der er BP-administratorrettigheder.

b. Klik på Webstedshandlinger på BP-startsiden, og vælg derefter Indstillinger.

Bemærk! Hvis du bruger BP 5.1, og du vil åbne sektionen Avancerede roller, skal du gå til Websted Indstillinger for webstedet for Business Portal på øverste niveau og derefter klikke på Administration af forretningsportal.

c. Under sektionen Administration af forretningsportal skal du klikke på Brugere.
d. Find den bruger, der oplever problemet, på brugerlisten, og klik på brugeren.
e. I sektionen Brugeregenskaber skal du klikke på fanen Roller.
f. På listen over Roller finder du linjen, hvor der står Medarbejder - Medarbejder-id - 'dit firma'.
g. Svarer værdien i medarbejder-id'et nøjagtigt til det, der blev vist i Løsning 1?  Det skal den.
h. Hvis ikke, skal du klikke på Rediger for at åbne vinduet Rediger portal og Avancerede roller.
i. I den nederste del, hvor der står Rolle/firma, skal du bruge rullemenuen til at finde "Medarbejder/dit
firma" j. Når medarbejderne udfylder rullevinduet, skal du vælge det medarbejder-id, der blev identificeret i løsning 1.
k. Klik på OK, og få BP-brugeren til at prøve timeseddel igen.

3. Kontrollér, at feltet CMPNYNAM i PDK40001 er det korrekte CMPANYID. CMPANYID og CMPNYNAM bør vises på samme måde i PDK40001 som i SY01500.  

Angiv firmanavnet i stedet for XXXXX.  


vælg CMPANYID, CMPNYNAM, * fra PDK40001, hvor CMPNYNAM = 'XXXXX', vælg


CMPANYID, CMPNYNAM, * fra SY01500, hvor CMPNYNAM = 'XXXXX', Hvis disse ikke stemmer overens, skal du ændre


CMPANYID i PDK40001 til det korrekte id ved hjælp af et SQL-forespørgselsværktøj. 

Bemærk Opret en sikkerhedskopi, der kan gendannes, før du kører opdateringssætninger mod databasen.

Følgende er et eksempel på en opdateringserklæring, der kan bruges: Opdater


PDK40001-sæt CMPANYID = 'YYYYY', hvor CMPNYNAM = 'XXXXX'-note angiv firmanavnet i stedet for XXXXX og firma-id'et fra


SY01500 til YYYYY.

Har du brug for mere hjælp?

Vil du have flere indstillinger?

Udforsk abonnementsfordele, gennemse kurser, få mere at vide om, hvordan du sikrer din enhed og meget mere.

Communities hjælper dig med at stille og besvare spørgsmål, give feedback og høre fra eksperter med omfattende viden.

Var disse oplysninger nyttige?

Hvor tilfreds er du med kvaliteten af sproget?
Hvad påvirkede din oplevelse?
Når du trykker på Send, bliver din feedback brugt til at forbedre Microsoft-produkter og -tjenester. Din it-administrator kan indsamle disse data. Erklæring om beskyttelse af personlige oplysninger.

Tak for din feedback!

×