Sign in with Microsoft
Sign in or create an account.

Bemærk!

Revideret 02-02-2022

Den 2. februar 2022 blev der føjet en vejledning til denne artikel om, hvordan du installerer sikkerhedsopdateringer, efter at der er foretaget ændringer i ESU-programmet. Se afsnittet Kendte problemer i denne artikel for at få mere at vide.

Den 8. juni 2021 blev denne opdatering udgivet til at erstatte en tidligere opdatering for at løse en fejl med "tilbagekaldelsesserveren var offline", der kan opstå under installationen. Hvis du allerede har installeret en tidligere version af denne opdatering, kræves der ingen handling. Følg vejledningen under Sådan henter og installerer du opdateringen for at få den opdaterede version.

Den 13. april 2021 blev denne opdatering udgivet til at erstatte en tidligere version af denne opdatering.

Gælder for:

Microsoft .NET Framework 4.6 Microsoft .NET Framework 4.6.1 Microsoft .NET Framework 4.6.2 Microsoft .NET Framework 4.7 Microsoft .NET Framework 4.7.1 Microsoft .NET Framework 4.7.2

VIGTIGT Kontrollér, at du har installeret de nødvendige opdateringer, der er angivet i afsnittet Sådan henter du denne opdatering, før du installerer denne opdatering. 

VIGTIGTNogle kunder, der bruger Windows Server 2008 R2 SP1 og har aktiveret deres TILFØJELSEsprogrammet ESU multiple activation key (MAK), før de installerer opdateringerne for 14. januar 2020, skal muligvis genaktivere nøglen. Genaktivering på de berørte enheder bør kun være påkrævet én gang.  Du kan finde oplysninger om aktivering i dette blogindlæg .

VIGTIGT WSUS scan cab-filer vil fortsat være tilgængelige for Windows 7 SP1 og Windows Server 2008 R2 SP1. Hvis du har et undersæt af enheder, der kører disse operativsystemer uden ESU, vises de muligvis som ikke-kompatible i dine værktøjer til styring af programrettelser og overholdelse af regler og standarder.

VIGTIGT Kunder, der har købt den udvidede sikkerhedsopdatering (ESU) til lokale versioner af disse operativsystemer, skal følge procedurerne i KB4522133 for at fortsætte med at modtage sikkerhedsopdateringer, når den udvidede support slutter d. 14. januar 2020. Du kan finde flere oplysninger om ESU, og hvilke udgaver der understøttes, under KB4497181.

VIGTIGT Pr. 15. januar 2020 vises der en meddelelse i fuld skærm, som beskriver risikoen for fortsat at bruge Windows 7 Service Pack 1, når supporten når den 14. januar 2020. Meddelelsen forbliver på skærmen, indtil du interagerer med den. Denne meddelelse vises kun på følgende udgaver af Windows 7 Service Pack 1:

Bemærk!Meddelelsen vises ikke på computere eller maskiner, der er forbundet med domæne, i kiosktilstand.

VIGTIGT Fra og med august 2019 opdateres .NET Framework 4.6 og derover til Windows Server 2008 R2 SP1 og Windows 7SP1 kræver SHA-2-kodeunderstøttelse. Sørg for, at du har alle de nyeste Windows opdateringer, før du anvender denne opdatering, for at undgå installationsproblemer. Du kan finde flere oplysninger om supportopdateringer til SHA-2-kodesignering i KB 4474419.

VIGTIGT Alle opdateringer til .NET Framework 4.7.2, 4.7.1, 4.7, 4.6.2, 4.6.1 og 4.6 kræver, at d3dcompiler_47.dll-opdateringen er installeret. Vi anbefaler, at du installerer den inkluderede d3dcompiler_47.dll, før du anvender denne opdatering. Du kan finde flere oplysninger d3dcompiler_47.dll under KB 4019990.

VIGTIGT Hvis du installerer en sprogpakke, efter du har installeret denne opdatering, skal du geninstallere denne opdatering. Vi anbefaler derfor, at du installerer alle de sprogpakker, du har brug for, før du installerer denne opdatering. Få mere at vide under Føj sprogpakker til Windows.

Oversigt

Der er en sikkerhedsrisiko, når .NET Framework håndterer objekter i hukommelsen forkert. En hacker, der har udnyttet sikkerhedsrisikoen, kan afsløre indhold i et påvirket systems hukommelse. Hvis du vil udnytte sikkerhedsrisikoen, skal en godkendt hacker køre en særligt udformet program. Opdateringen retter sikkerhedsrisikoen ved at rette den måde, som .NET Framework håndterer objekter i hukommelsen på.

Du kan få mere at vide om sårbarhederne ved at gå til følgende almindelige sikkerhedsrisici og eksponeringer (CVE).

Kendte problemer i denne opdatering

Symptom

Denne opdatering installeres ikke, og den returnerer en eller begge af følgende fejlmeddelelser:

  • -2146762495

  • Et påkrævet certifikat er ikke inden for dets gyldighedsperiode, når der bekræftes i forhold til det aktuelle systemur eller tidsstemplet i den signerede fil.

  • Tilbagekaldsfunktionen kunne ikke kontrollere tilbagekaldelsen, fordi tilbagekaldsserveren var offline.

Løsning

Dette problem blev rettet i den nyeste version af denne opdatering.  Følg vejledningen under Sådan henter og installerer du opdateringen for at få den opdaterede version.

Hvis du allerede har installeret en tidligere version af denne opdatering, kræves der ingen handling.

Symptom

Nogle ændringer rullet ud til Azure Instance Metadata Service (IMDS) indtalte data for at skifte fra Baltimore CyberTrust CA-roden til DigiCert Global G2 CA-roden. Du kan finde detaljerede oplysninger om denne ændring her: Azure Instance Metadata Service-Attested data TLS: Vigtige ændringer er næsten her! – Microsoft Tech Community. Denne opdatering installeres ikke og returnerer muligvis en fejlmeddelelse:

"Alvorlig fejl under installationen" med fejlkode: 0x80070643 (eller 0x643).

Løsning

Dette problem blev løst i de opdateringer, der blev udgivet i januar 2022, se KB5008886 for at få opdateringsoplysninger. Hvis du vil installere en tidligere udgivet opdatering, skal du anvende den seneste sikkerhedsopdatering fra januar 2022 .NET Framework på dit system, før du anvender en tidligere kun-sikkerhedsopdatering. Hvis du allerede har installeret en tidligere udgivet opdatering, kræves der ingen handling.

Yderligere oplysninger om denne opdatering

Følgende artikler indeholder yderligere oplysninger om denne opdatering, der relaterer til individuelle produktversioner.

  • 4580470 Beskrivelse af sikkerhedsopdateringen til .NET Framework 2.0, 3.0, 4.5.2, 4.6 til Windows Server 2008 SP2 (KB4580470)

  • 4580467 Beskrivelse af sikkerhedsopdateringen til .NET Framework 3.5.1, 4.5.2, 4.6, 4.6.1, 4.6.2, 4.7, 4.7.1, 4.7.2, 4.8 til Windows 7 SP1 og Windows Server 2008 R2 SP1 (KB4580467)

Sådan henter og installerer du opdateringen

Før du installerer denne opdatering

Forudsætninger:

For at anvende denne opdatering skal du have .NET Framework 4.6, 4.6.1, 4.6.2, 4.7, 4.7.1, 4.7.2 installeret.

Du skal installere de nedenstående opdateringer og genstarte enheden, før du installerer den seneste opdateringspakke. Installation af disse opdateringer forbedrer pålideligheden af opdateringsprocessen og afhjælper potentielle problemer under installationen af opdateringen og anvendelse af Microsoft-sikkerhedsrettelser.

  1. SSU (SSU) (SSU) for stabelopdateringen for 12. marts 2019. For at få den enkeltstående pakke til denne SSU skal du søge efter den i Microsoft Update-kataloget. Denne opdatering er påkrævet for at installere opdateringer, der kun er SHA-2 signeret.

  2. Den seneste SHA-2-opdatering (KB4474419) udgivet d. 10. september 2019. Hvis du bruger Windows Update, får du automatisk tilbudt den seneste SHA-2-opdatering. Denne opdatering er påkrævet for at installere opdateringer, der kun er SHA-2 signeret. Du kan finde flere oplysninger om SHA-2-opdateringer i 2019 SHA-2 Krav til signering af kode for Windows og WSUS.

  3. Den udvidede sikkerhedsopdatering (ESU) licensforberedelsespakke (KB4538483), der blev udgivet 11. februar 2020. ESU-licensforberedelsespakken tilbydes til dig fra WSUS. For at få den enkeltstående pakke til ESU-licensforberedelsespakke skal du søge efter den i Microsoft Update-kataloget.

Installér denne opdatering

Udgivelseskanal

Tilgængelig

Næste trin

Microsoft Update-katalog

Ja

Hvis du vil hente den enkeltstående pakke til denne opdatering, skal du gå til webstedet for Microsoft Update-kataloget .

Windows Server Update Services (WSUS)

Ja

Denne opdatering synkroniseres automatisk med WSUS, hvis du konfigurerer Produkter og klassificeringer på følgende måde:

Produkt: Windows 7 Service Pack 1, Windows Server 2008 R2 Service Pack 1,Windows Embedded Standard 7 Service Pack 1, Windows Embedded POSReady 7

Klassificering: Sikkerhedsopdateringer

Krav om genstart

Du skal genstarte computeren, når du har anvendt denne opdatering, hvis der bruges påvirkede filer. Vi anbefaler, at du afslutter .NET Framework-baserede programmer, før du anvender denne opdatering.

Opdatere installationsoplysninger

Hvis du vil have mere at vide om installation af denne sikkerhedsopdatering, skal du gå til følgende artikel i Microsoft Knowledge Base:

20201013 Installationsoplysninger for sikkerhedsopdatering: 13. oktober 2020

Oplysninger om fjernelse af opdatering

Bemærk Vi anbefaler ikke, at du fjerner nogen sikkerhedsopdatering. Hvis du vil fjerne denne opdatering, skal du bruge elementet Programmer og funktioner i Kontrolpanel.

Opdatere oplysninger om genstart

Denne opdatering kræver ikke en genstart af systemet, når du har anvendt den, medmindre filer, der bliver opdateret, er låst eller bruges.

Filoplysninger

Den engelske version (USA) af denne softwareopdatering installerer filer, der har de attributter, der er angivet i følgende tabeller.

x86

Filnavn

Filversion

Filstørrelse

Dato

Klokkeslæt

System.Security.dll

4.7.3700.0

318,728

28-aug-2020

18:20

x64

Filnavn

Filversion

Filstørrelse

Dato

Klokkeslæt

System.Security.dll

4.7.3700.0

318,728

28-aug-2020

18:20

Oplysninger om beskyttelse og sikkerhed

Har du brug for mere hjælp?

Udvid dine færdigheder
Gå på opdagelse i kurser
Få nye funktioner først
Deltag i Microsoft insiders

Var disse oplysninger nyttige?

Hvor tilfreds er du med kvaliteten af sproget?
Hvad påvirkede din oplevelse?

Tak for din feedback!

×