Sie sind zurzeit offline. Es wird auf die erneute Herstellung einer Internetverbindung gewartet.

Berechnen der Anzahl der Monate zwischen zwei Datumsangaben in Excel

Der Support für Office 2003 wurde eingestellt

Microsoft stellte am 8. April 2014 den Support für Office 2003 ein. Diese Änderung wirkt sich auf Ihre Softwareupdates und Sicherheitsoptionen aus. Erfahren Sie, was das für Sie bedeutet und wie Sie Ihren Schutz aufrechterhalten können.

Eine Version dieses Artikels für Microsoft Excel 97 und früher finden Sie unter 67093.

Inhalt

Zusammenfassung
Dieser Artikel erläutert Schritt für Schritt, wie Sie die Anzahl der Monate zwischen zwei beliebigen Datumsangaben berechnen.

Wenden Sie eine der folgenden Methoden an, um die Anzahl der Monate zwischen zwei beliebigen Datumsangaben zu berechnen. Beachten Sie, dass beide Methoden die folgenden Informationen verwenden:
  • FDatum = Früheres Datum
  • SDatum = Späteres DatumHINWEIS: Wenn Sie "SDatum" oder "FDatum" nicht in die Zellbezüge, sondern direkt in diese Formel eingeben, müssen Sie die Angaben in Anführungszeichen einschließen (Beispiel: "7.9.00").
back to the top

Aufrunden

Diese Methode verwendet in den Berechnungen nicht den Tag des Monats. Bei dem Anfangsdatum 31.10.2010 und dem Enddatum 02.11.2010 wird ein Monat zurückgegeben, obwohl nur zwei Tage vergangen sind.

Verwenden Sie für diese Methode die folgende Formel
=(JAHR(SDatum)-JAHR(FDatum))*12+MONAT(SDatum)-MONAT(FDatum)
wie im folgenden Beispiel ersichtlich:
  1. Geben Sie in die Zelle A1 das Datum 31.10.2010 ein.
  2. Geben Sie folgende Formel in Zelle A2 ein:
    =(JAHR(JETZT())-JAHR(A1))*12+MONAT(JETZT())-MONAT(A1)
    Die zurückgegebene Anzahl entspricht der Anzahl der Monate vom 31.10.2010 bis zum heutigen Datum, aufgerundet zur nächsten ganzen Zahl.
back to the top

Abrunden

Diese Methode verwendet die Anzahl der Tage in den Berechnungen und rundet auf die nächste Anzahl ganzer Monate ab. Bei dem Anfangsdatum 30.10.2010 und dem Enddatum 30.11.2010 wird ein Monat zurückgegeben. Das Enddatum 29.11.2010 ergibt jedoch den Wert Null.

Verwenden Sie für diese Methode die folgende Formel
=WENN(TAG(SDatum)>=TAG(FDatum),0,-1)+(JAHR(SDatum)-JAHR(FDatum))
*12+MONAT(SDatum)-MONAT(FDatum)
wie im folgenden Beispiel ersichtlich:
  1. Geben Sie in die Zelle A1 das Datum 31.10.2010 ein.
  2. Geben Sie die folgende Formel in Zelle B1 ein:
    =WENN(TAG(JETZT())>=TAG(A1),0,-1)+(JAHR(JETZT())-JAHR(A1)) *12+MONAT(JETZT())-MONAT(A1)
    Hinweis: Stellen Sie sicher, dass die Zelle B1 das Format "Allgemein" besitzt. Die zurückgegebene Anzahl entspricht der Anzahl der Monate vom 31.10.2010 bis zum heutigen Datum, abgerundet zur nächsten Anzahl ganzer Monate.
back to the top
XL2007 XL2003  XL2010
Hinweis Dies ist ein Artikel, der im Schnellverfahren direkt von der Microsoft-Supportorganisation erstellt wurde. Die hierin enthaltenen Informationen werden als Reaktion auf neue Probleme wie besehen bereitgestellt. Da dieser Artikel im Schnellverfahren erstellt wurde, kann er Tippfehler enthalten und zu einem späteren Zeitpunkt ohne vorherige Ankündigung überarbeitet werden. Weitere zu berücksichtigende Informationen finden Sie in den Nutzungsbedingungen.
Eigenschaften

Artikelnummer: 214134 – Letzte Überarbeitung: 05/22/2013 13:43:00 – Revision: 1.0

Microsoft Office Excel 2007, Microsoft Office Excel 2003, Microsoft Excel 2010

  • kbdatetime kbformula kbinfo kbhowtomaster KB214134
Feedback
tml>