In diesem Artikel werden die Formelsyntax und die Verwendung der Funktion CUBEWERT in Microsoft Excel beschrieben.

Beschreibung

Gibt einen aggregierten Wert aus dem Cube zurück.

Syntax

CUBEWERT(Verbindung;[Element_Ausdruck1];[Element_Ausdruck2];...)

Die Syntax der Funktion CUBEWERT weist die folgenden Argumente auf:

  • Verbindung    Erforderlich. Eine Textzeichenfolge mit dem Namen der Verbindung zum Cube.

  • Element_Ausdruck    Optional. Eine Textzeichenfolge eines multidimensionalen Ausdrucks (MDX), der ein Element oder Tupel im Cube auswerten kann. Alternativ können member_expression auch ein Satz sein, der mit der CUBESET-Funktion definiert ist. Verwenden member_expression Datenschnitt, um den Teil des Cubes zu definieren, für den der aggregierte Wert zurückgegeben wird. Wenn in einem Cube kein Measure member_expression, wird das Standardmaß für den Würfel verwendet.

Hinweise

  • Wenn Auswertungen mit der CUBEWERT-Funktion ausgeführt werden, wird vorübergehend die Meldung "#DATEN_ABRUFEN…" in der Zelle angezeigt, bis alle Daten abgerufen wurden.

  • Wenn für Element_Ausdruck ein Zellbezug verwendet wird und dieser Zellbezug eine Cubefunktion enthält, verwendet Element_Audruck den MDX-Ausdruck für das Element in der Zelle, für die der Bezug gilt, und nicht den in dieser Zelle mit Bezug angezeigten Wert.

  • Wenn der Verbindungsname keine gültige, in der Arbeitsmappe gespeicherte Arbeitsmappenverbindung darstellt, gibt CUBEWERT den Fehlerwert #NAME? zurück. Wenn der OLAP-Server (Online Analytical Processing) nicht ausgeführt wird, nicht verfügbar ist oder eine Fehlermeldung zurückgibt, gibt CUBEWERT den Fehlerwert #NAME? zurück.

  • Wenn mindestens ein Element im Tupel ungültig ist, gibt CUBEWERT den Fehlerwert #WERT! zurück.

  • CUBEWERT gibt unter folgenden Bedingungen den Fehlerwert #NV zurück:

    • Die Element_Ausdruck-Syntax ist fehlerhaft.

    • Das durch Element_Ausdruck angegebene Element ist nicht im Cube vorhanden.

    • Das Tupel ist ungültig, da keine Schnittmenge für die angegebenen Werte vorliegt. (Dies kann bei mehreren Elementen aus derselben Hierarchie auftreten.)

    • Der Satz enthält mindestens ein Element mit einer anderen Größe als die anderen Elemente.

    • CUBEWERT kann den Fehlerwert #NV zurückgeben, wenn Sie auf ein sitzungsbasiertes Objekt verweisen, beispielsweise auf ein berechnetes Element oder eine benannte Menge in einer PivotTable mit einer freigegebenen Verbindung, wenn diese PivotTable gelöscht oder in Formeln konvertiert wird. (Klicken Sie auf der Registerkarte Optionen in der Gruppe Extras auf OLAP-Tools, und klicken Sie dann auf In Formeln konvertieren.)

Problem: Nullwerte werden in leere Zeichenfolgen konvertiert

Wenn Excel Zelle keine Daten enthält, weil Sie sie nicht geändert oder den Inhalt gelöscht haben, enthält die Zelle einen leeren Wert. In vielen Datenbanksystemen wird ein leerer Wert als Nullwert bezeichnet. Ein leerer Wert oder Nullwert bedeutet buchstäblich "Kein Wert". Eine Formel kann jedoch niemals eine leere Zeichenfolge oder einen Nullwert zurückgeben. Eine Formel gibt immer einen von drei Werten zurück: einen Zahlenwert; text value, which may be a zero-length string, or an error value, such as #NUM! oder #VALUE.

Wenn eine Formel eine CUBEWERT-Funktion enthält, die mit einer OLAP-Datenbank verbunden ist, und eine Abfrage dieser Datenbank einen Nullwert zurückgibt, dann konvertiert Excel diesen Nullwert auch dann in eine leere Zeichenfolge, wenn die Formel ansonsten einen Zahlenwert zurückgegeben hätte. Dies kann zu einer Situation führen, in der ein Zellbereich eine Kombination aus numerischen Werten und leeren Zeichenfolgen enthält, was sich auf die Ergebnisse anderer Formeln auswirken kann, die auf diesen Zellbereich verweisen. Wenn z. B. A1 und A3 Zahlen enthalten und A2 eine Formel mit einer CUBEWERT -Funktion, die eine leere Zeichenfolge zurückgibt, dann gibt die folgende Formel den Fehler #WERT! zurück:

=A1+A2+A3

Wenn Sie dies verhindern möchten, können Sie wie im folgenden Beispiel mit der ISTTEXT-Funktion prüfen, ob eine leere Zeichenfolge vorliegt, und die Zeichenfolge mithilfe der WENN-Funktion durch 0 (null) ersetzen:

=WENN(ISTTEXT(A1);0;A1)+WENN(ISTTEXT(A2);0;A2)+WENN(ISTTEXT(A3);0;A3)

Alternativ können Sie wie im folgenden Beispiel die CUBEWERT-Funktion in einer WENN-Bedingung schachteln, die einen Nullwert zurückgibt, wenn die CUBEWERT-Funktion mit einer leeren Zeichenfolge ausgewertet wird:

=WENN(CUBEWERT("Vertrieb";"[Maßnahmen].[Gewinn]";"[Zeit].[2004]";"[Alle Produkte].[Getränke]")=""; 0; CUBEWERT("Vertrieb";"[Maßnahmen].[Gewinn]";"[Zeit].[2004]";"[Alle Produkte].[Getränke]"))

Beachten Sie, dass dieser Test auf leere Zeichenfolgen für die SUMME-Funktion nicht erforderlich ist, da diese leere Zeichenfolgen bei der Berechnung des Rückgabewerts automatisch ignoriert werden.

Beispiele

=CUBEWERT("Vertrieb";"[Maßnahmen].[Gewinn]";"[Zeit].[2004]";"[Alle Produkte].[Getränke]")

=CUBEWERT($A$1;"[Maßnahmen].[Gewinn]";D$12;$A23)

=CUBEWERT("Vertrieb";$B$7;D$12;$A23)

Benötigen Sie weitere Hilfe?

Ihre Office-Fähigkeiten erweitern
Schulungen erkunden
Neue Funktionen als Erster erhalten
Microsoft Office Insidern beitreten

War diese Information hilfreich?

Wie zufrieden sind Sie mit der Sprachqualität?
Was hat Ihre Erfahrung beeinflusst?

Vielen Dank für Ihr Feedback!

×