Sie können ein UML-Komponentendiagramm erstellen, um die Komponenten, Ports und Schnittstellen sowie die Beziehungen zwischen diesen zu zeigen.

Eine Komponente in UML stellt einen modulare Teil eines Systems dar. Das Verhalten wird in Bezug auf erforderliche und bereitgestellte Schnittstellen definiert. Eine Komponente verfügt über eine externe Ansicht mit öffentlichen Eigenschaften und Vorgängen und eine interne Ansicht mit privaten Eigenschaften und realisieren von Klassifizierungen. Die interne Ansicht zeigt, wie externes Verhalten intern realisiert wird.

Beispiel für EINL-Komponentendiagramm

Öffnen Sie zunächst die Vorlage UML-Komponente, und wählen Sie eine der vier Optionen aus. Dann wird die Schablone UML-Komponente zusammen mit Shapes angezeigt, die dem UML 2.5-Standard entsprechen.

Hinweis: Die Schablone UML-Komponente ist nur verfügbar, wenn Sie ein Visio Plan 2 sind. Wenn Sie über ein Abonnement verfügen, vergewissern Sie sich, dass Sie die neueste Version von Visio verwenden.

Starten eines Komponentendiagramms

  1. Starten Sie Visio. Oder, wenn Sie bereits eine Datei geöffnet haben, klicken Sie auf Datei > Neu.

  2. Wechseln Sie zu Kategorien > Software und Datenbank > UML-Komponente.

  3. Wählen Sie die leere Vorlage oder eines der drei Startdiagramme aus. Klicken Sie nach dem Auswählen der gewünschten Vorlage auf Erstellen.

  4. Daraufhin sollte neben dem Diagramm das Fenster Shapes angezeigt werden. Wenn sie nicht angezeigt wird, wechseln Sie zu Ansicht >Aufgabenbereiche, und stellen Sie sicher, dass Shapes ausgewählt ist. Wenn sie immer noch nicht angezeigt wird, klicken Sie auf der linken Seite Schaltfläche "Das Shapes-Fenster erweitern" auf die Schaltfläche Das Shapes-Fenster erweitern.

  5. Stellen Sie auf der Registerkarte Ansicht sicher, dass das Kontrollkästchen neben Verbindungspunkte aktiviert ist. Dadurch werden Verbindungspunkte angezeigt, wenn Sie mit dem Verbinden von Shapes beginnen.

  6. Ziehen Sie jetzt die Shapes, die Sie in Ihr Diagramm einbeziehen möchten, aus dem Fenster Shapes auf das Zeichenblatt. Wenn Sie die Textbezeichnungen umbenennen möchten, doppelklicken Sie auf die Bezeichnungen.

Komponenten-Shapes

Verwendung

Verwenden Sie Komponente-Shapes für jede Funktionseinheit in Ihrem System oder Ihrer Anwendung.

Komponente-Shape "Store"

Stereotyp ein- oder ausblenden

Klicken Sie mit der rechten Maustaste auf das Shape, um die Stereotypbezeichnung ein- oder auszublenden.

Kontextmenü, Befehl "Stereotyp anzeigen", <<Komponente>> Bezeichnung

Teilsysteme

Sie können das Komponenten-Shape als Teilsystem-Shape verwenden, das andere Komponenten enthält. Vergrößern Sie einfach das Shape, und legen Sie die anderen Komponenten (per Drag & Drop) darauf ab. Lassen Sie die Maustaste los, wenn die grüne Hervorhebung angezeigt wird. Fortan fungiert das größere Shape als Container, und das kleinere Shape wird mit ihm verschoben.

Tipp: Wenn eine Komponente nicht mehr angezeigt wird, nachdem sie auf eine andere Komponente gezogen wurde, drücken Sie STRG+UMSCHALT+F, um sie in den Vordergrund zu stellen.

Teilsystem-Shape für "Store" mit Komponente "Order", die auf das Teilsystem gezogen ist

Schnittstellen-Shapes

Verwendung

  1. Verwenden Sie das Shape Bereitgestellte Schnittstelle, wenn Sie die Realisierung einer Klasse/Schnittstelle angeben möchten.

  2. Verwenden Sie das Shape Erforderliche Schnittstelle, wenn Sie die Abhängigkeit von einer Klasse/Schnittstelle angeben möchten.

Zwei verbundene Schnittstellen, 1: Bereitgestellte Schnittstelle-Shape, das mit Kreis endet, 2: Erforderliche Schnittstelle-Shape, das mit Fassung endet

Schritt 1

Ziehen Sie ein Shape vom Typ Bereitgestellte Schnittstelle auf das Zeichenblatt, und richten Sie das Port-Quadrat mit einem Verbindungspunkt aus. Es ist verbunden, wenn der Verbindungspunkt von der grünen Hervorhebung umgeben ist.

Bereitgestellte Schnittstelle-Shape, das mit dem Komponente-Shape verklebt ist

Schritt 2

Ziehen Sie ein Shape vom Typ Erforderliche Schnittstelle auf das Zeichenblatt, und richten Sie auch das Port-Quadrat mit einem Verbindungspunkt aus. Es ist verbunden, wenn der Verbindungspunkt von der grünen Hervorhebung umgeben ist.

Erforderliche Schnittstelle-Shape, das mit dem Komponente-Shape verklebt ist

Schritt 3

Wenn Sie eine bereitgestellte Schnittstelle und eine erforderliche Schnittstelle verbinden möchten, wählen Sie zuerst das Shape "Erforderliche Schnittstelle" aus. Suchen Sie dann nach dem gelben Ziehpunkt.

Gelber Ziehpunkt auf dem Erforderliche Schnittstelle-Shape

Schritt 4

Ziehen Sie den gelben Ziehpunkt, um die Verbindung mit der bereitgestellten Schnittstelle herzustellen.

Erforderliche Schnittstelle-Shape, verbunden mit Bereitgestellte Schnittstelle-Shape

Tipps für die Verwendung von Verbindern

Begradigen von Verbindern

Wenn ein Verbinder zu viele Wendungen hat, klicken Sie mit der rechten Maustaste darauf, und klicken Sie dann auf Gerader Verbinder.

Anzeigen der Multiplizität

Klicken Sie bei Bedarf mit der rechten Maustaste auf den Verbinder, und wählen Sie Multiplizität anzeigen aus. Wenn Sie fertig sind, werden vier Textfelder angezeigt, in denen Sie Details hinzufügen können. Wenn Sie nicht alle Textfelder benötigen, löschen Sie nicht alle nicht benötigten Textfelder.

Ändern des Verbindertyps

Sie können einen Verbindertyp ändern. Sie können beispielsweise die Assoziation in eine gerichtete Assoziation ändern. Klicken Sie mit der rechten Maustaste auf den Verbinder, und klicken Sie dann auf Verbindertyp festlegen.

Erstellen von dynamischen Verbindungen anstelle von Punkt-zu-Punkt-Verbindungen

Wenn Shapes vorhers erwarten, dass Shapes in der Menge bewegt werden, sollten Sie eine dynamische Verbindung anstelle einer Punktverbindung herstellen.

Verschieben oder Drehen von Text auf Verbindern

Wahrscheinlich müssen Sie den Text auf Ihren Verbindungslinien drehen oder verschieben. Hier wird beschrieben, wie das geht:

  1. Klicken Sie auf dem Zeichenblatt auf einen leeren Bereich, um eine ggf. bestehende Auswahl aufzuheben.

  2. Klicken Sie auf der Registerkarte Start in der Gruppe Tools auf Textblock drehen Schaltfläche "Textblock".

  3. Klicken Sie auf den Verbinder, der den Text enthält, den Sie drehen oder verschieben möchten.

  4. Ziehen Sie den Textblock, um ihn zu verschieben, oder drehen Sie ihn mithilfe des Drehpunkts Drehpunkt.

  5. Wenn Sie fertig sind, klicken Sie auf die Schaltfläche Zeigertool, Schaltfläche "Zeiger"

    Nachdem Sie wieder zur Schaltfläche Zeigertool Schaltfläche "Zeiger", behält der Text die gleiche Position relativ zum Shape bei. Wenn Sie den Text mit dem Zeigertool Schaltfläche "Zeiger" ziehen, wird auch das Shape bewegt. Um den Text unabhängig vom Shape zu verschieben, wechseln Sie zurück zum Textblock-Tool Schaltfläche "Textblock" .

Hinweis: Zum Erstellen und Bearbeiten von UML-Diagrammen auf Visio für das Web-Diagrammen ist eine Visio Plan 1- oder Visio Plan 2-Lizenzerforderlich, die separat im Microsoft 365. Weitere Informationen erhalten Sie von Ihrem Microsoft 365 Administrator. Wenn Ihr Administrator den Self-Service-Einkauf aktiviert hat, können Sie eine Lizenz für Visio erwerben. Weitere Informationen finden Sie unter Häufig gestellte Fragen zu Self-Service-Käufen.

Beispiel für EINL-Komponentendiagramm

Öffnen Sie zunächst die Vorlage UML-Komponente, und wählen Sie eine der vier Optionen aus. Dann wird die Schablone UML-Komponente zusammen mit Shapes angezeigt, die dem UML 2.5-Standard entsprechen.

Hinweis: Die Schablone UML-Komponente ist nur verfügbar, wenn Sie ein Visio Plan 2 sind. Wenn Sie über ein Abonnement verfügen, vergewissern Sie sich, dass Sie die neueste Version von Visio verwenden.

Starten eines Sequenzdiagramms

  1. Öffnen Visio für das Web

  2. Wählen Sie in der oberen rechten Ecke der Seite Weitere Vorlagen aus.

  3. Scrollen Sie im Katalog nach unten zur Zeile UML-Komponente, etwa in der Mitte der Seite.

    Das erste Element in der Zeile stellt eine leere Vorlage sowie die Begleitschablone dar. Die anderen Elemente in der Zeile sind Beispieldiagramme, in die bereits einige Shapes gezeichnet wurden, um Ihnen einen schnellen Einstieg zu helfen.

  4. Klicken Sie auf ein Element, um eine größere Vorschau anzuzeigen.

  5. Wenn Sie das zu verwendende Diagramm finden, klicken Sie auf dessen Schaltfläche Erstellen.

    Das neue Diagramm mit der zugehörigen Schablone wird in Ihrem Browser geöffnet.

Komponente-Shapes

Verwendung

Verwenden Sie Komponente-Shapes für jede Funktionseinheit in Ihrem System oder Ihrer Anwendung.

Komponente-Shape "Store"

Stereotyp ein- oder ausblenden

Klicken Sie mit der rechten Maustaste auf das Shape, um die Stereotypbezeichnung ein- oder auszublenden.

Kontextmenü, Befehl "Stereotyp anzeigen", <<Komponente>> Bezeichnung

Teilsysteme

Sie können das Komponenten-Shape als Teilsystem-Shape verwenden, das andere Komponenten enthält. Vergrößern Sie einfach das Shape, und legen Sie die anderen Komponenten (per Drag & Drop) darauf ab. Lassen Sie die Maustaste los, wenn die grüne Hervorhebung angezeigt wird. Fortan fungiert das größere Shape als Container, und das kleinere Shape wird mit ihm verschoben.

Tipp: Wenn eine Komponente nicht mehr angezeigt wird, nachdem sie auf eine andere Komponente gezogen wurde, drücken Sie STRG+UMSCHALT+F, um sie in den Vordergrund zu stellen.

Teilsystem-Shape für "Store" mit Komponente "Order", die auf das Teilsystem gezogen ist

Schnittstellen-Shapes

Verwendung

  1. Verwenden Sie das Shape Bereitgestellte Schnittstelle, wenn Sie die Realisierung einer Klasse/Schnittstelle angeben möchten.

  2. Verwenden Sie das Shape Erforderliche Schnittstelle, wenn Sie die Abhängigkeit von einer Klasse/Schnittstelle angeben möchten.

Zwei verbundene Schnittstellen, 1: Bereitgestellte Schnittstelle-Shape, das mit Kreis endet, 2: Erforderliche Schnittstelle-Shape, das mit Fassung endet

Schritt 1

Ziehen Sie ein Shape vom Typ Bereitgestellte Schnittstelle auf das Zeichenblatt, und richten Sie das Port-Quadrat mit einem Verbindungspunkt aus. Es ist verbunden, wenn der Verbindungspunkt von der grünen Hervorhebung umgeben ist.

Bereitgestellte Schnittstelle-Shape, das mit dem Komponente-Shape verklebt ist

Schritt 2

Ziehen Sie ein Shape vom Typ Erforderliche Schnittstelle auf das Zeichenblatt, und richten Sie auch das Port-Quadrat mit einem Verbindungspunkt aus. Es ist verbunden, wenn der Verbindungspunkt von der grünen Hervorhebung umgeben ist.

Erforderliche Schnittstelle-Shape, das mit dem Komponente-Shape verklebt ist

Schritt 3

Wenn Sie eine bereitgestellte Schnittstelle und eine erforderliche Schnittstelle verbinden möchten, wählen Sie zuerst das Shape "Erforderliche Schnittstelle" aus. Suchen Sie dann nach dem gelben Ziehpunkt.

Gelber Ziehpunkt auf dem Erforderliche Schnittstelle-Shape

Schritt 4

Ziehen Sie den gelben Ziehpunkt, um die Verbindung mit der bereitgestellten Schnittstelle herzustellen.

Erforderliche Schnittstelle-Shape, verbunden mit Bereitgestellte Schnittstelle-Shape

Tipps für die Verwendung von Verbindern

Begradigen von Verbindern

Wenn ein Verbinder zu viele Wendungen hat, klicken Sie mit der rechten Maustaste darauf, und klicken Sie dann auf Gerader Verbinder.

Anzeigen der Multiplizität

Klicken Sie bei Bedarf mit der rechten Maustaste auf den Verbinder, und wählen Sie Multiplizität anzeigen aus. Wenn Sie fertig sind, werden vier Textfelder angezeigt, in denen Sie Details hinzufügen können. Wenn Sie nicht alle Textfelder benötigen, löschen Sie nicht alle nicht benötigten Textfelder.

Ändern des Verbindertyps

Sie können einen Verbindertyp ändern. Sie können beispielsweise die Assoziation in eine gerichtete Assoziation ändern. Klicken Sie mit der rechten Maustaste auf den Verbinder, und klicken Sie dann auf Verbindertyp festlegen.

Erstellen von dynamischen Verbindungen anstelle von Punkt-zu-Punkt-Verbindungen

Wenn Shapes vorhers erwarten, dass Shapes in der Menge bewegt werden, sollten Sie eine dynamische Verbindung anstelle einer Punktverbindung herstellen.

Verschieben oder Drehen von Text auf Verbindern

Wahrscheinlich müssen Sie den Text auf Ihren Verbindungslinien drehen oder verschieben. Hier wird beschrieben, wie das geht:

  1. Klicken Sie auf dem Zeichenblatt auf einen leeren Bereich, um eine ggf. bestehende Auswahl aufzuheben.

  2. Klicken Sie auf der Registerkarte Start in der Gruppe Tools auf Textblock drehen Schaltfläche "Textblock".

  3. Klicken Sie auf den Verbinder, der den Text enthält, den Sie drehen oder verschieben möchten.

  4. Ziehen Sie den Textblock, um ihn zu verschieben, oder drehen Sie ihn mithilfe des Drehpunkts Drehpunkt.

  5. Wenn Sie fertig sind, klicken Sie auf die Schaltfläche Zeigertool Schaltfläche "Zeiger"

    Nachdem Sie wieder zur Schaltfläche Zeigertool Schaltfläche "Zeiger", behält der Text die gleiche Position relativ zum Shape bei. Wenn Sie den Text mit dem Zeigertool Schaltfläche "Zeiger" ziehen, wird auch das Shape bewegt. Um den Text unabhängig vom Shape zu verschieben, wechseln Sie zurück zum Textblock-Tool Schaltfläche "Textblock" .

Component diagram displaying the structure of software code as cohesive components

Legende 1 In einem Komponentendiagramm sind Komponenten generische Typen und keine Instanzen. Verwenden Sie ein -Element, um Komponenteninstanzen Bereitstellungsdiagramm.

Schaltflächensymbol Abhängigkeiten gibt an, dass eine Clientkomponente in einer bestimmten Weise von einer Lieferantenkomponente abhängig ist.

  1. Klicken Visio 2010: Klicken Sie unter Vorlagenkategorien auf Software, und klicken Sie dann auf UML-Modelldiagramm, und klicken Sie dann auf Erstellen.

  2. Klicken Sie im Strukturansicht mit der rechten Maustaste auf das Paket oder Teilsystem, in das die Komponentendiagramm enthalten sein soll, und klicken Sie dann im Menü Neu auf Komponentendiagramm.

    Ein leeres Blatt wird angezeigt, und die Schablone UML-Komponente wird zur obersten Schablone. Im Arbeitsbereich wird "Komponente" als Wasserzeichen angezeigt. Der Strukturansicht wird ein Symbol hinzugefügt, das das Diagramm darstellt.

    Hinweis: Wenn die Strukturansicht nicht angezeigt wird, zeigen Sie im Menü UML auf Ansicht, und klicken Sie dann auf Modell-Explorer.

  3. Ziehen Sie für jede Komponente, die Sie darstellen möchten, ein Komponente-Shape auf das Zeichenblatt.

  4. Ziehen Sie gegebenenfalls ein Schnittstellen-Shape auf das Zeichenblatt, und kleben Sie den Endpunkt ohne den Kreis an ein Komponenten-Shape.

    Hinzufügen einer Schnittstelle zu einer Klasse, einer Komponente oder anderen Elementen

    1. Ziehen Sie in einer statischen Komponente oder einem Bereitstellungsdiagramm das LopopPop Interface-Shape auf das Zeichenblatt.

    2. Kleben Sie den Endpunkt ohne Kreis an einen Verbindungspunkt Verbindungspunkt (blaues X) der Klasse oder einem anderen Element.

    3. Doppelklicken Sie auf das Interface-Shape, um einen Namen, Vorgänge und andere Eigenschaftswerte hinzuzufügen.

      Tippliste

      Sie können auch eine Schnittstelle mit einem rechteckigen Interface-Shape darstellen, das einer Klasse ähnelt. Verwenden Sie dieses Shape, wenn Sie eine Liste der Schnittstellenoperationen anzeigen möchten.

      Wenn Sie den Typ der form ändern möchten, die für eine Schnittstelle angezeigt wird, klicken Sie mit der rechten Maustaste auf das Interface-Shape, und klicken Sie dann auf Als Klasse gleich Schnittstelle anzeigen oder Als Lopop-Schnittstelle anzeigen.

  5. Verwenden Sie Abhängigkeits-Shapes, um die Beziehungen zwischen Komponenten oder zwischen einer Komponente und der Schnittstelle einer anderen Komponente anzugeben.

    Angeben einer Abhängigkeitsbeziehung zwischen UML-Elementen

    1. Ziehen Sie ein Abhängigkeits-Shape aus der Schablone STATISCHE UML-Struktur,UML-Bereitstellungoder UML-Komponente auf das Zeichenblatt, und platzieren Sie es in der Nähe der Elemente, die Sie in Beziehung setzen möchten.

    2. Kleben Sie den Endpunkt mit einer Pfeilspitze an einen Verbindungspunkt, Verbindungspunkt (blaues X) element, von dem das andere Element abhängt. Kleben Sie den Endpunkt ohne Pfeilspitze an einen Verbindungspunkt des Elements, das vom anderen Element abhängig ist.

    3. Doppelklicken Sie auf die Abhängigkeit, um einen Namen, ein Stereotyp und andere Eigenschaften hinzuzufügen.

      Tipp: Wenn Sie eine Abhängigkeit Ablaufverfolgung, Verfeinerung, Verwendung oder Bindung angeben möchten, können Sie die Shapes Ablaufverfolgung, Einschränkung,Verwendung oder Bindung aus der Schablone STATISCHE UML-Struktur verwenden.

  6. Doppelklicken Sie auf ein beliebiges Shape, um das Dialogfeld UML-Eigenschaften zu öffnen, in dem Sie einen Namen, Attribute, Vorgänge und andere Eigenschaften hinzufügen können.

  7. Speichern Sie das Diagramm.

Siehe auch

UML-Diagramme in Visio

Erstellen eines UML-Kommunikationsdiagramms

Erstellen eines UML-Verteilungsdiagramms

Erstellen eines UML-Sequenzdiagramms

Benötigen Sie weitere Hilfe?

Ihre Office-Fähigkeiten erweitern
Schulungen erkunden
Neue Funktionen als Erster erhalten
Microsoft Office Insidern beitreten

War diese Information hilfreich?

Wie zufrieden sind Sie mit der Übersetzungsqualität?
Was hat Ihre Erfahrung beeinflusst?

Vielen Dank für Ihr Feedback!

×