In diesem Artikel werden die Formelsyntax und die Verwendung der Funktion FEHLER.TYP in Microsoft Excel beschrieben.

Beschreibung

Gibt eine Zahl zurück, die einem der Fehlerwerte in Microsoft Excel entspricht, oder den Fehlerwert #NV, wenn kein Fehler vorhanden ist. Sie können FEHLER.TYP in einer WENN-Funktion verwenden, um einen Fehlerwert zu ermitteln und eine Zeichenfolge, beispielsweise eine Meldung, anstelle des Fehlerwerts zurückzugeben.

Syntax

FEHLER.TYP(Fehlerwert)

Die Syntax der Funktion FEHLER.TYP weist die folgenden Argumente auf:

  • Error_val    Erforderlich. Der Fehlerwert, dessen identifizierende Nummer Sie suchen möchten. Obwohl error_val tatsächlicher Fehlerwert sein kann, ist dies normalerweise ein Bezug auf eine Zelle, die eine Formel enthält, die Sie testen möchten.

Fehlerwert

Rückgabe von FEHLER.TYP

#NULL!

1

#DIV/0!

2

#WERT!

3

#BEZUG!

4

#NAME?

5

#ZAHL!

6

#NV

7

#DATEN_ABRUFEN

8

Sonstiges

#NV

Beispiel

Kopieren Sie die Beispieldaten in der folgenden Tabelle, und fügen Sie sie in Zelle A1 eines neuen Excel-Arbeitsblatts ein. Um die Ergebnisse der Formeln anzuzeigen, markieren Sie sie, drücken Sie F2 und dann die EINGABETASTE. Im Bedarfsfall können Sie die Breite der Spalten anpassen, damit alle Daten angezeigt werden.

Daten

#NULL!

#DIV/0!

Formel

Beschreibung

Ergebnis

=FEHLER.TYP(A2)

Zahl des Fehlerwerts #NULL! (1)

1

=WENN(FEHLER.TYP(A3)<3;WAHL(FEHLER.TYP(A3);"Bereiche überschneiden sich nicht";"Der Divisor ist 0"))

Überprüft Zelle A3, um festzustellen, ob die Zelle die Zelle #NULL! zurück, oder der #DIV/0! zurück. In diesem Falls wird die Zahl für den Fehlerwert in der Arbeitsblattfunktion WAHL verwendet, um eine von zwei Meldungen anzeigen zu können. Andernfalls wird #N/A-Fehlerwert zurückgegeben.

Der Divisor ist 0

Benötigen Sie weitere Hilfe?

Ihre Office-Fähigkeiten erweitern
Schulungen erkunden
Neue Funktionen als Erster erhalten
Microsoft Insider beitreten

War diese Information hilfreich?

Wie zufrieden sind Sie mit der Übersetzungsqualität?
Was hat Ihre Erfahrung beeinflusst?

Vielen Dank für Ihr Feedback!

×