FELDWERT (Funktion)

Sie können die Funktion FELDWERT zum Abrufen von Felddaten aus verknüpften Datentypen wie den Datentypen "Aktien" oder "Geographie" verwenden. Es gibt einfachere Methoden zum Schreiben von Formeln, die auf Datentypen verweisen, daher sollte die Funktion FELDWERT in erster Linie zum Erstellen von bedingten Berechnungen basierend auf verknüpften Datentypen verwendet werden.

Hinweis: 28. März 2019: Datentypen wurden für alle Windows Microsoft 365 veröffentlicht. Wenn Sie Microsoft 365-Abonnent sind, vergewissern Sie sich, dass Sie über die neueste Office-Version verfügen.

Technische Details

Syntax

=FELDWERT(Wert; Feldname)

Die Syntax der Funktion FELDWERT weist die folgenden Argumente auf:

Argument

Beschreibung

Wert

Die Funktion gibt alle übereinstimmenden Felder aus dem im Argument "Wert" angegebenen verknüpften Datentyp zurück.

Feldname

Die Namen der Felder, die Sie aus dem verknüpften Datentyp extrahieren möchten.

Beschreibung

Beispiele

Im folgenden einfachen Beispiel extrahiert die Formel =FELDWERT(A2;"Preis") das Feld "Preis" aus dem Datentyp "Aktien" für JM Smucker Co.

Den Aktienkurs eines Unternehmens mit =FELDWERT(A2;"Preis") abrufen

Im nächste Beispiel sehen Sie ein typischeres Beispiel für die Funktion FELDWERT. Hier verwenden wir die WENNFEHLER-Funktion zur Überprüfung auf Fehler. Wenn in Zelle A2 kein Firmennamen enthalten ist, gibt die Formel FELDWERT einen Fehler zurück, und in diesem Fall soll nichts ("") angezeigt werden. Enthält die Zelle jedoch einen Firmennamen, möchten wir den Preis aus dem Datentyp in Zelle A2 mit =WENNFEHLER(FELDWERT($A2;B$1);"") abrufen.

Den Aktienkurs eines Unternehmens abrufen und Fehler mit =WENNFEHLER(FELDWERT($A2;B$1);"") ignorieren

Beachten Sie, dass die Funktion FELDWERT Ihnen ermöglicht, auf Arbeitsblattzellen für das Argument "Feldname" zu verweisen, daher verweist die oben stehende Formel für den "Preis" auf Zelle B1, anstatt "Preis" manuell in die Formel eingeben zu müssen.  

Anmerkungen

Wenn Sie versuchen, Daten aus einem nicht vorhandenen Datentypfeld abzurufen, gibt die Funktion FELDWERT den Fehler #FIELD! zurück.. Beispielsweise könnten Sie "Preise" eingegeben haben, wenn das eigentliche Datentypfeld den Namen "Preis" hat. Überprüfen Sie die Formel, um sicherzustellen, dass Sie einen gültigen Feldnamen verwenden. Wenn Sie eine Liste der Feldnamen für einen Datensatz anzeigen möchten, markieren Sie die Zelle für den Datensatz, und drücken Sie ALT+UMSCHALT+F10.

Benötigen Sie weitere Hilfe?

Sie können jederzeit einen Experten in der Excel Tech Community fragen oder Unterstützung in der Answers Community erhalten.

Siehe auch

Aktien und geografische Datentypen

Schreiben von Formeln, die auf Datentypen verweisen

#FIELD! #BLOCKIERT!

Benötigen Sie weitere Hilfe?

Ihre Office-Fähigkeiten erweitern
Schulungen erkunden
Neue Funktionen als Erster erhalten
Office Insider werden

War diese Information hilfreich?

×