Hinzufügen oder Entfernen von Add-Ins in Excel

Add-Ins bieten optionale Befehle und Features für Microsoft Excel. Standardmäßig sind Add-Ins in Excel nicht sofort verfügbar, daher müssen Sie diese Add-Ins zuerst installieren und (in einigen Fällen) aktivieren, damit Sie sie verwenden können.

Suchen Sie nach Informationen zu Office-Add-Ins, die auf HTML, CSS und JS basieren? Weitere Informationen finden Sie unter Office-Add-In für Excel.

Einige Add-Ins sind in Excel integriert, z. B. Solver und die Analysis ToolPak. Andere Add-Ins sind im Download Center verfügbar und müssen zuerst heruntergeladen und installiert werden. Schließlich gibt es Add-Ins, die von Dritten erstellt werden, z. B. einem Programmierer in Ihrer Organisation oder einem Softwarelösungsanbieter. Dies können COM-Add-Ins (Component Object Model), Visual Basic for Applications (VBA)-Add-Ins und DLL-Add-Ins sein. Diese Add-Ins müssen ebenfalls installiert sein, damit sie verwendet werden können.

Die meisten Add-Ins können in drei verschiedene Typen kategorisiert werden:

  • Excel-Add-Ins    Dazu gehören Excel-Add-In (XLAM), Excel 97-2003-Add-In (XLA) oder DLL-Add-In-Dateien (XLL) oder Automatisierungs-Add-Ins. Einige Excel-Add-Ins, z. B. Solver und die Analysis ToolPak, stehen möglicherweise nach der Installation von Excel oder Microsoft Office. Normalerweise müssen Sie diese Add-Ins nur aktivieren, um sie verwenden zu können.

  • Herunterladbare Add-Ins    Weitere Add-Ins für Excel können von Downloads unter Office.com.

  • Benutzerdefinierte Add-Ins    Entwickler und Lösungsanbieter entwerfen in der Regel benutzerdefinierte COM-Add-Ins (Component Object Model), Automatisierungs-Add-Ins, VBA-Add-Ins und XLL-Add-Ins. Diese müssen installiert sein, damit Sie sie verwenden können.

Nachdem Sie ein Add-In installiert oder aktiviert haben, stehen das Add-In und seine Befehle möglicherweise an einem der folgenden Speicherorte zur Verfügung:

  • Registerkarte "Daten". Nachdem Sie die Add-Ins Analysis ToolPak und Solver installiert und aktiviert haben, stehen die Befehle Datenanalyse und Solver in der Gruppe Analyse zur Verfügung.

    Schaltfläche 'Datenanalyse' in der Gruppe 'Datenanalyse'

  • Registerkarte 'Formeln' Nachdem Sie die Eurowährungstools installiert und aktiviert haben, werden die Befehle Eurokonvertierung und Euroformatierung in der Gruppe Lösungen angezeigt.

    'Eurokonvertierung' und 'Euroformatierung'

  • Registerkarte "Add-Ins". Weitere Add-Ins können der Registerkarte Add-Ins hinzugefügt werden. Diese Registerkarte wird dem Menüband hinzugefügt, wenn Sie das erste Add-In installieren und aktivieren, das auf der Registerkarte Add-Ins angezeigt wird. Wenn die Registerkarte Add-Ins nicht angezeigt wird, sollten Sie die Registerkarte beenden und dann Excel.

Andere Add-Ins, z. B. die Registerkarte Erste Schritte, sind an anderen Stellen in Excel verfügbar, z. B. auf einer Registerkarte im Menüband oder über Makros oder angepasste Menüs.

Wichtig: Wenn Sie ein Softwareentwickler sind, können Sie dieses Verfahren verwenden, um ein Automatisierungsprogramm zu installieren oder zu entfernen, bevor Sie Installationsprogramme und Entfernungsprogramme für Ihr Add-In entwerfen.

So aktivieren Sie ein Excel-Add-In    

  1. Klicken Sie auf der Registerkarte Datei auf Optionen, und klicken Sie dann auf die Kategorie Add-Ins.

  2. Klicken Sie im Feld Verwalten auf Excel-Add-Ins, und klicken Sie dann auf OK.

    Das Dialogfeld Add-Ins wird angezeigt.

  3. Aktivieren Sie im Feld Verfügbare Add-Ins das Kontrollkästchen neben dem zu aktivierenden Add-In, und klicken Sie dann auf OK.

Wenn Sie das zu aktivierende Add-In im Feld Verfügbare Add-Ins nicht finden können, müssen Sie es möglicherweise installieren.

So installieren Sie ein Excel-Add-In    

  • Um ein Add-In zu installieren, das normalerweise mit Excel installiert ist, z. B. Solver oder analysis ToolPak, führen Sie das Setupprogramm für Excel oder Microsoft Office aus, und wählen Sie die Option Ändern aus, um das Add-In zu installieren. Nachdem Sie die Excel neu gestartet haben, sollte das Add-In im Feld Verfügbare Add-Ins angezeigt werden.

  • Einige Excel-Add-Ins befinden sich auf Ihrem Computer und können installiert oder aktiviert werden, indem Sie auf Durchsuchen (im Dialogfeld Add-Ins) klicken, um das Add-In zu suchen, und dann auf OK klicken.

  • Einige Excel-Add-Ins erfordern die Ausführung eines Installationspakets. Möglicherweise müssen Sie das Installationspaket auf Ihren Computer herunterladen oder kopieren (ein Installationspaket ist normalerweise eine Datei mit .msi Dateinamenerweiterung), und dann ausführen.

  • Andere Add-Ins, die auf Ihrem Computer nicht verfügbar sind, können über einen Webbrowser von Downloads oder von anderen Websites im Internet oder einem Server in Ihrer Organisation heruntergeladen und installiert werden. Befolgen Sie bei Bedarf die Setupanweisungen für den Download.

So deaktivieren Sie ein Excel-Add-In    

  1. Klicken Sie auf der Registerkarte Datei auf Optionen, und klicken Sie dann auf die Kategorie Add-Ins.

  2. Klicken Sie im Feld Verwalten auf Excel-Add-Ins, und klicken Sie dann auf OK.

  3. Deaktivieren Sie im Feld Verfügbare Add-Ins das Kontrollkästchen neben dem Add-In, das Sie deaktivieren möchten, und klicken Sie dann auf OK.

    Wenn Sie ein Add-In inaktivieren, wird es in vielen Fällen aus seiner Gruppe im Menüband entfernt. In anderen Fällen müssen Sie das Add-In möglicherweise neu starten, um das Add-In aus dem Menüband Excel.

    Hinweis    Durch das Inaktivieren eines Add-Ins wird das Add-In nicht von Ihrem Computer entfernt. Um das Add-In von Ihrem Computer zu entfernen, müssen Sie es deinstallieren.

So entfernen Sie ein Excel-Add-In    

Wichtig: Wenn Sie das Excel-Add-In ursprünglich von einem Netzwerkdateiserver oder aus einem freigegebenen Ordner installiert haben, müssen Sie das Add-In möglicherweise von diesem Speicherort entfernen. Wenn Sie das Excel-Add-In von einer CD installiert haben und Ihr CD-Laufwerk nach der Installation des Add-Ins einem neuen Laufwerkbuchstaben zugeordnet haben, müssen Sie das Add-In von der CD erneut installieren. Wenn Sie alle Excel-Add-Ins von der CD ausführen, müssen Sie die Excel-Add-Ins deinstallieren und dann von der CD erneut installieren.

  1. Klicken Sie auf die Registerkarte Datei und dann auf Beenden.

  2. Klicken Sie in der Systemsteuerung auf Programme und Features (Windows 7 und Windows Vista) oder auf Programme hinzufügen/entfernen (Windows XP).

  3. Führen Sie eine der folgenden Aktionen aus:

    • Wenn Sie Excel im Microsoft Office installiert haben, klicken Microsoft Office in der Liste der installierten Programme auf Microsoft Office, und klicken Sie dann auf die Schaltfläche Ändern.

    • Wenn Sie Excel einzeln installiert haben, klicken Sie in der Liste der installierten Programme auf den Namen Ihres Programms, und klicken Sie dann auf die Schaltfläche Ändern.

    • Wenn Sie das Add-In im Download Center installiert haben, klicken Sie in der Liste der installierten Programme auf den Namen Ihres Programms, und klicken Sie dann auf die Schaltfläche Deinstallieren.

  4. Folgen Sie den Anweisungen im Installationsprogramm.

Wichtig: Wenn Sie ein Softwareentwickler sind, können Sie dieses Verfahren verwenden, um ein Automatisierungsprogramm zu installieren oder zu entfernen, bevor Sie Installationsprogramme und Entfernungsprogramme für Ihr Add-In entwerfen. Wenn Sie kein Entwickler sind, sollten Sie dieses Verfahren nicht verwenden müssen. Wenden Sie sich an den Systemadministrator, der das Add-In bereitgestellt hat, wenn Sie Installations- und Entfernungsanweisungen wünschen.

Hinzufügen eines COM-Add-Ins

  1. Klicken Sie auf der Registerkarte Datei auf Optionen, und klicken Sie dann auf die Kategorie Add-Ins.

  2. Klicken Sie im Feld Verwalten auf COM-Add-Insund dann auf Gehe zu.

    Das Dialogfeld COM-Add-Ins wird angezeigt.

  3. Aktivieren Sie im Feld Verfügbare Add-Ins das Kontrollkästchen neben dem zu installierenden Add-In, und klicken Sie dann auf OK.

    Tipp    Wenn das zu verwendende Add-In nicht im Feld Verfügbare Add-Ins aufgeführt ist, klicken Sie auf Hinzufügen ,und suchen Sie dann nach dem Add-In.

Entfernen eines COM-Add-Ins

  1. Klicken Sie auf der Registerkarte Datei auf Optionen, und klicken Sie dann auf die Kategorie Add-Ins.

  2. Klicken Sie im Feld Verwalten auf COM-Add-Insund dann auf Gehe zu.

    Das Dialogfeld COM-Add-Ins wird angezeigt.

  3. Aktivieren Sie im Feld Verfügbare Add-Ins das Kontrollkästchen neben dem Zu entfernenden Add-In, und klicken Sie dann auf OK.

    Hinweis    Dadurch wird das Add-In aus dem Arbeitsspeicher entfernt, der Name wird jedoch in der Liste der verfügbaren Add-Ins gespeichert. Das Add-In wird nicht von Ihrem Computer gelöscht.

  4. Wenn Sie ein COM-Add-In aus der Liste der verfügbaren Add-Ins entfernen und das Add-In von Ihrem Computer löschen möchten, klicken Sie im Feld Verfügbare Add-Ins auf seinen Namen, und klicken Sie dann auf Entfernen.

Hinweis: Wenn Sie ein Softwareentwickler sind, können Sie dieses Verfahren verwenden, um ein Automatisierungsprogramm zu installieren oder zu entfernen, bevor Sie Installationsprogramme und Entfernungsprogramme für Ihr Add-In entwerfen. Wenn Sie kein Entwickler sind, sollten Sie dieses Verfahren nicht verwenden müssen. Wenden Sie sich an den Systemadministrator, der das Add-In bereitgestellt hat, wenn Sie Installations- und Entfernungsanweisungen wünschen.

  1. Klicken Sie auf der Registerkarte Datei auf Optionen, und klicken Sie dann auf die Kategorie Add-Ins.

  2. Klicken Sie im Feld Verwalten auf Excel-Add-Ins, und klicken Sie dann auf OK.

    Das Dialogfeld Add-Ins wird angezeigt.

  3. Um ein Automatisierungs-Add-In zu installieren, klicken Sie im Feld Automatisierungsserver verfügbar auf Automatisierung, und klicken Sie dann auf das von Ihnen angezeigte Add-In.

    Tipp    Wenn das von Ihnen angezeigte Add-In nicht in der Liste enthalten ist, klicken Sie auf Durchsuchen,suchen Sie das Add-In, und klicken Sie dann auf OK.

  4. Um ein Automatisierungs-Add-In zu entfernen, müssen Sie es aus der Registrierung entfernen. Weitere Informationen finden Sie bei Ihrem Systemadministrator.

Einige Add-Ins sind in Excel integriert, z. B. Solver und die Analysis ToolPak. Andere Add-Ins sind im Download Center verfügbar und müssen zuerst heruntergeladen und installiert werden. Schließlich gibt es Add-Ins, die von Dritten erstellt werden, z. B. einem Programmierer in Ihrer Organisation oder einem Softwarelösungsanbieter. Dies können COM-Add-Ins (Component Object Model), Visual Basic for Applications (VBA)-Add-Ins und DLL-Add-Ins sein. Diese Add-Ins müssen ebenfalls installiert sein, damit sie verwendet werden können.

Die meisten Add-Ins können in drei verschiedene Typen kategorisiert werden:

  • Excel-Add-Ins    Dazu gehören Excel-Add-In (XLAM), Excel 97-2003-Add-In (XLA) oder DLL-Add-In-Dateien (XLL) oder Automatisierungs-Add-Ins. Einige Excel-Add-Ins, z. B. Solver und die Analysis ToolPak, stehen möglicherweise nach der Installation von Excel oder Microsoft Office. Normalerweise müssen Sie diese Add-Ins nur aktivieren, um sie verwenden zu können.

  • Herunterladbare Add-Ins    Weitere Add-Ins für Excel können von Downloads unter Office.com.

  • Benutzerdefinierte Add-Ins    Entwickler und Lösungsanbieter entwerfen in der Regel benutzerdefinierte COM-Add-Ins (Component Object Model), Automatisierungs-Add-Ins, VBA-Add-Ins und XLL-Add-Ins. Diese müssen installiert sein, damit Sie sie verwenden können.

Nachdem Sie ein Add-In installiert oder aktiviert haben, stehen das Add-In und seine Befehle möglicherweise an einem der folgenden Speicherorte zur Verfügung:

  • Registerkarte "Daten". Nachdem Sie die Add-Ins Analysis ToolPak und Solver installiert und aktiviert haben, sind die Befehle Datenanalyse und Solver auf der Registerkarte Daten im Menüband verfügbar.

  • Registerkarte "Start". Weitere Add-Ins können der Registerkarte Start hinzugefügt werden.

Andere Add-Ins, z. B. die Registerkarte Erste Schritte, sind an anderen Stellen in Excel verfügbar, z. B. auf einer Registerkarte im Menüband oder über Makros oder angepasste Menüs.

Wichtig: Wenn Sie ein Softwareentwickler sind, können Sie dieses Verfahren verwenden, um ein Automatisierungsprogramm zu installieren oder zu entfernen, bevor Sie Installationsprogramme und Entfernungsprogramme für Ihr Add-In entwerfen.

So aktivieren Sie ein vorinstalliertes Excel-Add-In    

  1. Wählen Sie im Menü Extras die Option Add-Ins aus.

  2. Aktivieren Sie im Feld Verfügbare Add-Ins das Kontrollkästchen für das Zu aktivierende Add-In, und klicken Sie dann auf OK.

So installieren Sie ein Excel-Add-In    

  • Einige Excel-Add-Ins befinden sich auf Ihrem Computer und können installiert oder aktiviert werden, indem Sie auf Durchsuchen (oben im Dialogfeld Add-Ins) klicken, um das Add-In zu suchen, und dann auf OK klicken.

  • Einige Excel-Add-Ins erfordern die Ausführung eines Installationspakets. Möglicherweise müssen Sie das Installationspaket auf Ihren Computer herunterladen oder kopieren (ein Installationspaket ist normalerweise eine Datei mit .msi Dateinamenerweiterung), und dann ausführen.

  • Andere Add-Ins, die auf Ihrem Computer nicht verfügbar sind, können über einen Webbrowser von Downloads oder von anderen Websites im Internet, einem Server in Ihrer Organisation oder mithilfe der integrierten option Store in Excel. Befolgen Sie bei Bedarf die Setupanweisungen für den Download.

    So installieren Sie Add-Ins aus Store

    1. Klicken Sie im Menüband auf die Registerkarte Einfügen.

    2. Klicken Sie auf Store Schaltfläche.

    3. Verwenden Sie das FeldKategorien oder Suchen, um Nach Add-Ins zu suchen.

    4. Klicken Sie auf Hinzufügen, um das Add-In zu installieren.

      Hinweis: Einige Add-Ins müssen erworben werden.

So entfernen Sie ein Excel-Add-In    

  1. Klicken Sie auf die Registerkarte Einfügen und dann auf Meine Add-Ins.

  2. Klicken Office Add-Insauf das Menü 3 Punkte neben dem Add-In.

  3. Klicken Sie auf Entfernen.

  4. Lesen Sie den Hinweis, der in Bezug auf andere Geräte angezeigt wird, und klicken Sie auf Entfernen.

Benötigen Sie weitere Hilfe?

Ihre Office-Fähigkeiten erweitern
Schulungen erkunden
Neue Funktionen als Erster erhalten
Office Insider werden

War diese Information hilfreich?

Vielen Dank für Ihr Feedback!

Vielen Dank für Ihr Feedback. Es klingt, als ob es hilfreich sein könnte, Sie mit einem unserer Office-Supportmitarbeiter zu verbinden.

×