Korrigieren eines Fehlerwerts vom Typ Fehler in den Funktionen Mittelwert oder Summe

Wenn Mittelwert oder Summe auf Zellen verweisen, die #Value enthalten! Fehler, führen die Formeln zu einem #Value! angezeigt.

#WERT!- Fehler im Mittelwert

Um die Fehlerwerte zu "übersehen", konstruieren wir eine Formel, die die Fehler im Bezugsbereich ignoriert und gleichzeitig den Mittelwert mit den restlichen "normalen" Werten berechnet.

Um dieses Szenario zu umgehen, verwenden wir eine Kombination aus MITTELWERT zusammen mit WENN und ISTFEHLER, um zu bestimmen, ob im angegebenen Bereich ein Fehler vorhanden ist. Dieses spezielle Szenario erfordert eine Matrixformel:

=MITTELWERT(WENN(ISTFEHLER(B2:D2);"";B2:D2))

Hierbei handelt es sich um eine Matrixformel. Sie müssen also entweder die Eingabe Taste drücken (nur bei Verwendung von Microsoft 365 ) oder STRG + UMSCHALT + Eingabe Taste in der Formel.

Hinweis: Wenn Sie über eine aktuelle Version von Microsoft 365verfügen, können Sie die Formel einfach in die Ausgabezelle eingeben und dann die Eingabe Taste drücken, um die Formel als dynamische Matrixformel zu bestätigen. Andernfalls muss die Formel als Legacy-Arrayformel eingegeben werden, indem Sie zunächst die Ausgabezelle auswählen, die Formel in die Ausgabezelle eingeben und dann STRG + UMSCHALT + Eingabe Taste drücken, um Sie zu bestätigen. Excel fügt geschweifte Klammern am Anfang und am Ende der Formel ein. Weitere Informationen zu Matrixformeln finden Sie unter Richtlinien und Beispiele für Matrixformeln.

Array-Funktion im Mittelwert, um den #Value zu beheben! Fehler

Hinweis: Die oben gezeigte Funktion funktioniert nicht nur für #WERT!-Fehler, sondern auch für #N/V-, #NULL-, #DIV/0!- und andere Fehler.

Sie können auch SUMME auf dieselbe Art verwenden:

=SUMME(WENN(ISTFEHLER(B2:D2);"";B2:D2))

Haben Sie eine Frage zu einer bestimmten Funktion?

Posten Sie eine Frage im Excel-Communityforum

Benötigen Sie weitere Hilfe?

Sie können jederzeit einen Experten in der Excel Tech Community fragen oder Unterstützung in der Answers Community erhalten.

Siehe auch

Korrigieren einer #Value! #BUSY!

MITTELWERT

SUMME

Übersicht über Formeln in Excel

Ermitteln von Fehlern in Formeln

Alle Excel-Funktionen (alphabetisch)

Alle Excel-Funktionen (nach Kategorie)

Benötigen Sie weitere Hilfe?

Ihre Office-Fähigkeiten erweitern
Schulungen erkunden
Neue Funktionen als Erster erhalten
Office Insider werden

War diese Information hilfreich?

Vielen Dank für Ihr Feedback!

Vielen Dank für Ihr Feedback. Es klingt, als ob es hilfreich sein könnte, Sie mit einem unserer Office-Supportmitarbeiter zu verbinden.

×