Mit Microsoft anmelden
Melden Sie sich an, oder erstellen Sie ein Konto.
Hallo,
Wählen Sie ein anderes Konto aus.
Sie haben mehrere Konten.
Wählen Sie das Konto aus, mit dem Sie sich anmelden möchten.

Wenn MITTELWERT oder SUMME auf Zellen bezugt, die #VALUE! fehler, führen die Formeln zu einer #VALUE! -Fehlermeldung zurück.

#WERT!- Fehler in MITTELWERT

Um die Fehlerwerte zu "übersehen", konstruieren wir eine Formel, die die Fehler im Bezugsbereich ignoriert und gleichzeitig den Mittelwert mit den restlichen "normalen" Werten berechnet.

Um dieses Szenario zu umgehen, verwenden wir eine Kombination aus MITTELWERT zusammen mit WENN und ISTFEHLER, um zu bestimmen, ob im angegebenen Bereich ein Fehler vorhanden ist. Dieses spezielle Szenario erfordert eine Matrixformel:

=MITTELWERT(WENN(ISTFEHLER(B2:D2);"";B2:D2))

Dies ist eine Matrixformel. Sie müssen also entweder die EINGABETASTE (nur bei Verwendung von Microsoft 365 ) oder STRG+UMSCHALT+EINGABETASTE in der Formel drücken.

Hinweis: Wenn Sie über eine aktuelle Version von Microsoft 365verfügen, können Sie die Formel einfach in die Ausgabezelle eingeben und dann die EINGABETASTE drücken, um die Formel als dynamische Matrixformel zu bestätigen. Andernfalls muss die Formel als herkömmliche Matrixformel eingegeben werden, indem zuerst die Ausgabezelle ausgewählt, die Formel in die Ausgabezelle eingegeben und dann ZUR Bestätigung STRG+UMSCHALT+EINGABETASTE gedrückt wird. Excel fügt automatisch geschweifte Klammern am Anfang und Ende der Formel ein. Weitere Informationen zu Matrixformeln finden Sie unter Richtlinien und Beispiele für Matrixformeln.

Arrayfunktion in MITTELWERT, um die Matrix #VALUE! #BLOCKIERT!

Hinweis: Die oben gezeigte Funktion funktioniert nicht nur für #WERT!-Fehler, sondern auch für #N/V-, #NULL-, #DIV/0!- und andere Fehler.

Sie können auch SUMME auf dieselbe Art verwenden:

=SUMME(WENN(ISTFEHLER(B2:D2);"";B2:D2))

Haben Sie eine Frage zu einer bestimmten Funktion?

Posten Sie eine Frage im Excel-Communityforum

Benötigen Sie weitere Hilfe?

Sie können jederzeit einen Experten in der Excel Tech Community fragen oder Unterstützung in der Answers Community erhalten.

Siehe auch

Korrigieren einer #VALUE! #BLOCKIERT!

MITTELWERT

SUMME

Übersicht über Formeln in Excel

Ermitteln von Fehlern in Formeln

Alle Excel (alphabetisch)

Alle Excel-Funktionen (nach Kategorie)

Benötigen Sie weitere Hilfe?

Ihre Office-Fähigkeiten erweitern

Schulungen erkunden >

Neue Funktionen als Erster erhalten

Microsoft Insider beitreten >

War diese Information hilfreich?

Wie zufrieden sind Sie mit der Sprachqualität?
Was hat Ihre Erfahrung beeinflusst?

Vielen Dank für Ihr Feedback!

×