Die Funktion SUMMENPRODUKT gibt die Summe der Produkte entsprechender Bereiche oder Matrizen zurück. Der Standardvorgang ist Multiplikation, aber Addition, Subtraktion und Division sind ebenfalls möglich.

In diesem Beispiel wird SUMMENPRODUKT verwendet, um den Gesamtumsatz für einen bestimmten Artikel und eine bestimmte Größe zurückzukehren:

Beispiel für die Verwendung der Funktion SUMMENPRODUKT zur Rückgabe des Gesamtumsatzes, wenn dafür jeweils Produktname, Größe und einzelne Umsatzwerte bereitgestellt werden.

SUMMENPRODUKT entspricht allen Instanzen von Element Y/Größe M und summiert sie, sodass für dieses Beispiel 21 plus 41 gleich 62 ist.

Syntax

So verwenden Sie den Standardvorgang (Multiplikation):

=SUMMENPRODUKT(Matrix1;[Matrix2];[Matrix3];...)

Die Syntax der Funktion SUMMENPRODUKT weist die folgenden Argumente auf:

Argument

Beschreibung

Matrix1   

Erforderlich

Das erste Arrayargument, dessen Komponenten Sie multiplizieren und anschließend addieren möchten

[Matrix2], [Matrix3],...    

Optional

2 bis 255 Arrayargumente, deren Komponenten Sie multiplizieren und anschließend addieren möchten

So führen Sie andere arithmetische Operationen aus

Verwenden Sie SUMMENPRODUKT wie gewohnt, ersetzen Sie jedoch die Kommas, durch die die Matrixargumente durch die von Ihnen verwendeten arithmetischen Operatoren (*, /, +, -) getrennt werden. Nachdem alle Vorgänge ausgeführt wurden, werden die Ergebnisse wie gewohnt addiert.

Hinweis: Wenn Sie arithmetische Operatoren verwenden, sollten Sie die Matrixargumente in Klammern einschließen und die Arrayargumente mithilfe von Klammern gruppieren, um die Reihenfolge von arithmetischen Operationen zu steuern.

Hinweise

  • Die als Argumente angegebenen Arrays müssen bezüglich der Zeilen- und Spaltenanzahl identisch sein. Ist dies nicht der Fall, gibt SUMMENPRODUKT den Fehlerwert #WERT! zurück. Beispiel: =SUMMENPRODUKT(C2:C10;D2:D5) gibt einen Fehler zurück, da die Bereiche nicht die gleiche Größe aufweisen.

  • SUMMENPRODUKT behandelt nicht numerische Arrayeinträge so, als wären sie Nullen.

  • Um eine optimale Leistung zu erzielen, sollte SUMMENPRODUKT nicht mit vollständigen Spaltenverweisen verwendet werden. Beachten Sie = SUMMENPRODUKT(A:A;B:B). Hier multipliziert die Funktion die 1.048.576 Zellen in Spalte A mit den 1.048.576 Zellen in Spalte B, bevor sie addiert werden. 

Beispiel 1

Beispiel für die Funktion SUMMENPRODUKT, die verwendet wird, um die Summe der verkauften Artikel zurückzukehren, wenn Einheitenkosten und -menge bereitgestellt werden.

Um die Formel mithilfe der obigen Beispielliste zu erstellen, geben Sie =SUMMENPRODUKT(C2:C5;D2:D5) ein, und drücken Sie die EINGABETASTE. Jede Zelle in Spalte C wird mit der entsprechenden Zelle in derselben Zeile in Spalte D multipliziert, und die Ergebnisse werden addiert. Der Gesamtbetrag für Lebensmittel beträgt 78,97 $.

Wenn Sie eine längere Formel schreiben möchten, die dasselbe Ergebnis liefert, geben Sie =C2*D2+C3*D3+C4*D4+C5*D5 ein, und drücken Sie die EINGABETASTE. Nach dem Drücken der EINGABETASTE ist das Ergebnis identisch: 78,97 $. Zelle C2 wird mit D2 multipliziert, und das Ergebnis wird dem Ergebnis von Zelle C3 multipliziert, Zelle D3 und so weiter.

Beispiel 2

Im folgenden Beispiel wird SUMMENPRODUKT verwendet, um den Gesamtumsatz nach Vertriebsmitarbeiter zurückzukehren, wo sowohl der Gesamtumsatz als auch die Ausgaben nach Agent zu finden sind. In diesem Fall verwenden wir eine Excel-Tabelle,die strukturierte Verweise anstelle von Standardbereichen Excel verwendet. Hier sehen Sie, dass auf die Bereiche "Vertrieb", "Ausgaben" und "Agent" nach Namen verwiesen wird.

Beispiel für die Funktion SUMMENPRODUKT zum Zurückgeben des Gesamtumsatzes nach Vertriebsmitarbeiter, wenn jeweils Umsätze und Ausgaben bereitgestellt werden.

Die Formel ist: =SUMMENPRODUKT(((Tabelle1[Umsätze])+(Tabelle1[Ausgaben]))*(Tabelle1[Agent]=B8)) und gibt die Summe aller Verkäufe und Ausgaben für den Agent zurück, der in Zelle B8 aufgeführt ist.

Beispiel 3

In diesem Beispiel soll die Summe eines bestimmten Artikels zurückgeben, der von einer bestimmten Region verkauft wurde. Wie viele Kirschen hat sich in diesem Fall für die Region Ost verkauft?

Prüfung der Verwendung von SUMMENPRODUKT zur Rückgabe der Summe von Elementen nach Region. In diesem Fall die Anzahl der im Gebiet Ost verkauften Kirschen.

Hier die Formel: =SUMMENPRODUKT((B2:B9=B12)*(C2:C9=C12)*D2:D9). Zuerst wird die Anzahl der Vorkommnisse von Ost mit der Anzahl der übereinstimmenden Vorkommen von Kirschen multipliziert. Abschließend werden die Werte der entsprechenden Zeilen in der Spalte "Umsatz" summiert. Um zu sehen, Excel berechnet, wählen Sie die Zelle der Formel aus, und wechseln Sie dann zu Formeln >Formel auswerten > Auswerten.

Benötigen Sie weitere Hilfe?

Sie können jederzeit einen Experten in der Excel Tech Community fragen oder Unterstützung in der Answers Community erhalten.

Siehe auch

Ausführen bedingter Berechnungen für Zellbereiche

Summe basierend auf mehreren Kriterien mit SUMMEWENNS

Zählen anhand mehrerer Kriterien mit ZÄHLENWENNS

Mittelwert basierend auf mehreren Kriterien mit MITTELWERTWENNS

Benötigen Sie weitere Hilfe?

Ihre Office-Fähigkeiten erweitern
Schulungen erkunden
Neue Funktionen als Erster erhalten
Microsoft Office Insidern beitreten

War diese Information hilfreich?

Wie zufrieden sind Sie mit der Übersetzungsqualität?
Was hat Ihre Erfahrung beeinflusst?

Vielen Dank für Ihr Feedback!

×