SUMMENPRODUKT (Funktion)

Die Funktion SUMMENPRODUKT gibt die Summe der Produkte der entsprechenden Bereiche oder Arrays zurück. Der Standardvorgang ist Multiplikation, aber auch Addition, Subtraktion und Division sind möglich.

In diesem Beispiel verwenden wir SUMMENPRODUKT, um den Gesamtumsatz für einen bestimmten Artikel und eine bestimmte Größe zurückzukehren:

Beispiel für die Verwendung der Funktion SUMMENPRODUKT zum Zurückgeben des Gesamtumsatzes, wenn der Produktname, die Größe und die einzelnen Umsatzwerte für die einzelnen Werte angegeben werden.

SUMMENPRODUKT entspricht allen Instanzen von Element Y/Größe M und summiert sie, sodass für dieses Beispiel 21 plus 41 gleich 62 ist.

Syntax

So verwenden Sie den Standardvorgang (Multiplikation):

=SUMMENPRODUKT(Matrix1; [Matrix2]; [Matrix3]; ...)

Die Syntax der Funktion SUMMENPRODUKT weist die folgenden Argumente auf:

Argument

Beschreibung

Matrix1   

Erforderlich

Das erste Arrayargument, dessen Komponenten Sie multiplizieren und anschließend addieren möchten

[Matrix2], [Array3],...    

Optional

2 bis 255 Arrayargumente, deren Komponenten Sie multiplizieren und anschließend addieren möchten

So führen Sie andere arithmetische Operationen aus

Verwenden Sie SUMMENPRODUKT wie gewohnt, ersetzen Sie aber die Kommas, die die Arrayargumente durch die arithmetischen Operatoren trennen, die Sie (*, /, +, -) verwenden möchten. Nachdem alle Vorgänge ausgeführt wurden, werden die Ergebnisse wie gewohnt addiert.

Hinweis: Wenn Sie arithmetische Operatoren verwenden, sollten Sie die Arrayargumente in Klammern einschließen und Klammern verwenden, um die Arrayargumente zu gruppieren, um die Reihenfolge arithmetischer Operationen zu steuern.

Hinweise

  • Die als Argumente angegebenen Arrays müssen bezüglich der Zeilen- und Spaltenanzahl identisch sein. Ist dies nicht der Fall, gibt SUMMENPRODUKT den Fehlerwert #WERT! zurück. Beispielsweise gibt =SUMMENPRODUKT(C2:C10;D2:D5) einen Fehler zurück, da die Bereiche nicht die gleiche Größe aufweisen.

  • SUMPRODUCT behandelt nicht numerische Arrayeinträge so, als wären sie Nullen.

  • Für eine optimale Leistung sollte SUMMENPRODUKT nicht mit vollständigen Spaltenverweisen verwendet werden. Berücksichtigen Sie =SUMMENPRODUKT(A:A;B:B), hier multipliziert die Funktion die 1.048.576 Zellen in Spalte A mit den 1.048.576 Zellen in Spalte B, bevor sie hinzugefügt werden. 

Beispiel 1

Beispiel für die Funktion SUMMENPRODUKT, die verwendet wird, um die Summe der verkauften Artikel zurückzukehren, wenn Einstandspreis und Menge bereitgestellt werden.

Wenn Sie die Formel mithilfe der obigen Beispielliste erstellen möchten, geben Sie =SUMMENPRODUKT(C2:C5;D2:D5) ein, und drücken Sie die EINGABETASTE. Jede Zelle in Spalte C wird mit der entsprechenden Zelle in derselben Zeile in Spalte D multipliziert, und die Ergebnisse werden addiert. Der Gesamtbetrag für Lebensmittel beträgt 78,97 $.

Wenn Sie eine längere Formel schreiben möchten, die dasselbe Ergebnis liefert, geben Sie =C2*D2+C3*D3+C4*D4+C5*D5 ein, und drücken Sie die EINGABETASTE. Nach dem Drücken der EINGABETASTE ist das Ergebnis identisch: 78,97 $. Zelle C2 wird mit D2 multipliziert, und das Ergebnis wird dem Ergebnis der Zelle C3 mal Zelle D3 und so weiter hinzugefügt.

Beispiel 2

Im folgenden Beispiel wird SUMMENPRODUKT verwendet, um den Gesamtumsatz nach Vertriebsmitarbeiter zurückzukehren, wobei wir sowohl gesamter Umsatz als auch Ausgaben nach Agent haben. In diesem Fall verwenden wir eine Excel-Tabelle,die strukturierte Verweise anstelle von Standard-Excel-Bereichen verwendet. Hier sehen Sie, dass auf die Bereiche "Vertrieb", "Ausgaben" und "Agent" nach Name verwiesen wird.

Beispiel für die Funktion SUMMENPRODUKT, um den Gesamtumsatz des Vertriebsmitarbeiters zurückzukehren, wenn er jeweils mit Umsätzen und Ausgaben bereitgestellt wird.

Die Formel ist: =SUMMENPRODUKT((((Tabelle1[Umsätze]+(Tabelle1[Ausgaben]))*(Tabelle1[Agent]=B8)) und gibt die Summe aller Umsätze und Ausgaben für den in Zelle B8 aufgelisteten Agenten zurück.

Beispiel 3

In diesem Beispiel möchten wir die Summe eines bestimmten Artikels zurückgeben, der von einer bestimmten Region verkauft wurde. Wie viele Kirschen hat die Region Ost in diesem Fall verkauft?

Prüfung der Verwendung von SUMMENPRODUKT zum Zurückgeben der Summe von Elementen nach Region. In diesem Fall die Anzahl der im Osten verkauften Kirschen.

Hier ist die Formel: =SUMMENPRODUKT(((B2:B9=B12)*(C2:C9=C12)*D2:D9). Sie multipliziert zunächst die Anzahl der Vorkommen im Osten mit der Anzahl der übereinstimmenden Vorkommen von Kirschen. Schließlich werden die Werte der entsprechenden Zeilen in der Spalte "Vertrieb" summiert. Um zu sehen, wie Excel dies berechnet, wählen Sie die Formelzelle aus, und wechseln Sie dann zu Formeln >Formel auswerten > Auswerten.

Benötigen Sie weitere Hilfe?

Sie können jederzeit einen Experten in der Excel Tech Community fragen oder Unterstützung in der Answers Community erhalten.

Siehe auch

Ausführen bedingter Berechnungen für Zellbereiche

Summe basierend auf mehreren Kriterien mit SUMMEWENNS

Anzahl basierend auf mehreren Kriterien mit ZÄHLENWENNS

Mittelwert basierend auf mehreren Kriterien mit MITTELWERTWENNS

Benötigen Sie weitere Hilfe?

Ihre Office-Fähigkeiten erweitern
Schulungen erkunden
Neue Funktionen als Erster erhalten
Office Insider werden

War diese Information hilfreich?

Vielen Dank für Ihr Feedback!

Vielen Dank für Ihr Feedback. Es klingt, als ob es hilfreich sein könnte, Sie mit einem unserer Office-Supportmitarbeiter zu verbinden.

×