Verwalten externer Datenbereiche und ihrer Eigenschaften

Sie können die Eigenschaften eines externen Datenbereichs ändern, um Daten zu steuern, die über eine Verbindung mit einer externen Datenquelle, wie einer Datenbank, einer Webabfrage oder einer Textdatei, in ein Arbeitsblatt importiert wurden.

Ein externer Datenbereich (auch als Abfragetabelle bezeichnet) ist ein definierter Name oder Tabellenname, der die Position der Daten definiert, die in ein Arbeitsblatt gebracht werden. Wenn Sie eine Verbindung mit externen Daten herstellen, erstellt Excel automatisch einen externen Datenbereich. Die einzige Ausnahme ist ein PivotTable-Bericht, der mit einer Datenquelle verbunden ist – ein PivotTable-Bericht verwendet keinen externen Datenbereich. In Excel können Sie einen externen Datenbereich formatieren und anordnen oder in Berechnungen wie bei allen anderen Daten verwenden.

Eigenschaften externer Datenbereich

Ein externer Datenbereich verfügt über zusätzliche Eigenschaften (nicht zu verwechseln mit Verbindungseigenschaften), mit denen Sie die Daten steuern können, beispielsweise die Beibehaltung der Zellenformatierung und der Spaltenbreite. Sie können diese externen Datenbereichseigenschaften ändern, indem Sie auf der Registerkarte Daten in der Gruppe Verbindungen auf Eigenschaften klicken. Führen Sie dann die folgenden Aktionen aus:

  • Verwenden Sie für externe Datenbereiche, die aus Microsoft Query und dem Datenverbindungs-Assistenten erstellt wurden, das Dialogfeld Eigenschaften für externe Daten .

  • Verwenden Sie für externe Datenbereiche, die aus einer importierten Textdatei oder Webabfrage erstellt werden, die HTML-Daten abruft, das Dialogfeld Eigenschaften für externen Datenbereich .

  • Verwenden Sie für externe Datenbereiche, die aus einer Webabfrage erstellt werden, die XML-Daten abruft, das Dialogfeld Eigenschaften für XML-Zuordnung .

Verwenden von Vorlagen mit externen Datenbereichen

Wenn Sie eine Zusammenfassung oder einen Bericht freigeben möchten, die auf externen Daten basiert, können Sie anderen Benutzern eine Arbeitsmappe zuweisen, die einen externen Datenbereich enthält, oder Sie können eine Berichtsvorlage erstellen. Mit einem Berichtvorlage können Sie die Zusammenfassung oder den Bericht speichern, ohne die externen Daten zu speichern, damit die Datei kleiner ist. Die externen Daten werden abgerufen, wenn ein Benutzer die Berichtsvorlage öffnet.

  1. Wählen Sie das Arbeitsblatt aus, in dem Sie nach einem Externer Datenbereich suchen möchten.

  2. Klicken Sie im Bearbeitungsleiste auf den Pfeil neben dem Feld Name, und klicken Sie dann auf den Namen des gewünschten externen Datenbereichs.

  1. Klicken Sie auf der Registerkarte Formeln in der Gruppe Definierte Namen auf Namens-Manager.

    Abbildung des Excel-Menübands

  2. Klicken Sie im Dialogfeld Namens-Manager auf den Namen des externen Datenbereichs, und klicken Sie dann auf Bearbeiten. Sie können auch auf den Namen doppelklicken.

  3. Geben Sie im Dialogfeld Namen bearbeiten im Feld Name den neuen Namen für den Bezug ein.

Hinweis: Die Schaltfläche Schließen schließt nur das Dialogfeld Namens-Manager . Sie müssen nicht auf Schließen klicken, um bereits vorgenommene Änderungen zu übernehmen.

Sie können die zugrunde liegende Abfrage für einen externen Datenbereich ändern, der aus Microsoft Query, einer importierten Textdatei, einer Webabfrage oder dem Datenverbindungs-Assistenten erstellt wurde.

  1. Klicken Sie auf eine Zelle im externen Datenbereich, für die Sie die zugrunde liegende Abfrage ändern möchten.

  2. Klicken Sie auf der Registerkarte Daten in der Gruppe Verbindungen auf Eigenschaften.

    Abbildung des Excel-Menübands

  3. Klicken Sie im Dialogfeld Eigenschaften für externe Daten auf Verbindungseigenschaften Schaltflächensymbol .

  4. Klicken Sie im Dialogfeld Verbindungseigenschaften auf die Registerkarte Definition , und klicken Sie dann auf Abfrage bearbeiten.

Weitere Informationen zum Erstellen und Bearbeiten von Abfragen in Microsoft Query finden Sie in der Hilfe zu Microsoft Query.

  1. Klicken Sie auf eine Zelle im externen Datenbereich, für die Sie die zugrunde liegende Abfrage ändern möchten.

  2. Klicken Sie auf der Registerkarte Daten in der Gruppe Verbindungen auf Verbindungen.

    Abbildung des Excel-Menübands

  3. Klicken Sie im Dialogfeld Arbeitsmappen-Verbindungen auf Eigenschaften.

  4. Klicken Sie im Dialogfeld Verbindungseigenschaften auf die Registerkarte Definition , und klicken Sie dann auf Abfrage bearbeiten.

  5. Klicken Sie im Dialogfeld Textdatei importieren auf importieren.

  6. Nehmen Sie im Text Import-Assistenten Änderungen an der importierten Textdatei vor, und klicken Sie dann auf Fertig stellen.

    Weitere Informationen zum Importieren von Textdateien finden Sie unter importieren oder Exportieren von Textdateien.

  1. Klicken Sie auf eine Zelle im externen Datenbereich, für die Sie die zugrunde liegende Abfrage ändern möchten.

  2. Klicken Sie auf der Registerkarte Daten in der Gruppe Verbindungen auf Eigenschaften.

    Abbildung des Excel-Menübands

  3. Klicken Sie im Dialogfeld Arbeitsmappen-Verbindungen auf Eigenschaften.

  4. Klicken Sie im Dialogfeld Verbindungseigenschaften auf die Registerkarte Definition , und klicken Sie dann auf Abfrage bearbeiten.

  5. Nehmen Sie im Dialogfeld Webabfrage bearbeiten Änderungen an der Webabfrage vor, und klicken Sie dann auf Fertig stellen.

Weitere Informationen zum Erstellen und Bearbeiten von Webabfragen finden Sie unter Herstellen einer Verbindung mit einer Webseite.

  1. Klicken Sie auf eine Zelle im externen Datenbereich, für die Sie die zugrunde liegende Abfrage ändern möchten.

  2. Klicken Sie auf der Registerkarte Daten in der Gruppe Verbindungen auf Eigenschaften.

    Abbildung des Excel-Menübands

  3. Klicken Sie im Dialogfeld Eigenschaften für externe Daten auf Verbindungseigenschaften Schaltflächensymbol .

  4. Klicken Sie im Dialogfeld Verbindungseigenschaften auf die Registerkarte Definition .

  5. Führen Sie eine der folgenden Aktionen aus:

    • Klicken Sie im Feld Befehlstyp auf Tabelle , und ändern Sie dann im Feld Befehlstext den Wert in den Namen einer geeigneten Tabelle, Ansicht oder Abfrage.

    • Klicken Sie im Feld Befehlstyp auf SQL oder Standard , und bearbeiten Sie dann im Textfeld Befehl die SQL-Anweisung.

      Hinweis: Je nachdem, wie die Verbindung definiert wurde, ist das Feld Befehlstyp möglicherweise nicht verfügbar (es wird abgeblendet angezeigt).

  1. Klicken Sie auf der Bearbeitungsleiste auf den Pfeil neben dem Feld Name, und wählen Sie den Namen des externen Datenbereichs aus, den Sie kopieren möchten.

    Wählen Sie bei einer Excel-Tabelle den Namen des Bereichs aus, und drücken Sie dann STRG + A, um die Tabellenüberschriften zu markieren.

    Wenn Sie Spaltenbeschriftungen oder Formeln einbeziehen möchten, die nicht Teil des externen Datenbereichs sind, markieren Sie die Zellen, die die Spaltenbeschriftungen oder Formeln enthalten, die Sie kopieren möchten. Klicken Sie auf der Bearbeitungsleiste auf den Pfeil neben dem Feld Name , und klicken Sie auf den Namen des externen Datenbereichs, den Sie kopieren möchten.

  2. Klicken Sie auf der Registerkarte Start in der Gruppe Zwischenablage auf Kopieren.

    Abbildung des Excel-Menübands

  3. Wechseln Sie zu der Arbeitsmappe, in der Sie den externen Datenbereich einfügen möchten.

  4. Klicken Sie auf die obere linke Zelle des Bereich zum Einfügen s.

    Um sicherzustellen, dass die Externe Daten vorhandene Daten nicht ersetzen, stellen Sie sicher, dass das Arbeitsblatt keine Daten unter oder rechts neben der Zelle enthält, auf die Sie klicken.

  5. Klicken Sie auf der Registerkarte Start in der Gruppe Zwischenablage auf Einfügen.

Hinweis: Wenn Sie nur einen Teil eines externen Datenbereichs kopieren, wird der zugrunde liegende Abfrage nicht kopiert, und die kopierten Daten können nicht aktualisiert werden.

Sie können steuern, wie eine kleinere oder größere Datenmenge behandelt wird, die bei der Aktualisierung von Daten an Excel zurückgegeben wird.

  1. Klicken Sie auf der Registerkarte Daten in der Gruppe Verbindungen auf Eigenschaften.

    Abbildung des Excel-Menübands

  2. Klicken Sie im Dialogfeld Eigenschaften für externen Datenbereich unter Wenn sich die Anzahl der Zeilen im Datenbereich beim Aktualisieren ändert, auf eine der folgenden Optionen:

    • Einfügen von Zellen für neue Daten, löschen nicht verwendeter Zellen

      Hinweise: 

      • Wenn eine oder mehrere Zeilen in der Datenquelle hinzugefügt werden, werden Zellen direkt unterhalb des externen Datenbereichs nach unten verschoben, aber die Zellen rechts vom externen Datenbereich werden nicht verschoben.

      • Wenn eine oder mehrere Zeilen in der Datenquelle gelöscht werden, werden Zellen direkt unterhalb des externen Datenbereichs nach oben verschoben, aber die Zellen rechts vom externen Datenbereich werden nicht verschoben.

    • Einfügen ganzer Zeilen für neue Daten, löschen nicht verwendeter Zellen

      Hinweise: 

      • Wenn eine oder mehrere Zeilen in der Datenquelle hinzugefügt werden, werden Zellen direkt unter und rechts des externen Datenbereichs nach unten verschoben.

      • Wenn eine oder mehrere Zeilen in der Datenquelle gelöscht werden, werden Zellen direkt unter und rechts vom externen Datenbereich nicht verschoben.

    • Überschreiben vorhandener Zellen mit neuen Daten, löschen nicht verwendeter Zellen

      Hinweise: 

      • Wenn eine oder mehrere Zeilen in der Datenquelle hinzugefügt werden, werden Zellen direkt unter dem externen Datenbereich überschrieben, aber die Zellen rechts vom externen Datenbereich werden nicht verschoben.

      • Wenn eine oder mehrere Zeilen in der Datenquelle gelöscht werden, werden Zellen direkt unter und rechts vom externen Datenbereich nicht verschoben.

  1. Klicken Sie auf der Registerkarte Daten in der Gruppe Verbindungen auf Eigenschaften.

    Abbildung des Excel-Menübands

  2. Führen Sie unter Datenformatierung und-Layouteine oder mehrere der folgenden Aktionen aus:

    • Aktivieren Sie das Kontrollkästchen Feldnamen einbeziehen , um Feldnamen als erste Zeile einzubeziehen.

      Hinweis: Dieses Kontrollkästchen ist nur für einen externen Datenbereich verfügbar, der aus einem Microsoft Office 2003-Programm konvertiert wird, oder in einen externen Datenbereich, der programmgesteuert erstellt wird.

    • Wenn Sie eine Spalte mit Zeilennummern hinzufügen möchten, aktivieren Sie das Kontrollkästchen Zeilennummern einbeziehen .

      Hinweis: Dieses Kontrollkästchen ist für importierte Textdateien, XML-Dateien oder Webabfragen nicht verfügbar.

    • Aktivieren Sie das Kontrollkästchen Zellformatierung beibehalten , um die angewendete Zellformatierung beizubehalten.

      Hinweis: Bei einer Webabfrage wird diese Option automatisch gelöscht, wenn Sie im Dialogfeld Optionen die Option vollständige HTML-Formatierung auswählen. Sie können im Dialogfeld Abfrage bearbeiten auf das Dialogfeld Optionen zugreifen.

    • Wenn Sie die von Ihnen festgelegten Spaltenbreiten beibehalten möchten, aktivieren Sie das Kontrollkästchen Spaltenbreite anpassen .

    • Wenn Sie die angewendete Spaltensortierung,-Filterung und das Layout beibehalten möchten, aktivieren Sie das Kontrollkästchen Spalte sortieren/filtern/Layout beibehalten .

      Hinweis: Dieses Kontrollkästchen ist für Webabfragen nicht verfügbar.

    • Wenn Sie die angewendete Spaltenfilterung beibehalten möchten, aktivieren Sie das Kontrollkästchen Spalten Filter beibehalten .

      Hinweis: Dieses Kontrollkästchen ist nur für Webabfragen verfügbar, die auf XML-Daten basieren.

Hinweis: Das folgende Verfahren gilt nur für einen externen Datenbereich, der aus einem Microsoft Office 2003-Programm konvertiert wird, oder in einen externen Datenbereich, der programmgesteuert erstellt wird. Alle externen Datenbereiche, die mit der Benutzeroberfläche erstellt werden, werden als Excel-Tabellen erstellt. Diese Tabellen werden automatisch erweitert, wenn neue Zeilen hinzugefügt werden, und Sie können berechnete Spalten ausfüllen.

  1. Geben Sie eine Formel in eine Zelle ein, die sich neben der ersten Datenzeile im externen Datenbereich befindet.

    Hinweis: Die erste Zeile der Daten kann die erste oder zweite Zeile im externen Datenbereich sein, je nachdem, ob die erste Zeile Kopfzeilen enthält.

  2. Wählen Sie die Zelle aus, und doppelklicken Sie auf das Ausfüllkästchen, um die Formel in alle Zeilen im externen Datenbereich zu kopieren.

  3. Klicken Sie auf eine Zelle im externen Datenbereich.

  4. Klicken Sie auf der Registerkarte Daten in der Gruppe Verbindungen auf Eigenschaften.

    Abbildung des Excel-Menübands

  5. Aktivieren Sie im Dialogfeld Eigenschaften für externen Datenbereich das Kontrollkästchen Formeln in Spalten neben Daten ausfüllen .

    Hinweis: Wenn der externe Datenbereich expandiert, wenn Sie Aktualisieren, kopiert Excel nur die Formeln, die unmittelbar neben oder innerhalb des externen Datenbereichs liegen.

Beim Fixieren eines externen Datenbereichs werden die Daten, aber nicht die zugrunde liegende Abfrage beibehalten, sodass ein fixierter externer Datenbereich nicht aktualisiert werden kann.

  1. Klicken Sie auf das Arbeitsblatt, das die Excel-Tabelle enthält, aus der Sie die Datenverbindung entfernen möchten.

  2. Klicken Sie auf der Bearbeitungsleiste auf den Pfeil neben dem Feld Name, und klicken Sie dann auf den Namen des externen Datenbereichs, aus dem Sie die Datenverbindung entfernen möchten. Anschließend wird der Datenbereich ausgewählt.

  3. Klicken Sie auf der Registerkarte Tools in der Gruppe Externe Tabellendaten auf Verknüpfung aufheben. Der Datenbereich verbleibt und hat weiterhin denselben Namen, aber die Verbindung wird gelöscht.

Hinweis: Das folgende Verfahren gilt nur für einen externen Datenbereich, der aus einem Microsoft Office 2003-Programm konvertiert wird, oder in einen externen Datenbereich, der programmgesteuert erstellt wird. Alle externen Datenbereiche, die mit der Benutzeroberfläche erstellt werden, werden als Excel-Tabellen erstellt. Diese Tabellen werden automatisch erweitert, wenn neue Zeilen hinzugefügt werden, und Sie können berechnete Spalten ausfüllen.

  1. Klicken Sie auf der Registerkarte Daten in der Gruppe Verbindungen auf Eigenschaften.

    Abbildung des Excel-Menübands

  2. Deaktivieren Sie unter Abfragedefinitiondas Kontrollkästchen Abfragedefinition speichern .

Hinweis:  Wenn Sie die Arbeitsmappe speichern, wird die zugrunde liegende Abfrage aus der Arbeitsmappe gelöscht. Die gespeicherten Datenbankabfragedateien (DQY-oder ODC-Dateien) werden jedoch nicht gelöscht. Wenn Sie die Abfrage gespeichert haben, als Sie Sie im Abfrage-Assistenten oder in Microsoft Query erstellt haben, wird die Abfragedatei auf Ihrem Computer gespeichert, und Sie können die Abfrage erneut verwenden, um externe Daten abzurufen. Weitere Informationen finden Sie in der Hilfe zu Microsoft Query.

Hinweis: Das folgende Verfahren gilt nur für einen externen Datenbereich, der mit dem Datenverbindungs-Assistenten oder mit Microsoft Query (und nicht mit einer importierten Textdatei oder Webabfrage) erstellt wird, einem externen Datenbereich, der von einem Microsoft Office 2003-Programm konvertiert wird, oder von einem externen Datenbereich, der programmgesteuert erstellt wird. Alle externen Datenbereiche, die mit der Benutzeroberfläche erstellt werden, werden als Excel-Tabellen erstellt.

  1. Fügen Sie eine leere Zeile oberhalb des externen Datenbereichs ein, indem Sie eine der folgenden Aktionen ausführen:

    • Wählen Sie eine Zelle aus, über der Sie die neue Zeile einfügen möchten. Klicken Sie dann auf der Registerkarte Start in der Gruppe Zellen auf den Pfeil neben Einfügen, und klicken Sie dann auf Tabellenzeilen einfügen. Da Sie eine Zelle markiert haben, wird eine neue Zeile oberhalb der aktuellen Zeile eingefügt.

    • Klicken Sie auf den Zeilenmarkierer der Zeile, über der Sie eine neue Zeile einfügen möchten. Klicken Sie dann auf der Registerkarte Start in der Gruppe Zellen auf Einfügen. Da Sie eine ganze Zeile markiert haben, wird eine neue Zeile oberhalb der markierten Zeile eingefügt.

  2. Geben Sie die gewünschten Beschriftungen in die Zellen in der leeren Zeile ein.

  3. Klicken Sie auf eine Zelle im externen Datenbereich.

  4. Klicken Sie auf der Registerkarte Daten in der Gruppe Verbindungen auf Eigenschaften.

    Abbildung des Excel-Menübands

  5. Deaktivieren Sie im Dialogfeld Eigenschaften für externen Datenbereich unter Datenformatierung und-Layoutdas Kontrollkästchen Feldnamen einbeziehen , und klicken Sie dann auf OK.

  6. Um die vorhandenen Feldnamen zu entfernen und den externen Datenbereich zu aktualisieren, klicken Sie auf eine Zelle im externen Datenbereich, und klicken Sie dann auf Daten Schaltflächensymbol aktualisieren .

Hinweis: Wenn Sie Daten aus einer Datenbank abrufen, werden alle Änderungen an Spaltennamen in Microsoft Query im externen Datenbereich beibehalten. Informationen zum Ändern von Spaltennamen in der Abfrage finden Sie in der Hilfe zu Microsoft Query.

  1. Klicken Sie auf das Arbeitsblatt mit dem externen Datenbereich, den Sie löschen möchten.

  2. Klicken Sie auf der Bearbeitungsleiste auf den Pfeil neben dem Feld Name, und klicken Sie dann auf den Namen des externen Datenbereichs, den Sie löschen möchten.

    Wenn es sich bei dem externen Datenbereich um eine Excel-Tabelle handelt, drücken Sie STRG + A, um die gesamte Tabelle zu markieren.

  3. Drücken Sie die ENTF-Taste, um den externen Datenbereich zu löschen.

  4. Wenn Sie die zugrunde liegende Abfrage löschen möchten, klicken Sie auf Ja , wenn Excel Sie auffordert.

Benötigen Sie weitere Hilfe?

Sie können jederzeit einen Experten in der Excel Tech Community fragen, Unterstützung in der Answers Community erhalten oder aber ein neues Feature oder eine Verbesserung auf Excel User Voice vorschlagen.

Hinweis:  Diese Seite wurde automatisiert übersetzt und kann Grammatikfehler oder Ungenauigkeiten enthalten. Unser Ziel ist es, Ihnen hilfreiche Inhalte bereitzustellen. Lassen Sie uns bitte wissen, ob diese Informationen hilfreich für Sie waren. Hier finden Sie den englischen Artikel als Referenz.

Benötigen Sie weitere Hilfe?

Ihre Office-Fähigkeiten erweitern
Schulungen erkunden
Neue Funktionen als Erster erhalten
Office Insider werden

War diese Information hilfreich?

Vielen Dank für Ihr Feedback!

Vielen Dank für Ihr Feedback. Es klingt, als ob es hilfreich sein könnte, Sie mit einem unserer Office-Supportmitarbeiter zu verbinden.

×