Sie können Microsoft Query verwenden, um Daten aus externen Quellen abzurufen. Wenn Sie Microsoft Query zum Abrufen von Daten aus Unternehmensdatenbanken und -dateien verwenden, müssen Sie die Daten, die Sie analysieren möchten, nicht erneut in die Excel. Sie können Ihre Berichte Excel Zusammenfassungen auch automatisch aus der ursprünglichen Quelldatenbank aktualisieren, sobald die Datenbank mit neuen Informationen aktualisiert wird.

Mithilfe von Microsoft Query können Sie eine Verbindung mit externen Datenquellen herstellen, Daten aus diesen externen Quellen auswählen, diese Daten in ihr Arbeitsblatt importieren und die Daten bei Bedarf aktualisieren, damit die Arbeitsblattdaten mit den Daten in den externen Quellen synchronisiert bleiben.

Datenbanktypen, auf die Sie zugreifen können     Sie können Daten aus verschiedenen Datenbanktypen abrufen, einschließlich Microsoft Office Access, Microsoft SQL Server und Microsoft SQL Server OLAP Services. Sie können Daten auch aus Excel Arbeitsmappen und aus Textdateien abrufen.

Microsoft Office stellt Treiber zum Abrufen von Daten aus den folgenden Datenquellen zur Verfügung:

  • Microsoft SQL Server Analysis Services (OLAP-Anbieter )

  • Microsoft Office Access

  • dBASE

  • Microsoft FoxPro

  • Microsoft Office Excel

  • Oracle

  • Paradox

  • Textdateidatenbanken

Sie können auch ODBC-Treiber oder Datenquellentreiber von anderen Herstellern verwenden, um Informationen aus Datenquellen abzurufen, die hier nicht aufgeführt sind, einschließlich anderer Typen von OLAP-Datenbanken. Informationen zum Installieren eines odBC-Treibers oder Datenquellentreibers, der hier nicht aufgeführt ist, finden Sie in der Dokumentation zur Datenbank, oder wenden Sie sich an den Datenbankanbieter.

Auswählen von Daten aus einer Datenbank     Sie rufen Daten aus einer Datenbank ab, indem Sie eine Abfrage erstellen. Dies ist eine Frage, die Sie zu daten stellen, die in einer externen Datenbank gespeichert sind. Wenn Ihre Daten z. B. in einer Access-Datenbank gespeichert sind, möchten Sie möglicherweise die Umsatzzahlen für ein bestimmtes Produkt nach Region wissen. Sie können einen Teil der Daten abrufen, indem Sie nur die Daten für das Produkt und die Region auswählen, das/die Sie analysieren möchten.

Mit Microsoft Query können Sie die Datenspalten auswählen, die Sie verwenden möchten, und nur diese Daten in Excel.

Aktualisieren des Arbeitsblatts in einem Vorgang     Sobald Sie über externe Daten in einer Excel-Arbeitsmappe verfügen, können Sie bei jeder Änderung der Datenbank die Daten Aktualisieren, um Ihre Analyse zu aktualisieren – ohne die Zusammenfassungsberichte und Diagramme neu erstellen zu müssen. Sie können z. B. eine monatliche Umsatzzusammenfassung erstellen und diese jeden Monat aktualisieren, wenn die neuen Umsatzzahlen einzahlen.

So verwendet Microsoft Query Datenquellen     Nachdem Sie eine Datenquelle für eine bestimmte Datenbank eingerichtet haben, können Sie diese immer dann verwenden, wenn Sie eine Abfrage zum Auswählen und Abrufen von Daten in dieser Datenbank erstellen möchten, ohne alle Verbindungsinformationen erneut ein geben zu müssen. Microsoft Query verwendet die Datenquelle, um eine Verbindung mit der externen Datenbank herzustellen und Ihnen zu zeigen, welche Daten verfügbar sind. Nachdem Sie ihre Abfrage erstellt und die Daten an Excel zurückgegeben haben, stellt Microsoft Query der Excel-Arbeitsmappe sowohl Die Abfrage- als auch Datenquelleninformationen zur Verfügung, sodass Sie erneut eine Verbindung mit der Datenbank herstellen können, wenn Sie die Daten aktualisieren möchten.

Abbildung: So werden in Query Datenquellen verwendet

Verwenden von Microsoft Query zum Importieren von Daten     Um externe Daten mit Microsoft Query Excel Daten zu importieren, führen Sie die folgenden grundlegenden Schritte aus, die in den folgenden Abschnitten jeweils ausführlicher beschrieben werden.

Was ist eine Datenquelle?     Eine Datenquelle ist ein gespeicherter Satz von Informationen, der es Excel und Microsoft Query ermöglicht, eine Verbindung mit einer externen Datenbank herzustellen. Wenn Sie Microsoft Query zum Einrichten einer Datenquelle verwenden, geben Sie der Datenquelle einen Namen und geben dann den Namen und Speicherort der Datenbank oder des Servers, den Datenbanktyp sowie Ihre Anmelde- und Kennwortinformationen an. Die Informationen umfassen auch den Namen eines OBDC-Treibers oder eines Datenquellentreibers, bei dem es sich um ein Programm handelt, das Verbindungen mit einem bestimmten Datenbanktyp erstellt.

So richten Sie eine Datenquelle mithilfe von Microsoft Query ein

  1. Klicken Sie auf der Registerkarte Daten in der Gruppe Externe Daten erhalten auf Aus anderenQuellen, und klicken Sie dann auf Aus Microsoft Query.

  2. Führen Sie eine der folgenden Aktionen aus:

    • Wenn Sie eine Datenquelle für eine Datenbank, eine Textdatei oder eine Excel angeben möchten, klicken Sie auf die Registerkarte Datenbanken.

    • Wenn Sie eine OLAP-Cube-Datenquelle angeben möchten, klicken Sie auf die Registerkarte OLAP-Cubes. Diese Registerkarte ist nur verfügbar, wenn Sie Microsoft Query über einen Excel.

  3. Doppelklicken Sie auf<Neue Datenquelle>.

    – oder –

    Klicken <auf Neue>, und klicken Sie dann auf OK.

    Das Dialogfeld Neue Datenquelle erstellen wird angezeigt.

  4. Geben Sie in Schritt 1 einen Namen zum Identifizieren der Datenquelle ein.

  5. Klicken Sie in Schritt 2 auf einen Treiber für den Datenbanktyp, den Sie als Datenquelle verwenden.

    Hinweise: 

    • Wenn die externe Datenbank, auf die Sie zugreifen möchten, von den ODBC-Treibern, die mit Microsoft Query installiert sind, nicht unterstützt wird, müssen Sie einen Microsoft Office-kompatiblen ODBC-Treiber von einem Drittanbieter wie dem Hersteller der Datenbank beziehen und installieren. Installationsanweisungen erhalten Sie beim Datenbankanbieter.

    • FÜR OLAP-Datenbanken sind keine ODBC-Treiber erforderlich. Bei der Installation von Microsoft Query werden Treiber für Datenbanken installiert, die mithilfe von Microsoft SQL Server Analysis Services erstellt wurden. Wenn Sie eine Verbindung mit anderen OLAP-Datenbanken herstellen möchten, müssen Sie einen Datenquellentreiber und Clientsoftware installieren.

  6. Klicken Verbindenauf , und geben Sie dann die Informationen an, die zum Herstellen einer Verbindung mit der Datenquelle erforderlich sind. Bei Datenbanken, Excel Arbeitsmappen und Textdateien sind die von Ihnen zur Verfügung 2013 gespeicherten Informationen vom ausgewählten Datenquellentyp abhängig. Möglicherweise werden Sie aufgefordert, einen Anmeldenamen, ein Kennwort, die Version der verwendeten Datenbank, den Datenbankspeicherort oder andere Informationen für den Datenbanktyp einzugeben.

    Wichtig: 

    • Verwenden Sie sichere Kennwörter, bei denen Groß- und Kleinbuchstaben, Zahlen und Symbole kombiniert sind. Unsichere Kennwörter weisen nicht diese Mischung auf. Sicheres Kennwort: Y6dh!et5. Unsicheres Kennwort: Haus27. Kennwörter sollten mindestens acht Zeichen umfassen. Ein Pass-Ausdruck mit mindestens 14 Zeichen ist besser geeignet.

    • Es ist wichtig, dass Sie sich das jeweilige Kennwort merken. Wenn Sie das Kennwort vergessen, kann es nicht von Microsoft abgerufen werden. Bewahren Sie die notierten Kennwörter an einem sicheren Ort auf, damit sie nicht mit den zu schützenden Informationen in Verbindung gebracht werden können.

  7. Nachdem Sie die erforderlichen Informationen eingeben, klicken Sie auf OKoder Fertig stellen, um zum Dialogfeld Neue Datenquelle erstellen zurückzukehren.

  8. Wenn Ihre Datenbank Tabellen enthält und eine bestimmte Tabelle automatisch im Abfrage-Assistenten angezeigt werden soll, klicken Sie auf das Feld für Schritt 4, und klicken Sie dann auf die tabelle, die Sie verwenden möchten.

  9. Wenn Sie bei Verwendung der Datenquelle ihren Anmeldenamen und das Kennwort nicht eingeben möchten, aktivieren Sie das Kontrollkästchen Meine Benutzer-ID und mein Kennwort in der Datenquellendefinition speichern. Das gespeicherte Kennwort ist nicht verschlüsselt. Wenn das Kontrollkästchen nicht verfügbar ist, wenden Sie sich an Ihren Datenbankadministrator, um festzustellen, ob diese Option verfügbar gemacht werden kann.

    Sicherheitshinweis: Vermeiden Sie das Speichern von Anmeldeinformationen beim Herstellen einer Verbindung mit Datenquellen. Diese Informationen können als Nur-Text gespeichert sein, und ein böswilliger Benutzer könnte auf die Informationen zugreifen, um die Sicherheit der Datenquelle zu gefährdet.

Nachdem Sie diese Schritte abgeschlossen haben, wird der Name der Datenquelle im Dialogfeld Datenquelle auswählen angezeigt.

Verwenden des Abfrage-Assistenten für die meisten Abfragen     Der Abfrage-Assistent erleichtert das Auswählen und Zusammenbringen von Daten aus verschiedenen Tabellen und Feldern in Ihrer Datenbank. Mit dem Abfrage-Assistenten können Sie die Tabellen und Felder auswählen, die Sie hinzufügen möchten. Eine innere Verknüpfung (ein Abfragevorgang, der angibt, dass Zeilen aus zwei Tabellen auf der Grundlage identischer Feldwerte kombiniert werden) wird automatisch erstellt, wenn der Assistent ein Primärschlüsselfeld in einer Tabelle und ein Feld mit demselben Namen in einer zweiten Tabelle erkennt.

Sie können auch den Assistenten verwenden, um das Ergebnis zu sortieren und einfache Filter zu verwenden. Im letzten Schritt des Assistenten können Sie auswählen, dass die Daten an die Abfrage zurückgegeben Excel oder die Abfrage in Microsoft Query weiter verfeinern. Nachdem Sie die Abfrage erstellt haben, können Sie sie entweder in Excel oder in Microsoft Query ausführen.

Führen Sie die folgenden Schritte aus, um den Abfrage-Assistenten zu starten.

  1. Klicken Sie auf der Registerkarte Daten in der Gruppe Externe Daten erhalten auf Aus anderenQuellen, und klicken Sie dann auf Aus Microsoft Query.

  2. Stellen Sie im Dialogfeld Datenquelle auswählen sicher, dass das Kontrollkästchen Abfrage-Assistent zum Erstellen/Bearbeiten von Abfragen verwenden aktiviert ist.

  3. Doppelklicken Sie auf die Datenquelle, die Sie verwenden möchten.

    – oder –

    Klicken Sie auf die Datenquelle, die Sie verwenden möchten, und klicken Sie dann auf OK.

Direktes Arbeiten in Microsoft Query für andere Abfragetypen     Wenn Sie eine komplexere Abfrage erstellen möchten, als der Abfrage-Assistent zulässt, können Sie direkt in Microsoft Query arbeiten. Sie können Microsoft Query verwenden, um Abfragen, die Sie mit der Erstellung im Abfrage-Assistenten beginnen, anzeigen und zu ändern, oder Sie können neue Abfragen erstellen, ohne den Assistenten zu verwenden. Arbeiten Sie direkt in Microsoft Query, wenn Sie Abfragen mit den folgenden Aufgaben erstellen möchten:

  • Auswählen bestimmter Daten aus einem Feld     In einer großen Datenbank möchten Sie möglicherweise einige der Daten in einem Feld auswählen und nicht mehr benötigte Daten weglassen. Wenn Sie beispielsweise Daten für zwei der Produkte in einem Feld benötigen, das Informationen zu vielen Produkten enthält, können Sie Kriterien verwenden, um Daten nur für die beiden von Ihnen benötigten Produkte auszuwählen.

  • Abrufen von Daten basierend auf unterschiedlichen Kriterien bei jeder Ausführung der Abfrage     Wenn Sie denselben Excel-Bericht oder die gleiche Zusammenfassung für mehrere Bereiche in denselben externen Daten erstellen müssen , z. B. einen separaten Umsatzbericht für jede Region, können Sie eine Parameterabfrage. Wenn Sie eine Parameterabfrage ausführen, werden Sie aufgefordert, einen Wert als Kriterium zu verwenden, wenn die Abfrage Datensätze auswählt. Beispielsweise könnte eine Parameterabfrage Sie zur Eingabe einer bestimmten Region aufgefordert haben, und Sie können diese Abfrage wiederverwenden, um jeden Ihrer regionalen Umsatzberichte zu erstellen.

  • Verbinden von Daten auf unterschiedliche Weise     Die inneren Verknüpfungen, die der Abfrage-Assistent erstellt, sind die am häufigsten verwendete Verknüpfungsart zum Erstellen von Abfragen. Manchmal möchten Sie jedoch einen anderen Verknüpfungstyp verwenden. Wenn Sie beispielsweise über eine Tabelle mit Produktverkaufsinformationen und eine Tabelle mit Kundeninformationen verfügen, verhindert eine innere Verknüpfung (der vom Abfrage-Assistenten erstellte Typ) das Abrufen von Kundendatensätzen für Kunden, die keinen Kauf tätigen. Mithilfe von Microsoft Query können Sie diese Tabellen so verbinden, dass alle Kundendatensätze zusammen mit den Umsatzdaten für die Kunden abgerufen werden, die Einkäufe getätigt haben.

Führen Sie die folgenden Schritte aus, um Microsoft Query zu starten.

  1. Klicken Sie auf der Registerkarte Daten in der Gruppe Externe Daten erhalten auf Aus anderenQuellen, und klicken Sie dann auf Aus Microsoft Query.

  2. Stellen Sie im Dialogfeld Datenquelle auswählen sicher, dass das Kontrollkästchen Abfrage-Assistent zum Erstellen/Bearbeiten von Abfragen verwenden nicht angezeigt wird.

  3. Doppelklicken Sie auf die Datenquelle, die Sie verwenden möchten.

    – oder –

    Klicken Sie auf die Datenquelle, die Sie verwenden möchten, und klicken Sie dann auf OK.

Wiederversprechen und Freigeben von Abfragen     Sowohl im Abfrage-Assistenten als auch in Microsoft Query können Sie Ihre Abfragen als DQY-Datei speichern, die Sie ändern, wiederverwenden und freigeben können. Excel können DQY-Dateien direkt öffnen, wodurch Sie oder andere Benutzer zusätzliche externe Datenbereiche aus derselben Abfrage erstellen können.

So öffnen Sie eine gespeicherte Abfrage aus Excel:

  1. Klicken Sie auf der Registerkarte Daten in der Gruppe Externe Daten erhalten auf Aus anderenQuellen, und klicken Sie dann auf Aus Microsoft Query. Das Dialogfeld Datenquelle auswählen wird angezeigt.

  2. Klicken Sie im Dialogfeld Datenquelle auswählen auf die Registerkarte Abfragen.

  3. Doppelklicken Sie auf die gespeicherte Abfrage, die Sie öffnen möchten. Die Abfrage wird in Microsoft Query angezeigt.

Wenn Sie eine gespeicherte Abfrage öffnen möchten und Microsoft Query bereits geöffnet ist, klicken Sie auf das Menü Microsoft Query-Datei, und klicken Sie dann auf Öffnen.

Wenn Sie auf eine DQY-Datei doppelklicken, Excel, führt die Abfrage aus und fügt die Ergebnisse in ein neues Arbeitsblatt ein.

Wenn Sie eine Excel oder einen Bericht freigeben möchten, die auf externen Daten basiert, können Sie anderen Benutzern eine Arbeitsmappe zur Verfügung stellen, die einen externen Datenbereich enthält, oder Sie können einen Vorlage. Mit einer Vorlage können Sie die Zusammenfassung oder den Bericht speichern, ohne die externen Daten zu speichern, damit die Datei kleiner ist. Die externen Daten werden abgerufen, wenn ein Benutzer die Berichtsvorlage öffnet.

Nachdem Sie eine Abfrage im Abfrage-Assistenten oder in Microsoft Query erstellt haben, können Sie die Daten an ein Excel zurückgeben. Die Daten werden dann zu Externer Datenbereich Daten oder PivotTable-Bericht, die Sie formatieren und aktualisieren können.

Formatieren abgerufener Daten     In Excel können Sie Tools wie Diagramme oder automatische Teilergebnisse verwenden, um die von Microsoft Query abgerufenen Daten zu präsentieren und zusammenzufassen. Sie können die Daten formatieren, und die Formatierung wird beibehalten, wenn Sie die externen Daten aktualisieren. Sie können eigene Spaltenbeschriftungen anstelle der Feldnamen verwenden und Zeilennummern automatisch hinzufügen.

Excel können neue Daten, die Sie am Ende eines Bereichs eingeben, automatisch so formatieren, dass sie den vorherigen Zeilen entsprechen. Excel Formeln, die in den vorherigen Zeilen wiederholt wurden, können auch automatisch kopiert und auf weitere Zeilen erweitert werden.

Hinweis: Um auf neue Zeilen im Bereich erweitert zu werden, müssen die Formate und Formeln in mindestens drei der fünf vorhergehenden Zeilen angezeigt werden.

Sie können diese Option jederzeit aktivieren (oder wieder deaktivieren):

  1. Klicken Sie auf Datei > Optionen > Erweitert.

    In Excel 2007: Klicken Sie auf Microsoft Office Schaltfläche Abbildung der Office-Schaltfläche, klicken Sie Excel Optionen, und klicken Sie dann auf die Kategorie Erweitert.

  2. Aktivieren Sie im Abschnitt Bearbeitungsoptionen das Kontrollkästchen Datenbereichsformate und -formeln erweitern. Wenn Sie die automatische Datenbereichsformatierung wieder deaktivieren möchten, deaktivieren Sie das Kontrollkästchen.

<c0>Aktualisieren von externen Daten</c0>.     Wenn Sie externe Daten aktualisieren, führen Sie die Abfrage aus, um neue oder geänderte Daten abzurufen, die Ihren Spezifikationen entsprechen. Sie können eine Abfrage sowohl in Microsoft Query als auch in Excel. Excel bietet mehrere Optionen zum Aktualisieren von Abfragen, einschließlich der Aktualisierung der Daten bei jedem Öffnen der Arbeitsmappe und der automatischen Aktualisierung in Zeitintervallen. Sie können während Excel Datenaktualisierungen weiterarbeiten, und Sie können auch den Status überprüfen, während die Daten aktualisiert werden. Weitere Informationen finden Sie unter Aktualisieren einer externen Datenverbindung in Excel.

Seitenanfang

Benötigen Sie weitere Hilfe?

Ihre Office-Fähigkeiten erweitern
Schulungen erkunden
Neue Funktionen als Erster erhalten
Microsoft Insider beitreten

War diese Information hilfreich?

Wie zufrieden sind Sie mit der Übersetzungsqualität?
Was hat Ihre Erfahrung beeinflusst?

Vielen Dank für Ihr Feedback!

×