Verwenden von WENN, um zu prüfen, ob eine Zelle leer ist

Manchmal müssen Sie prüfen, ob eine Zelle leer ist, in der Regel, weil Sie nicht möchten, dass eine Formel ein Ergebnis ohne Eingabe anzeigt.

Die Formel in Zelle E2 lautet =WENN(D2=1;"Ja";WENN(D2=2;"Nein";"Vielleicht"))

In diesem Fall verwenden wir WENN mit der ISTLEER-Funktion:

  • =WENN(ISTLEER(D2);"Leer";"Nicht Leer")

Die Formel besagt Folgendes: WENN(D2 leer ist, gib "Leer" zurück, andernfalls gib "Nicht Leer" zurück). Sie können auch ganz einfach eine eigene Formel für die "Nicht Leer"-Bedingung verwenden. Im nächsten Beispiel verwenden wir "" anstelle von ISTLEER. Das "" bedeutet im Wesentlichen "nichts".

Überprüfen, ob eine Zelle leer ist – die Formel in Zelle E2 lautet =WENN(ISTLEER(D2);"Leer";"Nicht Leer")

=WENN(D3="";"Leer";"Nicht Leer")

Diese Formel besagt Folgendes: WENN(D3 nichts ist, gib "Leer" zurück, andernfalls "Nicht leer"). Nachfolgend ein Beispiel für eine sehr häufige Methode zur Verwendung von "" zur Verhinderung der Berechnung einer Formel, wenn eine abhängige Zelle leer ist:

  • =WENN(D3="";"";IhreFormel())

    WENN(D3 nichts ist, gib nichts zurück, andernfalls berechne die Formel).

Benötigen Sie weitere Hilfe?

Ihre Office-Fähigkeiten erweitern
Schulungen erkunden
Neue Funktionen als Erster erhalten
Office Insider werden

War diese Information hilfreich?

×