WAHL (Funktion)

In diesem Artikel werden die Formelsyntax und die Verwendung der Funktion WAHL in Microsoft Excel beschrieben.

Beschreibung

Verwendet Index, um einen Wert aus der Liste der Werteargumente zurückzugeben. Verwenden Sie WAHL, um bis zu 254 Werte auf der Grundlage der Indexnummer auszuwählen. Wenn beispielsweise Wert1 bis Wert7 Tage der Woche sind, gibt WAHL einen der Tage zurück, wenn eine Zahl zwischen 1 und 7 als Index verwendet wird.

Syntax

WAHL(Index;Wert1;[Wert2];...)

Die Syntax der Funktion WAHL weist die folgenden Argumente auf:

  • Index_num    Erforderlich. Gibt an, welches Wert Argument ausgewählt ist. Index_num muss eine Zahl zwischen 1 und 254 oder eine Formel oder ein Bezug auf eine Zelle sein, die eine Zahl zwischen 1 und 254 enthält.

    • Wenn Index 1 ist, gibt WAHL Wert1 zurück. Wenn Index 2 ist, gibt WAHL Wert2 zurück usw.

    • Wenn Index kleiner als 1 oder größer als die Nummer des letzten Werts in der Liste ist, gibt WAHL den Fehlerwert #WERT! zurück.

    • Wenn Index ein Bruch ist, wird der Wert in die kleinste ganze Zahl umgewandelt, bevor er verwendet wird.

  • Wert1; Wert2;...     Wert 1 ist erforderlich, nachfolgende Werte sind optional. 1 bis 254-Wertargumente, aus denen auswählen einen Wert oder eine Aktion auswählt, die basierend auf index_num ausgeführt werden soll. Die Argumente können Zahlen, Zellbezüge, definierte Namen, Formeln, Funktionen oder Text sein.

Hinweise

  • Wenn "Index" eine Matrix ist, wird jeder Wert ausgewertet, wenn WAHL ausgewertet wird.

  • Die Werteargumente für WAHL können Bereichsbezüge oder einzelne Werte sein.

    Beispielsweise wird die Formel:

=SUMME(WAHL(2;A1: A10;B1: B10;C1: C10))

ausgewertet zu:

=SUMME(B1:B10)

Diese Funktion gibt dann auf der Grundlage der Werte im Bereich B1:B10 einen Wert zurück.

Die WAHL-Funktion wird zuerst ausgewertet und gibt den Bezug B1:B10 zurück. Anschließend wird die SUMME-Funktion ausgewertet, wobei als Argument B1:B10, also das Ergebnis der WAHL-Funktion, verwendet wird.

Beispiele

Kopieren Sie die Beispieldaten in der folgenden Tabelle, und fügen Sie sie in Zelle A1 eines neuen Excel-Arbeitsblatts ein. Um die Ergebnisse der Formeln anzuzeigen, markieren Sie sie, drücken Sie F2 und dann die EINGABETASTE. Im Bedarfsfall können Sie die Breite der Spalten anpassen, damit alle Daten angezeigt werden.

Daten

 

Erster

Nägel

Zweiter

Schrauben

Dritter

Muttern

Beendet

Bolzen

Formel

Beschreibung

Ergebnis

=WAHL(2;A2;A3;A4;A5)

Wert des zweiten Listenarguments (Wert von Zelle A3)

Zweiter

=WAHL(4;B2;B3;B4;B5)

Wert des vierten Listenarguments (Wert von Zelle B5)

Bolzen

=WAHL(3;"Weit";115;"Welt";8)

Wert des dritten Listenarguments

Welt

Beispiel 2

Daten

23

45

12

10

Formel

Beschreibung (Ergebnis)

Ergebnis

=SUMME(A2:WAHL(2;A3;A4;A5))

Addiert die Werte des Bereichs A2:A4. Die WAHL-Funktion gibt A4 als zweiten Teil des Bereichs für die Funktion SUMME zurück.

80

Hinweis:  Diese Seite wurde automatisiert übersetzt und kann Grammatikfehler oder Ungenauigkeiten enthalten. Unser Ziel ist es, Ihnen hilfreiche Inhalte bereitzustellen. Lassen Sie uns bitte wissen, ob diese Informationen hilfreich für Sie waren. Hier finden Sie den englischen Artikel als Referenz.

Benötigen Sie weitere Hilfe?

Ihre Office-Fähigkeiten erweitern
Schulungen erkunden
Neue Funktionen als Erster erhalten
Office Insider werden

War diese Information hilfreich?

Vielen Dank für Ihr Feedback!

Vielen Dank für Ihr Feedback. Es klingt, als ob es hilfreich sein könnte, Sie mit einem unserer Office-Supportmitarbeiter zu verbinden.

×