Symptome
Angenommen, Sie stellen eine Verbindung zu Microsoft SQL Server 2012- oder 2014 Analysis Services her, die an einem Nichtstandardport ausgeführt werden, und der SQL-Browser ist deaktiviert. Wenn Sie eine MDX-Abfrage (MultiDimension Expressions) für die Cubeerstellung ausführen, wird möglicherweise die folgende Fehlermeldung angezeigt:
Hinweis
Ausführen der Abfrage ...
Entweder kann keine Verbindung mit dem Server "ServerName\Instance" hergestellt werden, oder Analysis Services wird auf dem angegebenen Computer nicht ausgeführt.
Fehler im OLE DB-Anbieter. Beim Abrufen von Informationen zur benannten Instance aus dem SQLBrowser-Dienst auf dem Server "ServerName" ist ein Fehler aufgetreten.
Fehler im OLE DB-Anbieter. Es konnte keine Verbindung mit dem Redirector hergestellt werden. Stellen Sie sicher, dass der SQLBrowser-Dienst auf dem Server "ServerName" ausgeführt wird.
Ausführung abgeschlossen
Ursache
Das Problem tritt auf, weil der falsche Codepfad verwendet wird. Eine Verbindung versucht immer, das Namensformat der Instance zu verwenden, das auf dem SQL-Browser basiert.
Lösung
Nachdem Sie den Hotfix angewendet haben, legen Sie den Wert von LocalCubeServerPortInConnectionString auf 1 fest, um dieses Feature in der SSAS-Konfigurationsdatei zu aktivieren.
Service Pack-Informationen für SQL Server 2014
Installieren Sie Service Pack 1 für SQL Server 2014, um dieses Problem zu beheben.
Weitere Informationen zu SQL Server 2014 Service Pack 1 (SP1) finden Sie unter In SQL Server 2014 Service Pack 1 behobene Fehler.
Service Pack-Informationen für SQL Server 2012
Um dieses Problem zu beheben, besorgen Sie sich das neueste Service Pack für Microsoft SQL Server 2012. Weitere Informationen finden Sie im folgenden Artikel der Microsoft Knowledge Base:
2755533 So erhalten Sie das neueste Service Pack für SQL Server 2012
Status
Microsoft hat bestätigt, dass dies ein Problem bei den Microsoft-Produkten ist, die im Abschnitt „Gilt für“ aufgeführt sind.