KB2289254 – Kumulatives Updatepaket 1 für SQL Server 2008 Service Pack 2

Gilt für
SQL Server 2008 Standard SQL Server 2008 Developer SQL Server 2008 Enterprise SQL Server 2008 Workgroup SQL Server 2008 Web SQL Server 2008 Express SQL Server 2008 Express with Advanced Services

EINFÜHRUNG

Microsoft SQL Server 2008-Hotfixes werden für bestimmte SQL Server Service Packs erstellt. Sie müssen einen SQL Server 2008 Service Pack 2-Hotfix auf eine Installation von SQL Server 2008 Service Pack 2 anwenden. Standardmäßig sind alle in einem Service Pack für SQL Server enthaltenen Hotfixes im nächsten Service Pack für SQL Server enthalten.

Das kumulative Update 1 für SQL Server 2008 Service Pack 2 (SP2) ist als Rollup nach Service Pack für SQL Server 2008-Kunden gedacht, die ein Upgrade auf SQL Server 2008 SP2 planen und weiterhin die Hotfixes von SQL Server 2008 SP1 behaltenKumulatives Update 9 für SQL Server 2008 SP1Kumulatives Update 10.

Hinweis: Dieser Build des kumulativen Updatepakets wird auch als Build 10.00.4266.00 bezeichnet.

Es wird empfohlen, Hotfixes zu testen, bevor Sie diese in einer Produktionsumgebung bereitstellen. Da die Builds kumulativ sind, enthält jede neue Fixversion alle Hotfixes und Sicherheitsfixes, die in der vorherigen Updateversion von SQL Server 2008 enthalten waren. Es wird empfohlen, die Anwendung des neuesten Fixrelease in Betracht zu ziehen, das diesen Hotfix enthält.
  Weitere Informationen finden Sie im folgenden Artikel der Microsoft Knowledge Base:

2402659 Die SQL Server 2008-Builds, die nach der Freigabe von SQL Server 2008 Service Pack 2 veröffentlicht wurden

Wichtige Hinweise zum kumulativen Updatepaket

  • Hotfixes für SQL Server 2008 sind jetzt mehrsprachig. Daher gibt es nur ein kumulatives Hotfixpaket für alle Sprachen.
  • Ein kumulatives Hotfixpaket enthält alle Komponentenpakete. Mit dem kumulativen Updatepaket werden nur die Komponenten aktualisiert, die auf dem System installiert sind.

Weitere Informationen

Beziehen des kumulativen Updates 1 für SQL Server 2008 Service Pack 2

Ein unterstütztes kumulatives Updatepaket ist jetzt von Microsoft erhältlich. Es sollen jedoch nur die in diesem Artikel beschriebenen Probleme behoben werden. Wenden Sie sie nur auf Systeme an, bei denen diese spezifischen Probleme auftreten. Dieses kumulative Updatepaket wird unter Umständen zu einem späteren Zeitpunkt weiteren Tests unterzogen. Wenn Ihr System durch keines dieser Probleme schwerwiegend beeinträchtigt ist, empfehlen wir, auf das nächste SQL Server 2008 Service Pack zu warten, das die Hotfixes in diesem kumulativen Updatepaket enthält.

Wenn das kumulative Update zum Download zur Verfügung steht, finden Sie einen Abschnitt "Hotfixdownload verfügbar" oben in diesem Knowledge Base-Artikel. Ist dies nicht der Fall, wenden Sie sich an die Kundenbetreuung bzw. den Support von Microsoft, um das kumulative Updatepaket zu beziehen.

Hinweis: Falls weitere Probleme auftreten oder eine Problembehandlung erforderlich ist, müssen Sie möglicherweise eine separate Serviceanfrage erstellen. Für zusätzliche Supportanfragen und -belange, die sich nicht auf dieses spezielle kumulative Updatepaket beziehen, fallen die üblichen Supportgebühren an. Besuchen Sie die folgende Microsoft-Website, um eine vollständige Liste der Telefonnummern von Microsoft-Kundendienst und -Support (CSS) anzuzeigen oder eine separate Serviceanfrage zu erstellen:

/contactus/?ws=support Hinweis: Das Formular "Hotfix-Download verfügbar" zeigt die Sprachen an, für die das kumulative Update verfügbar ist. Wenn Ihre Sprache nicht angezeigt wird, steht kein kumulatives Updatepaket für diese Sprache zur Verfügung.

Hotfixes, die im kumulativen Update 1 für SQL Server 2008 Service Pack 2 enthalten sind

  Microsoft Knowledge Base-Artikel, in denen diese Hotfixes behandelt werden, werden veröffentlicht, sobald sie verfügbar sind.

  Weitere Informationen zu den Fehlern in SQL Server finden Sie in den folgenden Artikeln der Microsoft Knowledge Base:

VSTS-Fehlernummer KB-Artikelnummer Beschreibung
561807 942712 FIX: Der W3WP.exe-Prozess der Internetinformationsdienste wird unerwartet beendet, wenn Sie eine Mergereplikation konfigurieren, die die Websynchronisierung in SQL Server 2005 und SQL Server 2008 verwendet
549033 keine Bei dem CDC-Aufzeichnungsauftrag kann die folgende Assertionsbedingung auftreten, wenn CDC für Datenbanktabellen aktiviert ist, die Spalten vom XML- oder anderen BLOB-Datentyp enthalten:

Assertion: Datei: Dateiname <>
line=<line number> Fehlgeschlagene Assertion = 'fNoWriters' -UND-
line=<line number> Fehlgeschlagene Assertion = 'fNoReaderWriterConflict'
576988 979212 FIX: Ein DateTime-Wert wird durch einen NULL-Wert ersetzt, wenn ein Konflikt mithilfe eines benutzerdefinierten Resolvers in Microsoft SQL Server 2005, Microsoft SQL Server 2008 oder Microsoft SQL Server 2008 R2 Mergereplikation gelöst wird
576899 980142 FIX: Wenn Sie einen SQL Server WMI-Anbieter verwenden, um Informationen über SQL Server 2005-, SQL Server 2008- oder SQL Server 2008 R2-Dienste zu erhalten, wird die Fehlermeldung "Fehler beim Laden des Anbieters" angezeigt, oder der Wmiprvse.exe Prozess reagiert nicht mehr.
548967 980350 FIX: Polnische Worttrennung bewirkt, dass eine Full-Text Abfrage in SQL Server 2008 ein unvollständiges Ergebnis zurückgibt
548983 980570 FIX: Fehlermeldung "Volltextindexfehler während der Komprimierung oder Dekomprimierung", wenn Sie den Volltextsuchindex in Microsoft SQL Server 2008 oder in Microsoft SQL Server 2008 R2 neu erstellen
548985 980832 FIX: Fehlermeldung "Eine Systemassertionsprüfung ist fehlgeschlagen" beim Ausführen einer Transaction-SQL-Abfrage in Microsoft SQL Server 2008 oder in Microsoft SQL Server 2008 R2
576971 980849 BEHEBUNG: Hohe Latenz bei Peer-to-Peer-Verteilungs-Agents in Microsoft SQL Server 2005, Microsoft SQL Server 2008 oder Microsoft SQL Server 2008 R2
548999 980883 FIX: Die proaktive Zwischenspeicherung startet unerwartet, wenn Sie Daten in SQL Server 2005, SQL Server 2008 R2 oder SQL Server 2008 einfügen
576984 980948 BEHEBUNG: Metadaten werden beschädigt, wenn Sie SSAS 2005-, SSAS 2008 R2- oder SSAS 2008-Datenordner von einem Computer auf einen anderen verschieben
548987 981120 FEHLERBEHEBUNG: Fehlermeldung, wenn Sie TDE für eine Datenbank aktivieren, für die die Momentaufnahme-Isolation in SQL Server 2008 oder in SQL Server 2008 R2 aktiviert ist
549015 981502 FIX: Eine Abfrage, die einen parallelen Abfrageplan verwendet, gibt jedes Mal, wenn Sie die Abfrage in SQL Server 2005, SQL Server 2008 R2 oder SQL Server 2008 ausführen, unterschiedliche Ergebnisse zurück
576985 981713 FIX: Eine Abfrage gibt ein falsches Ergebnis zurück, wenn ein Index verwendet wird, der online in SQL Server 2005, SQL Server 2008 R2 oder SQL Server 2008 neu erstellt wird
576992 981867 FIX: Ein berechnetes Element, das gefilterte Dimensionselemente verwendet, gibt in SSAS 2005, SSAS 2008 R2 oder SSAS 2008 ein falsches Ergebnis zurück
576993 981888 FIX: "Der Deadlock-Monitor konnte diesen Deadlock nicht auflösen. Der Server muss möglicherweise neu gestartet werden, um von dieser Bedingung wiederhergestellt zu werden." Fehlermeldung, wenn eine Datenbank in Microsoft SQL Server 2005, Microsoft SQL Server 2008 oder Microsoft SQL Server 2008 R2 wiederhergestellt wird
548989 982034 FIX: Das Übersetzungsfeature funktioniert nicht, wenn Sie eine Gruppierungsaktion in einer Excel-PivotTable ausführen, die SSAS 2008 oder SSAS 2008 R2 als Datenquelle verwendet
577024 982363 FEHLERBEHEBUNG: SQL Server 2005, SQL Server 2008 oder SQL Server 2008 R2 benötigen möglicherweise sehr lange, um eine ALTER TABLE-Anweisung abzuschließen, die eine XML-Datentypspalte in einer Tabelle von "NOT NULL" in "NULL" ändert
576999 982376 FIX: Ein Planerfehler ohne Ergebnis oder der Fehler 8623 tritt auf, wenn Sie eine Abfrage ausführen, die eine große IN-Klausel in SQL Server 2005, SQL Server 2008 oder SQL Server 2008 R2 enthält
561817 982808 Ein Drillthroughbericht funktioniert möglicherweise nicht falsch, wenn die Option "Eingabe von Anmeldeinformationen anfordern" in den Datenquellen in SQL Server 2008 Reporting Service verwendet wird
548995 982854 FIX: Fehlermeldung "Es ist nicht genügend Systemspeicher im Ressourcenpool 'intern' vorhanden, um diese Abfrage auszuführen" beim Ausführen einer Volltextabfrage, die zusammengesetzte Wörter in Microsoft SQL Server 2008 oder in Microsoft SQL Server 2008 R2 verwendet
548997 982857 FEHLERBEHEBUNG: Fehlermeldung beim Konfigurieren einer Transaktionsreplikation für eine Datenbank in SQL Server 2008 oder SQL Server 2008 R2
577003 982932 Die Abfrageleistung sinkt nach der Installation von SQL Server 2005 SP2 kumulatives Update 7 oder höher
577002 983429 FIX: Ein Deadlock tritt auf, wenn Sie eine Abfrage oder eine gespeicherte Prozedur ausführen, die eine XML-Spalte in SQL Server 2005, SQL Server 2008 oder SQL Server 2008 R2 enthält
549007 983446 Ein SSRS 2008-Bericht zeigt beim Exportieren des Berichts in das CSV-Format die duplizierte erste Zeile für jede Gruppe eines Unterberichts an
577006 983480 FIX: Verschiedene Probleme treten auf, wenn eine Datenbank an einer Datenbankspiegelungssitzung und an einer Transaktionsreplikation beteiligt ist, wenn das Ablaufverfolgungsflag 1448 aktiviert ist
577007 983500 FIX: Der Rollensynchronisierungsprozess verzögert sich, wenn ein automatisches Spiegelungs-Failover in SQL Server 2005, SQL Server 2008 oder SQL Server 2008 R2 stattfindet
549013 983577 FIX: Der Exportvorgang wird nie abgeschlossen, wenn Sie einen Bericht exportieren, der verschachtelte Tablix-Elemente in SSRS 2008 oder in SSRS 2008 R2 in die Erweiterungen exportiert, die von den harten Seitenumbruch-Renderern unterstützt werden
442541 2022254 SQL Server meldet bei Wiederherstellungsvorgängen möglicherweise den Fehler 18272
549017 2028406 FIX: Leerzeichen zwischen einigen Elementen werden in einem SQL Server 2008- oder SQL Server 2008 R2-Bericht falsch generiert
561732 2028727 FIX: Spaltengruppenwerte werden in SSRS 2008 nur in der letzten untergeordneten Zeilengruppe der angrenzenden Zeilengruppen angezeigt
549020 2028755 FIX: Beim Ausführen einer LIKE-Abfrage mit Platzhaltern und der Latin1_General_100_CS_AS Sortierung in Microsoft SQL Server 2008 oder Microsoft SQL Server 2008 R2 wird ein falsches Ergebnis zurückgegeben
561809 2028830 FIX: Gemeinsam genutzte Komponenten werden beim Implementieren einer SQL Server 2008-Failoverclusterinstallation am falschen Ort installiert
561744 2121407 FEHLERBEHEBUNG: Fehlermeldung, wenn Sie das Hilfsprogramm sqlcmd zum Ausführen der Transact-SQL-Abfrage in SQL Server 2008 und SQL Server 2008 R2 verwenden
549026 2152148 FIX: Fehlermeldung "Interner Fehler: Unerwartete Ausnahme ist aufgetreten" beim Ausführen einer MDX-Abfrage (Multidimensional Expressions) mithilfe von Zeitintelligenz in Microsoft SQL Server Analysis Services 2008
549039 2200755 FEHLERBEHEBUNG: Fehlermeldung beim Ausführen einer MDX-Abfrage in SSAS 2008 oder in SSAS 2008 R2
561746 2214666 FIX: Ein SSIS-Paket, das die Unpivot-Transformation verwendet, kann in SQL Server 2008 zu inkonsistenten Ergebnissen führen
549041 2220252 FEHLERBEHEBUNG: Ein SQL Server 2005-Bericht, der das Sichtbarkeitsumschaltfeature verwendet, wird in SQL Server 2008 oder in SQL Server 2008 R2 falsch ausgeführt
577012 2222998 FEHLERBEHEBUNG: Beim Ausführen einer Abfrage in SQL Server 2005, SQL Server 2008 oder SQL Server 2008 R2 wird eine falsche Kardinalitätsschätzung zurückgegeben
549031 2248999 FIX: Beim Aktualisieren einer Ansicht in Microsoft SQL Server 2008 oder in Microsoft SQL Server 2008 R2 tritt eine Indexbeschädigung auf
549043 2255410 Eine Abfrage gibt inkonsistente Ergebnisse zurück, bevor der Datencache in SSAS 2008 oder in SSAS 2008 R2 aufgewärmt wird
561750 2256829 FIX: Eine bestimmte Anzahl der letzten XML-Spalten wird möglicherweise nicht korrekt repliziert, wenn Sie die Websynchronisierung für die Mergereplikation in SQL Server 2008 verwenden
561757 2260502 FIX: Die Abfrageleistung nimmt nach dem Upgrade von SQL Server 2000 auf SQL Server 2008 ab, wenn die Abfrage eine benutzerdefinierte Skalarfunktion verwendet.
561760 2261403 FIX: Das Leistungsobjekt "SQL Server:SSIS Pipeline 10.0" wird nicht in der Liste "Leistungsobjekt" angezeigt, während ein anderer Benutzer auf einige SSIS-Pipelineindikatoren in SQL Server 2008 oder in SQL Server 2008 R2 zugreift
549028 2264562 FIX: Die Ausführung einer Volltextabfrage, die das Prädikat CONTAINS oder FREETEXT zusammen mit dem Operator "oder" verwendet, dauert sehr lange, um in SQL Server 2008 oder in SQL Server 2008 R2 ausgeführt zu werden.
577013 2268122 FIX: Fehlermeldung "Benutzer 'Gast' hat keine Berechtigung zum Ausführen von DBCC checkdb für die Datenbank 'mssqlsystemresource'" beim Ausführen des Befehls DBCC CHECKDB('master') auf einem Computer mit SQL Server 2005, SQL Server 2008 oder SQL Server 2008 R2
561766 2276330 FIX: Die Funktion "CHANGETABLE" ist in SQL Server 2008 und SQL Server 2008 R2 langsam
561768 2276717 FEHLERCODE: Fehlercode 1456, wenn Sie einen Zeugen zu einer neuen Datenbankspiegelungssitzung hinzufügen, die denselben Datenbanknamen wie eine vorhandene Datenbankspiegelungssitzung in Microsoft SQL Server 2005, Microsoft SQL Server 2008 und Microsoft SQL Server 2008 R2 hat
577014 2277207 FEHLERBEHEBUNG: Der Wert der Beschriftung "Achse" wird in jeder Spalte angezeigt, und der Wert für "Gitternetzlinienintervall" wird nach dem Upgrade einer RDL-Datei von SSRS 2005 auf SSRS 2008 nicht berücksichtigt
561770 2278042 FIX: Eine Transformation abgeleiteter Spalten kann in SSIS 2008 oder in SSIS 2008 R2 falsche Ergebnisse generieren, wenn eine Spalte sowohl in schreibgeschützter Verwendung als auch in Lese-/Schreibnutzung abgeleitet wird
561773 2282743 FIX: Die Sonderzeichen werden in einem "TextBox"-Steuerelement einer PDF-Datei falsch angezeigt, wenn Sie einen Bericht in SSRS 2008 rendern
577017 2283072 BEHEBUNG: Es ist ein Hotfix verfügbar, der es SQL Server 2008 Reporting Services und SQL Server 2008 R2 Reporting Services ermöglicht, einen 2048-Bit-RSA-Schlüssel zum Verschlüsseln eines Reporting Services-Schlüssels für FIPS-Konformität zu verwenden
561791 2287990 FIX: Die Transformation "Abgeleitete Spalte" führt möglicherweise zu falschen Ergebnissen, wenn Sie ein Paket in Microsoft SQL Server 2008 Integration Services ausführen
561789 2292725 BEHEBUNG: Beim Ausführen einer MDX-Abfrage in SQL Server 2008 SP1, für die das kumulative Update 5 oder eine höhere Version des Updatepakets installiert ist, kommt es zu einer verminderten Leistung
577020 2297308 FIX: Der Fehler "Ein früherer Filestream-Konfigurationsversuch war unvollständig" und eine Zugriffsverletzung treten auf, wenn Sie die Konfiguration der FILESTREAM-Funktion nach dem Setup auf einem SQL Server 2008- oder SQL Server 2008 R2-Failovercluster durchführen
561783 2297709 FIX: Eine Fehlermeldung kann auftreten, wenn Sie eine "BULK INSERT"-Abfrage auf einer Datenbank ausführen, die das Wiederherstellungsmodell "BULK_LOGGED" oder "SIMPLE" in SQL Server 2008 verwendet
577018 2297903 FIX: Ereignis-ID 322 wird protokolliert, wenn eine Serverüberwachung in SQL Server 2008 oder SQL Server 2008 R2 ausgegeben wird
561801 2300689 FIX: Sie können eine Sicherung einer Datenbank nicht auf einer anderen Instance von SQL Server wiederherstellen, wenn Sie transparent data encryption deaktivieren, bevor Sie die Sicherung in SQL Server 2008 oder in SQL Server 2008 R2 erstellen
561787 2306162 FIX: Schlechte Leistung und gelegentliche Non-yielding-Schedulerfehler treten auf, wenn Sie in SQL Server 2008 eine komplexe Sicht erstellen, die auf eine große Anzahl geschachtelter Ansichten oder Tabellen verweist
561785 2316135 FIX: Interner Fehler "Unerwartete Ausnahme" und Heap-Beschädigung treten auf, wenn Sie eine MDX-Abfrage ausführen, die von Drittanbietersoftware in SSAS 2008 generiert wird
561793 2344600 FIX: Fehler "Non-yielding Scheduler" kann auftreten, wenn Sie die CONTAINSTABLE-Funktion zusammen mit vielen OR- und AND-Prädikaten in SQL Server 2008 verwenden
561795 2352413 FIX: Abfragefehler und die Fehlermeldung "Ungültiger Spaltenname" treten auf, wenn Sie eine verknüpfte Serverabfrage zu einer anderen Instance von SQL Server 2008 ausführen
561742 2379466 UPDATE: Fehlercode "0x84B10001", Fehler beim SQL Server 2008 Setup und eine unbehandelte Ausnahme treten auf, wenn Sie SQL Server 2008 Setup ausführen
561797 2380361 FIX: Fehlermeldung beim Ausführen der gespeicherten Prozedur "sp_createstats" in SQL Server 2008 oder in SQL Server 2008 R2, wenn die Tabelle eine nicht deterministische berechnete Spalte enthält
561799 2380435 FIX: Der Abfrageplan für eine gespeicherte Prozedur wird nicht zwischengespeichert, wenn die gespeicherte Prozedur eine BLOB-Variable verwendet und die Variable in einer Zeichenfolgenfunktion in Microsoft SQL Server 2008 oder in Microsoft SQL Server 2008 R2 verwendet wird
561803 2384766 FIX: Die ANSI_NULLS Eigenschaft einer indizierten Sicht wird in FALSE geändert, nachdem die indizierte Sicht in die Abonnementdatenbank in SQL Server 2008 oder SQL Server 2008 R2 repliziert wurde
561805 2387686 FIX: BEIM VERSUCH, SQL Server 2008 oder SQL Server 2008 R2 zu installieren, wird die Fehlermeldung "Ein MOF-Syntaxfehler ist aufgetreten" wird
561813 2399715 FIX: Eine "UPDATE CUBE"-Anweisung gibt eine falsche Fehlermeldung zurück, wenn Sie versuchen, ein berechnetes Measure oder ein berechnetes Element in SSAS 2008 zu aktualisieren
561811 2407172 FIX: Eine Ausnahme tritt auf, bevor die Fehlerausgabe für ungültige Daten einer Aufgabe "XML-Quelle" in SSIS 2005 oder SSIS 2008 umgeleitet wird

Informationen zum kumulativen Updatepaket

Voraussetzungen

Microsoft SQL Server 2008 Service Pack 2
Weitere Informationen finden Sie im folgenden Artikel der Microsoft Knowledge Base:

968382 So erhalten Sie das neueste Service Pack für SQL Server 2008

Informationen zum Neustart

  Sie müssen den Computer nach der Installation dieses kumulativen Updatepakets unter Umständen neu starten.

Registrierungsinformationen

  Sie müssen keine Änderungen an der Registrierung vornehmen, um die Hotfixes aus dem Paket verwenden zu können.

Referenzmaterial

  Weitere Informationen zum inkrementellen Wartungsmodell für SQL Server finden Sie im folgenden Artikel der Microsoft Knowledge Base:

935897
  Zur Bereitstellung von Hotfixes für gemeldete Probleme ist ein inkrementelles Wartungsmodell vom SQL Server-Team verfügbar

  Weitere Informationen zum Benennungsschema für SQL Server-Updates finden Sie im folgenden Artikel der Microsoft Knowledge Base:

822499
  Neues Benennungsschema für Softwareupdatepakete für Microsoft SQL Server
   Weitere Informationen zur Terminologie für Softwareupdates von Microsoft finden Sie im folgenden Artikel der Microsoft Knowledge Base:

824684
  Erläuterung von Standardbegriffen bei Microsoft-Softwareupdates