In diesem Artikel werden Verbesserungen für die Fehlerberichterstattung in Microsoft SQL Server 2014 Service Pack 1 (SP1) beschrieben, wenn Sie die neue Featurepufferpoolerweiterung in Microsoft SQL Server 2014 verwenden.
Weitere Informationen
Wenn Sie das Pufferpoolerweiterungsfeature in SQL Server 2014 aktivieren, treten möglicherweise die folgenden bekannten Probleme auf:
Sie aktivieren das Pufferpoolerweiterungsfeature, dessen Größe kleiner, aber fast viermal so groß ist wie die maximale Serverspeichergröße in SQL Server 2014 Standard Edition. Beispielsweise beträgt die maximale Größe des Serverarbeitsspeichers 28 Gigabyte (GB), und die Größe der Pufferpoolerweiterung beträgt 109 GB. Wenn Sie versuchen, den SQL Server-Dienst neu zu starten, kann SQL Server nicht gestartet werden, und die folgende Fehlermeldung wird im SQL Server-Fehlerprotokoll angezeigt:
Hinweis
< Datum><Zeit> Die CLR-Funktionalität (Common Language Runtime) des Servers, die mit der CLR-Version v4.0.30319 < aus dem Datenträgernamen>:\Windows\Microsoft.NET\Framework64\v4.0.30319\ initialisiert wurde.
< Datum><Zeit> spid8s Es wird versucht, 14299819 BUF für die Pufferpoolerweiterung für maximal 12989098 Seitendeskriptoren zuzuweisen.
< Datum><Zeit> spid8s Fehler: 864, Schweregrad: 16, Zustand: 1.
< Datum><Zeit> spid8s Es wird versucht, 14299819 BUF für die Pufferpoolerweiterung für maximal 12989098 Seitendeskriptoren zuzuweisen.Nachdem SQL Server 2014 Service Pack 1 (SP1) angewendet wurde, kann SQL Server ohne dieses Problem neu gestartet werden.
Sie aktivieren das Pufferpoolerweiterungsfeature und konfigurieren dann die maximale Größe des Serverspeichers so, dass sie größer ist als die zuvor definierte Dateigröße der Pufferpoolerweiterung (entwurfsbedingt muss die Größe der Pufferpoolerweiterung größer als die maximale Größe des Serverspeichers sein). Die Konfiguration ist erfolgreich, und die Pufferpoolerweiterung funktioniert ordnungsgemäß. Die Pufferpoolerweiterung wird jedoch deaktiviert, nachdem Sie den SQL Server-Dienst neu gestartet haben, und die folgende Fehlermeldung wird im SQL Server-Fehlerprotokoll angezeigt:
Hinweis
< Datum><Zeit> Die Größe der Serverpufferpoolerweiterung muss größer sein als die Größe < des physischen Arbeitsspeichers in maximal angegebenem Serverspeicher> in MB. Die Pufferpoolerweiterung ist nicht aktiviert.
Nach der Installation von SQL Server 2014 SP1 erhalten Sie zusätzlich zu der Meldung im SQL-Fehlerprotokoll auch die folgende Warnmeldung in SQL Server Management Studio (SSMS):
Hinweis
Maximaler angegebener Serverarbeitsspeicher – <XXX> MB ist größer als die Dateigröße der Pufferpoolerweiterung – <XXX> MB. Die Pufferpoolerweiterung wird beim Neustart deaktiviert.
Wenn Sie eine Pufferpoolerweiterungsdatei auf dem Datenträger erstellen, auf dem nicht genügend Speicherplatz vorhanden ist (z. B. wenn die maximale Serverspeichergröße 28 GB und die Größe der Pufferpoolerweiterung 120 GB beträgt), wird im SQL Server-Fehlerprotokoll die folgende mehrdeutige Betriebssystemfehlermeldung angezeigt:
Hinweis
< Datum><Zeit> spid52 CREATE FILE Encountered operating system error (Datei erstellen) Fehler beim Ändern der Dateigröße beim Versuch, die physische Datei '<File Path>. BPE".
Nach der Installation von SQL Server 2014 SP1 erhalten Sie die folgende eindeutige Fehlermeldung:
Hinweis
Betriebssystemfehler (Es ist nicht genügend Speicherplatz auf der Festplatte vorhanden)
Wenn Sie eine sehr große Pufferpoolerweiterungsdatei konfigurieren, wird die folgende Fehlermeldung angezeigt, deren tatsächliche Bedeutung nicht beschrieben werden kann:
Hinweis
Meldung 864, Ebene 16, Status 1, Zeile 1
Es wird versucht, 25600 BUF für die Pufferpoolerweiterung für maximal 12800 Seitendeskriptoren zuzuweisen.Nachdem SQL Server 2014 SP1 angewendet wurde, ändert sich die Fehlermeldung wie folgt:
Hinweis
Es wurde versucht, die Pufferpoolerweiterung der Größe <XXX> KB zu initialisieren, aber die maximal zulässige Größe ist <XXX> KB
Wenn die Erstellung einer SSD-Erweiterungsdatei aufgrund eines Fehlers fehlschlägt (z. B. weil das angegebene Verzeichnis nicht vorhanden ist), druckt SQL Server die folgende Fehlermeldung:
Hinweis
Fehler beim Erstellen einer Pufferpoolerweiterung der Größe <XXX> MB auf dem Pfad ""
Der Pfad in der Fehlermeldung wird nicht gedruckt.
Nachdem SQL Server 2014 SP1 angewendet wurde, wird der Pfad korrekt gedruckt, wenn die Erstellung der SSD-Datei fehlschlägt.
Informationen zum Service Pack
Das Service Pack 1 für SQL Server 2014 können Sie unter folgendem Link beziehen:
Weitere Informationen zu SQL Server 2014 Service Pack 1 (SP1) finden Sie unter In SQL Server 2014 Service Pack 1 behobene Fehler.
Status
Microsoft hat bestätigt, dass dies ein Problem bei den Microsoft-Produkten ist, die im Abschnitt „Gilt für“ aufgeführt sind.