Symptome
Angenommen, Sie aktivieren die Option "AutoSchließen" für Ihre Datenbank in Microsoft SQL Server 2014. Wenn die Datenbank heruntergefahren wird, kann in der E/A-Abschlussroutine ein Zugriffsverletzungsfehler auftreten, und eine Speicherabbilddatei wird generiert. Nachdem die Ausnahme aufgetreten ist, kann eine der verschiedenen sekundären Protokollversanddatenbanken keine weiteren Wiederherstellungen mehr durchführen. Die betroffene Datenbank ist nicht immer dieselbe.
Ursache
Dieses Problem tritt aufgrund einer Racebedingung zwischen dem Log Writer-Thread und einem anderen Thread auf, der die Datenbank schließt.
Lösung
Informationen zum Service Pack
Installieren Sie Service Pack 1 für SQL Server 2014, um dieses Problem zu beheben.
Weitere Informationen zu SQL Server 2014 Service Pack 1 (SP1) finden Sie unter In SQL Server 2014 Service Pack 1 behobene Fehler.
Status
Microsoft hat bestätigt, dass dies ein Problem bei den Microsoft-Produkten ist, die im Abschnitt „Gilt für“ aufgeführt sind.