Symptome
Sie erstellen einen Datenbankverschlüsselungsschlüssel (Database Encryption Key, DEK) mit mehr als 3.456 Bit auf einer Instance von Microsoft SQL Server 2016 oder 2017. Wenn Sie Transparent Database Encryption (TDE) mit diesem DEK aktivieren, wird im SQL Server-Fehlerprotokoll ein Fehlereintrag protokolliert, der dem Folgenden ähnelt:
Hinweis
Datum Uhrzeit SPID Festlegen der Datenbankoption ENCRYPTION auf EIN für die Datenbank 'database_name'. Datum Uhrzeit SPID Der Scan der Datenbankverschlüsselung für die Datenbank "Datenbankname" wird gestartet. Datum Uhrzeit SPID Datenbankverschlüsselungsüberprüfung für Datenbank wurde abgebrochen. Geben Sie ALTER DB erneut aus, um den Scan fortzusetzen.
Ursache
Dieses Problem tritt auf, weil SQL Server keine Fehlermeldung ausgibt, die angibt, dass ein DEK mit einer Länge von mehr als 3.456 Bit nicht unterstützt wird.
Lösung
Dieses Problem wird durch die folgenden Updates für SQL Server behoben:
Kumulatives Update 13 für SQL Server 2017
Kumulatives Update 5 für SQL Server 2016 Service Pack 2
Kumulatives Update 11 für SQL Server 2016 Service Pack 1
Hinweis Nachdem Sie diesen Fix angewendet und dann versucht haben, ein DEK zu erstellen, das länger als 3.456 Bit ist, ist der Versuch nicht erfolgreich, und Sie erhalten die folgende Fehlermeldung:
Hinweis
Meldung 33178, Ebene 16, Status 2, Line LineNumber
Die Länge des Verschlüsselungsschlüssels überschreitet die derzeit unterstützte maximale Länge von 3456.
Informationen zu SQL Server-Builds
Jeder neue Build für SQL Server enthält alle Hotfixes und Sicherheitsfixes, die im vorherigen Build enthalten waren. Es wird empfohlen, den neuesten Build für Ihre Version von SQL Server zu installieren:
Neuestes kumulative Update für SQL Server 2017
Neuester Build für SQL Server 2016
Status
Microsoft hat bestätigt, dass dies ein Problem bei den Microsoft-Produkten ist, die im Abschnitt „Gilt für“ aufgeführt sind.
Referenzmaterial
Erfahren Sie mehr über die Terminologie , die Microsoft zum Beschreiben von Softwareupdates verwendet.