Symptoms
In a hybrid Exchange Server environment, remote mailboxes are not shown when you try to configure email forwarding for a mailbox in Exchange admin center (EAC).
Cause
The filter that's used for searching the remote mailboxes is missing RemoteUserMailbox under RecipientTypeDetails.
Resolution
To fix this issue, install one of the following updates:
For Exchange Server 2019, install the Cumulative Update 7 for Exchange Server 2019 or a later cumulative update for Exchange Server 2019. For Exchange Server 2016, install the Cumulative Update 18 for Exchange Server 2016 or a later cumulative update for Exchange Server 2016.
References
Learn about the terminology that Microsoft uses to describe software updates.